locked
Send to Repository RRS feed

  • Question

  • I am creating a very simple SPD workflow--sending a document to a Repository; before, I did it for another site collection and had no problems with finding the "destination route" as a Repository.

    For some reasons, even though, I have a Records Center created as a sub-site, I cannot find the Repository as one of the possible receivers.

    What am I missing?

    Thanks

    Friday, June 7, 2013 8:05 PM

Answers

  • There is no option as "Repositaries" in the Lookup for destination. This is a custom list of library that has been created in your site. The name itself is spelled wrong for being a SharePoint out of box Data Source.

    Regards, Kapil ***Please mark answer as Helpful or Answered after consideration***

    • Marked as answer by Oleg O Thursday, June 13, 2013 3:11 PM
    Wednesday, June 12, 2013 8:47 PM

All replies

  • Please refer to this thread, it discusses the same thing. Make sure the step in workflow points to asmx web service link to the sub site where Content Organizer feature has been activated.

    http://social.msdn.microsoft.com/Forums/en-US/sharepointcustomizationprevious/thread/3c88bf1f-9ceb-4790-849c-ad3bfcfd7d06

    Regards, Kapil ***Please mark answer as Helpful or Answered after consideration***

    Friday, June 7, 2013 8:47 PM
  • Please refer to this thread, it discusses the same thing. Make sure the step in workflow points to asmx web service link to the sub site where Content Organizer feature has been activated.

    http://social.msdn.microsoft.com/Forums/en-US/sharepointcustomizationprevious/thread/3c88bf1f-9ceb-4790-849c-ad3bfcfd7d06

    Regards, Kapil ***Please mark answer as Helpful or Answered after consideration***

    That was not exactly the question--the question was why the Repository was not one of the choices within the workflow receivers.

    Thanks

    Monday, June 10, 2013 3:18 PM
  • Hi,

    How do you set the destination router?

    The 'Send Document to Repository' is used to send document to record center. You need to set the destination router to a URL like this http://recordcenterurl/_vti_bin/officialfile.asmx.

    If I have any misunderstanding, please feel free to point it out.

    Thanks,

    Entan Ming


    Entan Ming
    TechNet Community Support

    Tuesday, June 11, 2013 9:37 AM
  • Hi,

    How do you set the destination router?

    The 'Send Document to Repository' is used to send document to record center. You need to set the destination router to a URL like this http://recordcenterurl/_vti_bin/officialfile.asmx.

    If I have any misunderstanding, please feel free to point it out.

    Thanks,

    Entan Ming


    Entan Ming
    TechNet Community Support

    Here is what I see in the old workflow:

    Compare to the new one:

    As you can see the old one has Repositories property while in the new one does not have it, even though, in both of them Records Centers were created as sub-sites. That means that I didn't have to use the "officialfile.asmx" for the Url--it was just the Repositories' Url.

    Wednesday, June 12, 2013 8:24 PM
  • There is no option as "Repositaries" in the Lookup for destination. This is a custom list of library that has been created in your site. The name itself is spelled wrong for being a SharePoint out of box Data Source.

    Regards, Kapil ***Please mark answer as Helpful or Answered after consideration***

    • Marked as answer by Oleg O Thursday, June 13, 2013 3:11 PM
    Wednesday, June 12, 2013 8:47 PM