none
RDP does not work

    Question

  • Hello,

     one of our Hyper-V server does not respond to remote desktop,

    the server is Microsoft Hyper-V Server 2012R2, and management network has been configured as NIC teaming, Firewall for all profiles is off, I am able to telnet to 3389 on localhost, Netstat -a shows it is listening to 3389, everything seems ok on the server.

    but I cannot RDP to the server!!! even it does not respond to 3389 telnet from out side.

    can someone please help me?

    Thanks in advance

    Bahram

    Tuesday, April 11, 2017 3:23 PM

Answers

  • Can you ping it? An unedited ipconfig /all of source and target might help.

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    • Marked as answer by Maleki_bahram Tuesday, April 25, 2017 11:03 PM
    Tuesday, April 11, 2017 3:28 PM
  • Then the latter; An unedited ipconfig /all of source and target might help. Also try to RDP the ip address to rule out name resolution issues.

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.


    Tuesday, April 11, 2017 3:34 PM
  • Hello Maleki_bahram,

    One thing you may want to check is the port number for RDP as set in the registry. Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp and look for the DWORD (32-bit) Value. Ensure that it is set to 3389 (Decimal) or d3d (Hexadecimal).

    Thanks,
    Christopher H.

    • Marked as answer by Maleki_bahram Tuesday, April 25, 2017 11:03 PM
    Tuesday, April 11, 2017 4:16 PM
  • Hi Sir,

    >>the server is Microsoft Hyper-V Server 2012R2,

    >> I am able to telnet to 3389 on localhost

    >> even it does not respond to 3389 telnet from out side.

     


    The client can telnet to 3389 port but RDP client can not connect to that server over port 3389 ?

    Even there is no user credential prompt for you?

    Have you tried to connect to that server use its IP address directly  ?

    Also please post the screenshot for connection failed information of mstsc . 

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Wednesday, April 12, 2017 9:59 AM
    Moderator
  • Hi Sir,

    >>I can Telnet to 3389 on the server but from out side I cannot telnet.

    Do you mean the server can telnet itself , but other computers can not telnet it  (Using IP address) successfully ?

    If it is the case , I'd suggest you try to telnet other listening port of that server to see if it works .

    Also , I'd suggest you use netmon.exe to capture packets to see what happened between "client" and "server".

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Maleki_bahram Tuesday, April 25, 2017 11:03 PM
    Sunday, April 23, 2017 9:44 AM
    Moderator
  • Telnet and RDP are two completely separate protocols and are configured differently.  The fact that you can telnet does tell us that you at least have network connectivity between the two systems, but it does not tell us that you have properly configured the RDP client role.  You must ensure that the Remote Desktop access has been enabled on the target system.  

    tim

    • Marked as answer by Maleki_bahram Tuesday, April 25, 2017 11:03 PM
    Monday, April 24, 2017 2:16 PM
  • Please provide the commands you used to 'enable' it on the target server.

    If you use the same commands on any other server to enable RDP, does that server respond properly?  In other words, since you started experiencing this problem, have you tried replicating it on another server?


    tim

    • Marked as answer by Maleki_bahram Tuesday, April 25, 2017 11:03 PM
    Tuesday, April 25, 2017 1:08 PM
  • Might also check the settings here and users have been added.

     

     

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    • Marked as answer by Maleki_bahram Tuesday, April 25, 2017 11:04 PM
    Tuesday, April 25, 2017 2:52 PM
  • I'd try another to see if you can replicate. Also seems forums suggestions have been exhausted so I'd probably call it in to product support.

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    • Marked as answer by Maleki_bahram Tuesday, April 25, 2017 11:04 PM
    Tuesday, April 25, 2017 6:06 PM
  • Guys,

    you cannot believe me, I just installed netmon_64.exe and it fixed.

    BTW, thank for your help and support.

    regards

    • Marked as answer by Maleki_bahram Tuesday, April 25, 2017 11:03 PM
    Tuesday, April 25, 2017 11:03 PM

All replies

  • Can you ping it? An unedited ipconfig /all of source and target might help.

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    • Marked as answer by Maleki_bahram Tuesday, April 25, 2017 11:03 PM
    Tuesday, April 11, 2017 3:28 PM
  • Hello Dave, Yes I can ping it.

    thanks

    Tuesday, April 11, 2017 3:32 PM
  • Then the latter; An unedited ipconfig /all of source and target might help. Also try to RDP the ip address to rule out name resolution issues.

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.


    Tuesday, April 11, 2017 3:34 PM
  • Tried with IP as well but did not work.
    Tuesday, April 11, 2017 3:59 PM
  • Hello Maleki_bahram,

    One thing you may want to check is the port number for RDP as set in the registry. Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp and look for the DWORD (32-bit) Value. Ensure that it is set to 3389 (Decimal) or d3d (Hexadecimal).

    Thanks,
    Christopher H.

    • Marked as answer by Maleki_bahram Tuesday, April 25, 2017 11:03 PM
    Tuesday, April 11, 2017 4:16 PM
  • Checked and it is set to 3389!

    Tuesday, April 11, 2017 4:21 PM
  • Hi Sir,

    >>the server is Microsoft Hyper-V Server 2012R2,

    >> I am able to telnet to 3389 on localhost

    >> even it does not respond to 3389 telnet from out side.

     


    The client can telnet to 3389 port but RDP client can not connect to that server over port 3389 ?

    Even there is no user credential prompt for you?

    Have you tried to connect to that server use its IP address directly  ?

    Also please post the screenshot for connection failed information of mstsc . 

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Wednesday, April 12, 2017 9:59 AM
    Moderator
  • You still have not provided the ipconfig /all of the client and target that Dave requested.

    It might seem obvious, but have you ensured that you have enabled RDS on the target?  It is disabled by default.


    tim

    Wednesday, April 12, 2017 1:27 PM
  • Hello Elton,

    I can Telnet to 3389 on the server but from out side I cannot telnet.

    here is the screenshot:

    thanks

    Wednesday, April 12, 2017 1:56 PM
  • RDP is not telnet.  Please let us know if you are trying to telnet or RDP to the system.  Have you enabled the proper client?

    tim

    Wednesday, April 12, 2017 2:00 PM
  • Hello Tim,

    yes I have enabled RDS on the server and it is listening to 3389 (Ran netstat -a).

    here is the ipconfig /all:

    Wednesday, April 12, 2017 2:04 PM
  • Hi Sir,

    >>I can Telnet to 3389 on the server but from out side I cannot telnet.

    Do you mean the server can telnet itself , but other computers can not telnet it  (Using IP address) successfully ?

    If it is the case , I'd suggest you try to telnet other listening port of that server to see if it works .

    Also , I'd suggest you use netmon.exe to capture packets to see what happened between "client" and "server".

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by Maleki_bahram Tuesday, April 25, 2017 11:03 PM
    Sunday, April 23, 2017 9:44 AM
    Moderator
  • Yes Elton, the server can telnet itself, also I am able to telnet to the other ports from anywhere.

    thanks

    Monday, April 24, 2017 2:10 PM
  • Telnet and RDP are two completely separate protocols and are configured differently.  The fact that you can telnet does tell us that you at least have network connectivity between the two systems, but it does not tell us that you have properly configured the RDP client role.  You must ensure that the Remote Desktop access has been enabled on the target system.  

    tim

    • Marked as answer by Maleki_bahram Tuesday, April 25, 2017 11:03 PM
    Monday, April 24, 2017 2:16 PM
  • Hello Tim,

    I double checked registry and it is enabled on the target server.

    regards

    Monday, April 24, 2017 2:33 PM
  • Please provide the commands you used to 'enable' it on the target server.

    If you use the same commands on any other server to enable RDP, does that server respond properly?  In other words, since you started experiencing this problem, have you tried replicating it on another server?


    tim

    • Marked as answer by Maleki_bahram Tuesday, April 25, 2017 11:03 PM
    Tuesday, April 25, 2017 1:08 PM
  • Tim,

    I ran the following command to enable RDP:

    cscript scregedit.wsf /AR 0

    and here is the status of RDP setting on the server:

    Tuesday, April 25, 2017 2:02 PM
  • Might also check the settings here and users have been added.

     

     

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    • Marked as answer by Maleki_bahram Tuesday, April 25, 2017 11:04 PM
    Tuesday, April 25, 2017 2:52 PM
  • Dave, Checked and seems ok!
    Tuesday, April 25, 2017 5:10 PM
  • I'd try another to see if you can replicate. Also seems forums suggestions have been exhausted so I'd probably call it in to product support.

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    • Marked as answer by Maleki_bahram Tuesday, April 25, 2017 11:04 PM
    Tuesday, April 25, 2017 6:06 PM
  • Guys,

    you cannot believe me, I just installed netmon_64.exe and it fixed.

    BTW, thank for your help and support.

    regards

    • Marked as answer by Maleki_bahram Tuesday, April 25, 2017 11:03 PM
    Tuesday, April 25, 2017 11:03 PM