locked
Lync not saving conversation history RRS feed

  • Question

  • My SFB has stopped saving my conversation history in both SFB and Outlook since 04/07. It was working fine since then with no issues. My box is checked under my personal settings to save the history.  How to do with it
    Tuesday, April 17, 2018 3:06 PM

Answers

  • Hi Scort0,

    This can happen if your Skype for Business client hasn't authenticated with Exchange. this normally happens after a password change (although sometimes doesn't happen right away).

    What i'd recommend you do is delete your local Skype cache on your machine, and remove any cached credentials on the machine too from the Credential manager. to do this:

    1.  Completely exit out of Outlook and Skype for Business
    2.  Browse to: C:\Users\USERNAME\AppData\Local\Microsoft\Office\16.0\Lync
    3.  Delete the contents of this folder (it'll contain a bunch of sip_ folders)
    4.  Open the credential manager, click the Windows Credentials tab and then locate and delete any reference to MicrosoftOffice16
    5. Re-launch Outlook and Skype for Business. Sign in to Skype for Business
    6. Conversation history should now work.

    Cheers
    Craig - blog.chiffers.com

    Wednesday, April 18, 2018 3:47 AM
  • Hi,

    Is that specific user had the issue or all users had the issue?

    You can try the following way:

    Solution 1(You already tried, please try others)

    Make sure that this option is enabled in Lync client, In your Lync client, click options, go to Personal Tab and make sure “Save IM Conversation in my Email Conversation History Folder” box is checked

    Solution 2

    In your outlook, make sure that ONLY ONE Conversation History folder exist and that you didn’t accidently delete or move it.

    From Exchange side, make sure that user does not have 1000 or more folders in his mailbox using PowerShell command

    c:> (Get-mailboxfolderstatistics “mailbox”).count

    If more => 1000 item them instruct the user to delete some folders

    Please press Ctrl and right click Lync icon in the taskbar, open configuration information. On the open page check if EWS status and MAPI status are OK.


    Best Regards,
    Alice Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by scort0 Wednesday, April 18, 2018 2:51 PM
    Wednesday, April 18, 2018 2:18 AM

All replies

  • Hi,

    Is that specific user had the issue or all users had the issue?

    You can try the following way:

    Solution 1(You already tried, please try others)

    Make sure that this option is enabled in Lync client, In your Lync client, click options, go to Personal Tab and make sure “Save IM Conversation in my Email Conversation History Folder” box is checked

    Solution 2

    In your outlook, make sure that ONLY ONE Conversation History folder exist and that you didn’t accidently delete or move it.

    From Exchange side, make sure that user does not have 1000 or more folders in his mailbox using PowerShell command

    c:> (Get-mailboxfolderstatistics “mailbox”).count

    If more => 1000 item them instruct the user to delete some folders

    Please press Ctrl and right click Lync icon in the taskbar, open configuration information. On the open page check if EWS status and MAPI status are OK.


    Best Regards,
    Alice Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by scort0 Wednesday, April 18, 2018 2:51 PM
    Wednesday, April 18, 2018 2:18 AM
  • Hi Scort0,

    This can happen if your Skype for Business client hasn't authenticated with Exchange. this normally happens after a password change (although sometimes doesn't happen right away).

    What i'd recommend you do is delete your local Skype cache on your machine, and remove any cached credentials on the machine too from the Credential manager. to do this:

    1.  Completely exit out of Outlook and Skype for Business
    2.  Browse to: C:\Users\USERNAME\AppData\Local\Microsoft\Office\16.0\Lync
    3.  Delete the contents of this folder (it'll contain a bunch of sip_ folders)
    4.  Open the credential manager, click the Windows Credentials tab and then locate and delete any reference to MicrosoftOffice16
    5. Re-launch Outlook and Skype for Business. Sign in to Skype for Business
    6. Conversation history should now work.

    Cheers
    Craig - blog.chiffers.com

    Wednesday, April 18, 2018 3:47 AM
  • I have this same problem.  I have followed your instruction, but the issue persists.  I can confirm that this issue started the last time I changed my domain password.  Can you recommend any other steps?  Thanks.

    Dale
    Tuesday, July 10, 2018 6:35 PM