locked
Sending Skype IM to Offline Contact Won't Send RRS feed

  • Question

  • Hi, we have noticed that for some reason if you send an IM to someone whose status is Offline you instantly get that generic Skype message that the message was not sent nor does the recipient receive it as a missed chat in their conversation history. Seems to be widespread. 
    Wednesday, January 23, 2019 9:10 PM

Answers

  • This has fixed this issue: Disable Teams Interoperability in the client policy, here is the command where "websearch" is the name of the client policy:

    $a = New-CsClientPolicyEntry -Name "EnableTeamsInteropEscalation" -Value "False"​ 

    Set-CsClientPolicy -Identity "WebSearch" -PolicyEntry @{Add=$a}​

    • Marked as answer by ÁNLEIFR Monday, February 11, 2019 2:42 PM
    Monday, February 11, 2019 2:42 PM

All replies

  • Hey,

    what kind of Skype for Business installation do you use? 
    Office365 version or basic MSI installation?

    The Offline IM functionality is not available in the basic MSI SfB Client installation. You need the O365 version of SfB 2016 for this feature. (I do not know how it is with SfB 2019 MSI, but I think it is the same)

    We ran into the same issue. Even after a lot of upgrades, the MSI client is still not capable of this feature. We changed all the appropriate Server configurations but it did not work. Straight after installing the O365 version it directly worked. (It is the same as with the consultant transfer function. MSI Installation --> No | O365 --> yes)

    You should see a message in the chat window when you try to chat with someone who is offline. 
    It will say, that the account is not online but you can send an offline message and the other party will receive it as a missed conversation in the mailbox.

    I hope this clarifies things for you.

    Greets,
    Markus

    Wednesday, January 23, 2019 9:52 PM
  • Thank you. The function used to work and still does for some people. 
    Wednesday, January 23, 2019 10:33 PM
  • Hi,

    Please Run the command “Get-CsImConfiguration” as Admin in SFB Mgmt shell to confirm the ability to store Offline IM's is set.

    If the EnableOfflineIm is false, please run “Set-CsImConfiguration -EnableOfflineIM $True” to enable Offline IM.

    Also, as Markus mentioned, Offline IM is a client side feature built into the SFB client which includes in O365 package, please make sure the users have installed the Skype for Business client (2016 C2R build 16.0.6701.1000 or higher) in your company.

    Here you will find more details: https://docs.microsoft.com/en-us/skypeforbusiness/deploy/im-and-presence/enable-or-disable-offline-im

    By the way, please kindly note that offline IM uses Exchange Web Services (EWS) to send Offline messages from the Skype for Business client to the mailbox of recipient. So please make sure Exchange is well integrated with SFB server in your organization to confirm the EWS status is ok to realize this feature.

    Kind regards,

    Calvin Liu


    Please remember to mark the reply as an answer if you find it is helpful. It will assist others who has similar issue. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.


    • Edited by Calvin-Liu Thursday, January 24, 2019 9:50 AM
    • Proposed as answer by Calvin-Liu Monday, January 28, 2019 10:12 AM
    Thursday, January 24, 2019 9:44 AM
  • Hi,

    Are there any update for this issue? If the reply is helpful to you, please try to mark it as an answer, this will make answer searching in the forum easier and be beneficial to other community members as well. :)

    Kind regards, 

    Calvin Liu


    Please remember to mark the reply as an answer if you find it is helpful. It will assist others who has similar issue. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to shareexplore and talk to experts about Microsoft Teams.


    Monday, January 28, 2019 10:27 AM
  • Hi thank you. No it is not resolved yet. I ran the command and it is enabled and we are also using the latest Skype client. 
    Monday, January 28, 2019 3:42 PM
  • Hi,

    Would you please let us know if you have checked the EWS and MAPI status yet?

    Please hold on Ctrl key and right click Skype for Business icon in the taskbar, click configuration information feature. On the open page check if MAPI status is OK.

    If the status shows a “MAPI unavailable”, please refer to this guide to resolve accordingly: https://support.microsoft.com/en-us/help/3147130/mapi-unavailable-error-in-skype-for-business-2016-client

    And if the EWS internal or external URL is unavailable, please make sure you have configured the Exchange CAS Server Certificates including all SAN Names for all SMTP and SIP domains.

    Just to make sure you have an Autodiscover.domain.com A record pointing to your Exchange CAS(s), and that your EWS internal and external urls are configured correctly.

    Reference:

    http://www.uclabs.blog/2013/01/lync-and-exchange-web-services-ews-and.html

    https://social.technet.microsoft.com/Forums/ie/en-US/f2e382aa-9e3b-49e6-a8ef-058baf895015/skype-for-business-ews-unavailable-retrying?forum=lyncprofile

    Kind regards,

    Calvin Liu


    Please remember to mark the reply as an answer if you find it is helpful. It will assist others who has similar issue. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Proposed as answer by Calvin-Liu Friday, February 1, 2019 9:36 AM
    Friday, February 1, 2019 9:35 AM
  • This has fixed this issue: Disable Teams Interoperability in the client policy, here is the command where "websearch" is the name of the client policy:

    $a = New-CsClientPolicyEntry -Name "EnableTeamsInteropEscalation" -Value "False"​ 

    Set-CsClientPolicy -Identity "WebSearch" -PolicyEntry @{Add=$a}​

    • Marked as answer by ÁNLEIFR Monday, February 11, 2019 2:42 PM
    Monday, February 11, 2019 2:42 PM
  • Oh, thanks for sharing.

    It seems that the command that disabling Teams interoperability not only resolves the client Group issue but also sending offline IM of this one!

    Kind regards,

    Calvin Liu


    Please remember to mark the reply as an answer if you find it is helpful. It will assist others who has similar issue. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, February 12, 2019 1:38 AM
  • Yes it does, apparently this was in the code in the most recent update of the Skype for Business client and that is why these things broke. 
    • Edited by ÁNLEIFR Wednesday, February 13, 2019 3:36 PM
    Wednesday, February 13, 2019 3:36 PM