locked
MDT 2013 Update 2 Activate Office 2016 RRS feed

  • Question

  • I have installed Office 2016 into reference image and added a command line in my TS to activate Office 2016

    Command line: 

    cscript.exe C:\Program Files\Microsoft Office\Office16\ospp.vbs /act

    Start in:

    C:\Program Files\Microsoft Office\Office16

    TS failes immediately. I have ran this exact command line before in MDT 2012 but for some reason not able to work in this current version.

    Any ideas or better ways to activate office 2016?

    Thank you!

    Tuesday, September 27, 2016 3:15 PM

Answers

  • oh and yes I don't feel that you need the

    Start in:

    C:\Program Files\Microsoft Office\Office16


    If this post is helpful please click "Mark for answer", thanks! Kind regards

    Tuesday, September 27, 2016 4:48 PM
  • All is good!

    Final command line: cscript.exe "c:\program files\microsoft office\office16\ospp.vbs" /act

    This is for 64-bit office

    Nothing under Start in:

    Activated as it should. Opened up office and no popups! Thank you for your help.

    • Proposed as answer by Massivesystem Tuesday, September 27, 2016 6:07 PM
    • Unproposed as answer by Massivesystem Tuesday, September 27, 2016 6:07 PM
    • Marked as answer by Prince Ali Ababwa Wednesday, September 28, 2016 1:17 PM
    Tuesday, September 27, 2016 5:15 PM

All replies

  • Do you have a KMS server onsite? And did you use the Office Customization Tool (OCT) after adding Office 2016 to the MDT application node?

    If this post is helpful please click "Mark for answer", thanks! Kind regards


    Tuesday, September 27, 2016 3:16 PM
  • No, not at the moment. We are using MAK keys....

    Tuesday, September 27, 2016 3:17 PM
  • Did you include the MAK key in the .msp created by OCT

    If this post is helpful please click "Mark for answer", thanks! Kind regards

    Tuesday, September 27, 2016 3:23 PM
  • Yes, I sure did. But instead of installing as a post application, I decided to bake it into the reference image. I re-armed it before sysprep. I am trying to activate it as the final step as I dont want the user to see the activation box.
    Tuesday, September 27, 2016 3:24 PM
  • And you have all these covered

    Prior to running ospp.vbs ensure that:

    • Windows firewall allows WMI traffic on remote computer.
    • You have or pass credentials with required permissions on computer.
    • Cmd.exe is elevated (Run as administrator)

    Also have you utilized the other /switch options to verify

    /dstatus Display license information for installed product keys.
    /dstatusall Display license information for installed licenses.
    /dhistoryacterr Display MAK/Retail activation failure history


    If this post is helpful please click "Mark for answer", thanks! Kind regards


    Tuesday, September 27, 2016 3:38 PM
  • It is a standard task sequence and I assume it runs as an elevated command.

    Placing the key and activating Windows 10 works but Office... No dice.. Like I said, I have done this previously so I dont know if its a bug or not in MDT 2013 Update 2. 

    Tuesday, September 27, 2016 4:20 PM
  • Have you ran cscript.exe C:\Program Files\Microsoft Office\Office16\ospp.vbs /act from a elevated CMD prompt within Windows to see what the outcome is?

    If this post is helpful please click "Mark for answer", thanks! Kind regards

    Tuesday, September 27, 2016 4:37 PM
  • Yes, I JUST tried that and it activated successfully. I'm going to delete the parameters under start in section and re-run my image. Will let you know shortly.
    Tuesday, September 27, 2016 4:40 PM
  • oh and yes I don't feel that you need the

    Start in:

    C:\Program Files\Microsoft Office\Office16


    If this post is helpful please click "Mark for answer", thanks! Kind regards

    Tuesday, September 27, 2016 4:48 PM
  • All is good!

    Final command line: cscript.exe "c:\program files\microsoft office\office16\ospp.vbs" /act

    This is for 64-bit office

    Nothing under Start in:

    Activated as it should. Opened up office and no popups! Thank you for your help.

    • Proposed as answer by Massivesystem Tuesday, September 27, 2016 6:07 PM
    • Unproposed as answer by Massivesystem Tuesday, September 27, 2016 6:07 PM
    • Marked as answer by Prince Ali Ababwa Wednesday, September 28, 2016 1:17 PM
    Tuesday, September 27, 2016 5:15 PM