none
Can't edit the Task Mode RRS feed

  • Question

  • This is MSP2010 with the April 2013 CU. Not connected to Project Server in this exercise, however the project server settings are set to Manual Mode and the setting to allow user override is also set to yes.

    I have set the default to Manual Schedule for new tasks within the file. They do get created in manual mode. However once I change them to Auto-Schedule, I can no longer switch them back to Manual.

    Is there another setting that I need to change?

    Wednesday, June 19, 2013 4:22 PM

Answers

  • Jan,

    I had the same issue (twice) and on advice of some folks from Microsoft edited the registry.  Worked a charm!  Below are the steps:

    1. Start the Registry Editor (I don’t know what OS you’re using or how you have it configured so I can’t say how you’ll find and start it).

    2. Go to HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\MS Project

    3. Rename the “MS Project” to something else.

    4. Start Project. 

    5. Test your issue.  If the problem is gone, then there was a registry setting that was suppressing the functionality you wanted.

    CAUTION - Registry edits are not for the faint of heart.  First back up the registry using the registry editor and proceed at your own risk.

    • Marked as answer by Quized again Thursday, June 20, 2013 2:46 PM
    Thursday, June 20, 2013 1:49 PM
    Moderator

All replies

  • Its a toggle option, task could be changed either ways. Does your file have any macro? Could you elaborate further so that we could understand what may be preventing this change.

    Trying checking through - I guess you have already tried this - from task tab, second from below in status bar also you have option to change; thirdly, select all tasks right click open Task Information and try to change mode there. I saw strange behaviors some time when I have constrains it prevent changing mode from status bar option but let me change through first and third option. Let us know if this helps.


    Sapna Shukla

    Wednesday, June 19, 2013 5:26 PM
    Moderator
  • Hi,

    I still have that problem in the version in this account here. There is some sort of incompatibility between windows and Project 2010 - only few people suffer from it (like you and me). Can you create a new windows account in that computer and run Project from that new account? Normally your woes will be over. Working on Project absolutely doesn't help.

    Note that you probably cannot insert projecs into a master project either :-(

    Greetings,

    Wednesday, June 19, 2013 7:54 PM
    Moderator
  • I am not clear on your suggestions but let me try:

    The option to change how new tasks are scheduled using the lower left icon in the status bar (?) shows that new tasks are set to auto Scheduled. However when I click on that item the ability to change to manual scheduled is greyed out and cannot be selected.

    On the right side of the status bar, flipping through the views does not change the situation. The task mode cannot be changed in any of the views containing the Task Mode column.

    Using task information, the option to change to manually scheduled is greyed out.

    There are no constraints in the file.

    The file was originally a MSP2007 file. It has been saved in MSP2010 and saved-as from that 2010 file to another 2010 file.

    This behavior is being reported in files that 2007 files and the user has MSP2010 Std - never touched MSP Server 2007 or 2010.

    This is also happening in new MSP2010 files. As long as the option to use Manual Scheduling is set in the file, the user can change the mode using the File > Scheduling option or the little icon in the task bar to change to Auto. Also the user can change any manually scheduled task to Auto in the views. However once ANY task is changed to auto, nobody can change them back. This occurs in MSP2007 files converted to MSP2010 and Native MSP2010 files.

    Any ideas? Anybody see this in their files?

    Wednesday, June 19, 2013 8:04 PM
  • Jan,

    I had the same issue (twice) and on advice of some folks from Microsoft edited the registry.  Worked a charm!  Below are the steps:

    1. Start the Registry Editor (I don’t know what OS you’re using or how you have it configured so I can’t say how you’ll find and start it).

    2. Go to HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\MS Project

    3. Rename the “MS Project” to something else.

    4. Start Project. 

    5. Test your issue.  If the problem is gone, then there was a registry setting that was suppressing the functionality you wanted.

    CAUTION - Registry edits are not for the faint of heart.  First back up the registry using the registry editor and proceed at your own risk.

    • Marked as answer by Quized again Thursday, June 20, 2013 2:46 PM
    Thursday, June 20, 2013 1:49 PM
    Moderator
  • Hi Julie,

    I'm a bit faint of heart :-( so I tried a new account and that worked as well.

    Greetings,

    Thursday, June 20, 2013 1:55 PM
    Moderator
  • I did the first time, Jan.  But the second time I was tired of having to move all the documents from one account to another.
    Thursday, June 20, 2013 2:03 PM
    Moderator
  • Julie this worked perfectly! Thank you!
    • Edited by Quized again Thursday, June 20, 2013 2:47 PM mispelled name
    Thursday, June 20, 2013 2:47 PM
  • Great.  Glad to know it worked for you and thank you for the feedback.

    Julie

    Thursday, June 20, 2013 4:15 PM
    Moderator