none
Issue in executing PostInstall Script for FSIS RRS feed

  • Question

  • Hi,

    I am seeing the below error while executing the Post Install script for FSIS .


    Standalone Host ESP-DEV-133 :  2010-09-02 18-17-26 Error InstallDb - Unable to find registry key for SQL Server program dir. FastSearch probably not installed

     

    Executed the below steps for Instalation:

    SQL server  (Express) installation :


    setup.exe /QUIETSIMPLE /ACTION=Install /ADDCURRENTUSERASSQLADMIN /INSTANCENAME=FASTSEARCH /FEATURES=SQL /SQLSVCACCOUNT="NT AUTHORITY\NETWORK SERVICE" /IAcceptSQLServerLicenseTerms=true

    FSIS Install :

    msiexec /i SetUp_FSIS.msi /log Installation.log

    POST Install SCRIPT :

    .\InstallConfig.ps1 -action I -espSdkDir C:\FSIS\espSDK -secureStorageDir C:\FSIS\securestoragedir -serviceAccount Administrator -createGroups -createKeys -installKeys -enableCertificateSecurity -overwriteExistingHostDirs -overwriteExistingStrongNameKeys

    All steps were executed as per the documentation. I did the install using the Administrator userid. 

    Has anyone seen this error before? Any pointers will be highly appreciated. Is there a way to add more debug statements to the post installation script, so that I get more details like the key it is referring to it, so that I can edit the same using regedit.

     

    Thanks,

    Sujith Joseph

     

    Friday, September 10, 2010 4:14 AM

Answers

All replies

  • This is issue was caused due to SQL Server 2008 Express R2. downgrading it to SQL Server 2008 Express solved it.

    Thanks,

    Sujith Joseph.

    • Proposed as answer by Jose Kurian Wednesday, May 4, 2011 6:16 PM
    Saturday, September 11, 2010 3:08 AM
  • I ran into same issue. Thanks Sujith for sharing the solution which you found.
    Josku
    Wednesday, May 4, 2011 6:17 PM