locked
Win Server 2008 R2 cannot update roles or features. RRS feed

  • Question

  • When I try to update roles or features on my server I get the following message:

    Roles: Error: Cannot display data until computer is restarted.  I've rebooted the server multiple times but still get this same message and no error code.  Any ideas what caused this and how to fix it?

    TC

    Tuesday, February 1, 2011 4:46 AM

Answers

  • Hi,

     

    Please check the ServerManager.log in the folder C:\Windows\ Logs to see if any specific error is logged.

     

    Best Regards

    Dale


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, February 1, 2011 6:51 AM

All replies

  • Hi,

     

    Please check the ServerManager.log in the folder C:\Windows\ Logs to see if any specific error is logged.

     

    Best Regards

    Dale


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, February 1, 2011 6:51 AM
  • This is what ServerManager.log file has in it

    11760: 2011-03-28 16:08:12.771 [CBS]                       LastModified CBS Time (UTC): 03/18/2011 09:01:41
    11760: 2011-03-28 16:08:12.771 [CBS]                       Cache Last Write Time (UTC): 01/18/2011 14:26:18
    11760: 2011-03-28 16:08:12.771 [CBS]                       IsCacheStillGood: False.
    11760: 2011-03-28 16:08:17.233 [CBS]                       >>>GetUpdateInfo--------------------------------------------------
    11760: 2011-03-28 16:08:21.788 [CBS] Error (Id=0) Function: 'ReadUpdateInfo()->Update_GetInstallState' failed: 80070bc9 (-2147021879)
    11760: 2011-03-28 16:08:21.788 [CBS]                       <<<GetUpdateInfo--------------------------------------------------
    11760: 2011-03-28 16:08:21.882 [DISCOVERY]                 hr: -2147021879 -> reboot required.
     

    And the Windows6.1-KB947821-v10 update that check status has no errors CheckSUR.log


    =================================
    Checking System Update Readiness.
    Binary Version 6.1.7601.21645
    Package Version 11.0
    2011-03-29 15:04

    Checking Windows Servicing Packages

    Checking Package Manifests and Catalogs

    Checking Package Watchlist

    Checking Component Watchlist

    Checking Packages

    Checking Component Store

    Summary:
    Seconds executed: 256
     No errors detected

    Thanks Craig

    Tuesday, March 29, 2011 2:02 PM
  • OK so after logging it with MS, I got the following answer "and it worked"

     

    1.    Under HKEY_LOCAL_MACHINE\COMPONENTS registry key, we deleted "PendingXmlIdentifier" registry entry from the details pane.

             (NOTE: Entire COMPONENTS registry key was exported before making any changes in the registry)

         2.  Since we were unable to view installed Roles/Features we deleted c:\windows\winsxs\Pending.xml file and rebooted the machine. (you will have to take ownership of this file to delete it)

         3.  After a reboot, we were able to view all the installed Roles/Features.

     

    Thanks

    Craig Eldridge

    • Proposed as answer by Beach Rat Wednesday, March 30, 2011 8:52 AM
    Wednesday, March 30, 2011 8:52 AM
  • I am having the same issue. There is no PendingXmlIdentifer under the registry path though. 
    Tuesday, May 24, 2011 9:31 PM
  • I am having the same issue. There is no PendingXmlIdentifer under the registry path though. 

    Take a look at this. http://support.microsoft.com/kb/946414

    There are 2 other registry entries that can be deleted. 

    Monday, July 11, 2011 3:15 PM
  • Please see this Thread:

    http://social.technet.microsoft.com/Forums/en-US/winservermanager/thread/582e885f-8a33-4791-ad99-3470c1f010be/#abf85855-a3a1-4bd4-a3b3-906dd4a8662b

    Quote from noamo48

    "

    Go to registry and delete the following keys (i only had two of the three and it worked anyways):

    • HKEY_LOCAL_MACHINE\COMPONENTS\PendingXmlIdentifier
    • HKEY_LOCAL_MACHINE\COMPONENTS\NextQueueEntryIndex
    • HKEY_LOCAL_MACHINE\COMPONENTS\AdvancedInstallersNeedResolving

    Reboot and that's it!

    "

    Tuesday, July 12, 2011 1:22 AM
  • Hi!

    Your solution No. 2 (delete c:\windows\winsxs\Pending.xml ) worked... Thank you very much.


    .::[ashX]::.

    Friday, November 2, 2012 10:01 AM
  • Hi,

    Thanks, after deleting registry & Pending.xml file it worked.

    Wednesday, November 21, 2012 2:39 AM
  • I know this is a very old thread but I just wanted to share what I had to do. This post helped me solve this annoying issue :)

    First when I checked i did not have the pending.xml file nor the registry key "PendingXmlIdentifier". I had to "try" to enable the feature, then when it failed i check again and both the file and registry key was there. Deleted both and rebooted. Now when going to enable the feature it was already enabled.

    The problem for me was after a failed installation it always wanted me to reboot, which i did and after the reboot the file mentioned was gone, as were the registry key. I had to delete the file and registry key before performing a reboot after a failed installation.

    Tuesday, July 23, 2013 7:01 PM
  • Hi,

    I am facing the same issue. In my scenarion when when I open the Hkey_local_machine, there is no components, and it still display "Roles: Error: Cannot display data until computer is restarted" even if I reboot the machine. Hope someone will help me please very important.

    Friday, September 27, 2013 4:19 PM
  • hi

    I open it but i don't see what you provided to delete, i cannot find the pending.xml file

    Friday, September 27, 2013 4:21 PM
  • Hello

    I'm having the same issue as a poster above.

    Can't find pending.xml nor any of this registry enteries:

    • HKEY_LOCAL_MACHINE\COMPONENTS\PendingXmlIdentifier
    • HKEY_LOCAL_MACHINE\COMPONENTS\NextQueueEntryIndex
    • HKEY_LOCAL_MACHINE\COMPONENTS\AdvancedInstallersNeedResolving

    In fact I don't have "COMPONENTS" key at all.

    And the "Add feature" button is greyed out.

    Can anyone give any update on this?

    Thank you!

    Thursday, October 3, 2013 9:08 AM
  • ===========================================

    so after logging it with MS, I got the following answer "and it worked"

     

    1.    Under HKEY_LOCAL_MACHINE\COMPONENTS registry key, we deleted "PendingXmlIdentifier" registry entry from the details pane.

             (NOTE: Entire COMPONENTS registry key was exported before making any changes in the registry)

         2.  Since we were unable to view installed Roles/Features we deleted c:\windows\winsxs\Pending.xml file and rebooted the machine. (you will have to take ownership of this file to delete it)

         3.  After a reboot, we were able to view all the installed Roles/Features.

     

    Thanks

    Craig Eldridge

    =======================

    Hello, 

    it's works for me too on several servers.

    Monday, October 12, 2015 2:04 PM
  • Adding my fix in case anyone else encounters this.

    Servermanager.log indicated "There are no more endpoints available from the endpoint mapper. (Exception from HRESULT: 0x800706D9)"

    Issue was that the Windows Firewall service was Disabled, re-enabling the service and restarting the system resolved the issue. Many folks don't understand that in Vista/2008+ the Firewall service functions differently than it did with XP\2003 where disabling the service only disabled the firewall.

    TL;DR: Make sure the Windows Firewall service is running.


    • Edited by Ian.Fuller Wednesday, October 14, 2015 5:48 PM Typo
    Wednesday, October 14, 2015 5:47 PM