none
Workflows

    Question

  • Hi 

    Moved all the ContentDB from Server A to Server B (from Farm A to Farm B) - but every workflow in a specific site seems to fail (SPD 2010 WF)    

    WinWF Internal Error, terminating workflow Id.....

    can anyone help troubleshoot this issue? 

    do I need to Re-publish all WF ? 

    • Edited by JmATK Tuesday, March 21, 2017 8:13 AM
    Tuesday, March 21, 2017 7:39 AM

Answers

  • Hi,

    Since the error message doesn’t provide more details, you can insert actions that write to the history list at any point in the workflow. This information helps you determine the last successful step that the workflow completed before the error occurred and also the step in which the error occurred.

    A demo for your reference:

    http://www.dotnetcurry.com/sharepoint/1045/debugging-sharepoint-workflows

    Best Regards,

    Dean Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Marked as answer by JmATK Monday, April 10, 2017 5:57 AM
    Saturday, April 08, 2017 11:12 AM
    Moderator

All replies

  • Hi

    you have to use VisualStudio

    Check this similar post

    https://social.msdn.microsoft.com/Forums/en-US/b034a5ba-abc8-4396-99cc-ce38f9eb7747/copying-moving-sharepoint-designer-workflow?forum=sharepointcustomizationlegacy


    Romeo Donca, Orange Romania (MCSE, MCITP, CCNA) Please Mark As Answer if my post solves your problem or Vote As Helpful if the post has been helpful for you.

    Tuesday, March 21, 2017 7:59 AM
  • Hi Romeo 

    I don't understand - I can open the WF in SPD and edit (and publish) so the WF are in the ContentDB - its all list WF?  

    - the new farm is setup with same Service accounts etc.  - it just went from physical to Virtual   

    so I have to create a new WF - similar to the "old" ? 




    • Edited by JmATK Tuesday, March 21, 2017 8:29 AM
    Tuesday, March 21, 2017 8:15 AM
  • Hi

    The workflow is linked to list/library ID  and farm ID ( which changed when you moved to diff env )


    Romeo Donca, Orange Romania (MCSE, MCITP, CCNA) Please Mark As Answer if my post solves your problem or Vote As Helpful if the post has been helpful for you.

    Tuesday, March 21, 2017 9:56 AM
  • Hi 

    So how do I update the Farm ID on the Workflows?  - I've ShareGate - so I guess I can migrate them from Old server to New Server 

    I've just created a new WF - same error - some (simple) WF's works perfect - there's this installed  https://spdactivities.codeplex.com/ 

    I'll try to enabled verbose to see if I can get a more explaining error... the An error has occurred in WF name  doesn't tell much 

    there's no WorkFlow Manager installed - 


    • Edited by JmATK Tuesday, March 21, 2017 10:23 AM
    Tuesday, March 21, 2017 10:06 AM
  • How do I see the error ? 
    Wednesday, March 22, 2017 6:26 AM
  • Hi,

    You can migrate SharePoint workflows by exporting it to visio on farm A and importing from visio to farm B.

    Detailed steps for your reference:

    https://chanakyajayabalan.wordpress.com/2012/01/02/copyingmoving-sharepoint-2010-designer-workflows/

    Note: You need to update list GUID in the workflow if your list GUID has been changed after migration.

    Best Regards,

    Dean Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, March 23, 2017 12:46 PM
    Moderator
  • Hi Dean 

    That just it - the listID etc. are the same (as they are all in the same ContentDB) - I recon that, if the FarmID is necessary in order for the WF to work - but why is a re-publsih not enough? its 2010 SPD WF attached to list - not reusable site WF and some works perfect....others not 


    • Edited by JmATK Thursday, March 23, 2017 2:30 PM
    Thursday, March 23, 2017 2:30 PM
  • Re-publish the workflows.
    Thursday, March 23, 2017 6:00 PM
  • Hi,

    If you create a new 2010 workflow in your current environment, will it work fine?

    Please access SharePoint Designer, select workflows in All Files list and open workflowname.xoml.wfconfig.xml to check for the ListID. Then republish this workflow.

    If the issue still occurs, you need to check for the USL logs to get detailed error message.

    Best Regards,

    Dean Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, April 06, 2017 10:01 AM
    Moderator
  • Hi Dean 

    Ok - I'll do that -:) 

    but how do I find out what's the error when all I have is this: 

    Event Type: 10   
    Workflow History Parent Instance: {80b2d50a-66e8-4067-a699-b93e9957cca6}   
    Workflow Association ID: {b84577a1-ac95-433d-b07b-8f26e6987448}   
    Workflow Template ID: {44527dbb-f70b-4aa8-8622-f271d8e811b9}   
    List ID: {90289d5b-68ba-42a5-ba52-d734583f134b}   
    Primary Item ID: 5079   
    User ID: System Account   
    Date Occurred: 07-04-2017 10:23   
    Group Type:  
    Outcome:    
    Description: An error has occurred in <WF name>. 


    • Edited by JmATK Friday, April 07, 2017 8:38 AM
    Friday, April 07, 2017 8:35 AM
  • Hi,

    Since the error message doesn’t provide more details, you can insert actions that write to the history list at any point in the workflow. This information helps you determine the last successful step that the workflow completed before the error occurred and also the step in which the error occurred.

    A demo for your reference:

    http://www.dotnetcurry.com/sharepoint/1045/debugging-sharepoint-workflows

    Best Regards,

    Dean Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Marked as answer by JmATK Monday, April 10, 2017 5:57 AM
    Saturday, April 08, 2017 11:12 AM
    Moderator