none
DNS keeps changing to Static RRS feed

  • Question

  • Hello,

    I have set up a Windows Server 2012 R2 Essentials domain, and I am able to remotely log in to my network with the Anywhere Access VPN. It's very handy. This works great when out of the office.
    However, something weird happens when I am inside the office. The DNS somehow gets changed to a static 192.168.1.3, (which is the server's IP). Why doesn't it stay automatic?
    This creates a problem when I try to use the laptop again outside the office, because I have to change it back to "obtain automatically"

    Our network is fairly simple. We have a router, with the server connected directly, and a my laptop on wifi. DHCP is not enabled on the server, since the router handles that.

    I even went into my laptop's adapter settings, set a static DNS to 208.67.220.220 & 208.67. 222.222 (openDNS) but after rebooting and logging in again, those were gone and the static ip 192.168.1.3 had returned.
    I also tried the "Advanced" settings for the wifi adapter and added those IPs to the preferred list, but again after rebooting, they were gone and replaced with the 192.168.1.3 address.
    Just wanna reiterate, this only happens when I am connected to the network at the office, not when I connect from home or anywhere else.

    I have not configured any group policies, so it's just whatever is default after running through the "Get Started" "Setup" section of the Dashboard.

    Any ideas why my DNS keeps changing to static inside the office? Thanks so much!!

    P.S. Laptop is a new HP Spectre x360. I reached out to HP to ask if there is any software on the laptop that would cause this. They spoke with their supervisors and said they've never heard of this before, they don't believe it is caused by HP.

    • Edited by alanudi Wednesday, August 3, 2016 7:33 PM added info about HP
    Wednesday, August 3, 2016 7:09 PM

All replies

  • Hi,

    >>I even went into my laptop's adapter settings, set a static DNS to 208.67.220.220 & 208.67. 222.222 (openDNS) but after rebooting and logging in again, those were gone and the static ip 192.168.1.3 had returned.

    Typically,manually modifying preferred list has the highest priority.

    >>Just wanna reiterate, this only happens when I am connected to the network at the office, not when I connect from home or anywhere else.

    Considerring it only happens at office,please perform a fully scan for virus/malware on your office network.

    And you also could check your DHCP on your router,if it has been set to  the specific DNS.

    ________________________________________
    Best Regards,
    Cartman
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, August 4, 2016 6:21 AM
  • OI I found the answer, and I want to post a picture of it, but the forum says I can't post pics or links until my account is verified.  I don't see an email requesting verification, do you know how I verify my account? Thanks!
    • Edited by alanudi Thursday, August 4, 2016 7:32 PM
    Thursday, August 4, 2016 7:32 PM
  • Hi,

    》》OI I found the answer, and I want to post a picture of it, but the forum says I can't post pics or links until my account is verified.  I don't see an email requesting verification, do you know how I verify my account? Thanks!

    Check this:

    https://social.technet.microsoft.com/wiki/contents/articles/15960.how-to-verify-your-msdntechnet-forums-account-so-that-you-can-post-images-and-links.aspx

    ________________________________________
    Best Regards,
    Cartman
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, August 5, 2016 1:22 AM
  • Hi,

    I am checking to see if the problem has been resolved. If there's anything you'd like to know, don't hesitate to ask.

    ________________________________________
    Best Regards,
    Cartman
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact
    tnmff@microsoft.com.

    Monday, August 8, 2016 8:03 AM