none
SSMS fails to open Object Explorer

    Question

  • When starting SSMS, Object Explorer won't open and cannot be opened by hitting the <F8> key. There is no menu item, either, to open the Object Explorer in SSMS.

    This is the error message I get:


    Wednesday, December 27, 2017 2:21 PM

All replies

  • i bet most of us here can't understand the error message, as this is a English-spoken forum and the message is in some other language. So why not post the translated version of the error so we can help?
    Wednesday, December 27, 2017 3:32 PM
  • It's ...

    =================================
    Error opening the connection dialog field.
    =================================

    Object reference not set to an instance of an object.
    (Microsoft.SqlServer.Management.SqlStudio)

    _____________________________________

    Program stack trace:

     at Microsoft.SqlServer.Management.SqlStudio.ConnectToOe().

    I doubt anyone here can help - except he'd work in the SSMS development team being able to check the source for a uninitialized object.

    Unfortunally, the SQL Server channel on MS Connect has been shut down, so there is no place to drop bug reports elsewhere.

    • Edited by BetterToday Wednesday, December 27, 2017 4:15 PM
    Wednesday, December 27, 2017 4:15 PM
  • Other people complaining of this issue resolved it by updating/reinstalling the .Net version using Windows Update.

    Wednesday, December 27, 2017 7:21 PM
  • Hi BetterToday,

    Could you please share more detailed information to help us reproduce this problem?

    1. How did you meet this problem? After upgrading some packages like .net framework or visual studio?

    2. Which version of Windows and SSMS did you use? 

    Generally, this problem is related to .net framework, please try to repair .net framework and upgrade it to the latest version.

    Best Regards,

    Teige


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, December 28, 2017 2:15 AM
  • Hi, y'all,

    I set up a virtual machine three days ago for SQL Server/SSMS. So anything in this machine is the latest version - at least nothing's older than three days.

    All I did is to move the SSMS working folder to a sub directory of the Documents folder (from "D:\Documents\SQL Server Management Studio\" to "D:\Documents\Visual Studio-Projekte\SQL Server Management Studio\"). And I locked down the Documents folder (revoked "Create Directory" rights) to keep SSMS from recreating the "SQL Server Management Studio" folder everytime anew when it starts.

    • Edited by BetterToday Thursday, December 28, 2017 10:46 AM
    Thursday, December 28, 2017 10:46 AM
  • All I did is to move the SSMS working folder to a sub directory of the Documents folder (from"D:\Documents\SQL Server Management Studio\" to "D:\Documents\Visual Studio-Projekte\SQL Server Management Studio\"). And I locked down the Documents folder (revoked "Create Directory" rights) to keep SSMS from recreating the "SQL Server Management Studio" folder everytime anew when it starts.

    And if you revert these actions, what happens?

    Thursday, December 28, 2017 10:51 PM
  • Really?????????

    For every expert, there is an equal and opposite expert. - Becker's Law


    My blog


    My TechNet articles

    Thursday, December 28, 2017 11:33 PM
    Moderator
  • And if you revert these actions, what happens?

    I reverted the installation and left everything at its default for now. Let me finish setting up the virtual machine. As soon as I have set-up and configured it completely I'll take a snapshot and reproduce the issue.

    For a start, go to Regedit and replace every occurence of "D:\Documents\SQL Server management Studio" (use your personal Documents path here) with "D:\Documents\Visual Studio-Projekte\SQL Server management Studio" and every occurence of "D:\Documents\Visual Studio 2015" with "D:\Documents\Visual Studio-Projekte\Visual Studio 2015". (And make sure these folders exist.)


    • Edited by BetterToday Saturday, December 30, 2017 5:16 PM
    Saturday, December 30, 2017 5:16 PM
  • I now set-up the VM and created a simple example for everyone to be able to reproduce the problem ...

    It's easy to reproduce the issue by following these steps:

    1. Move the "%MyDocuments%\SQL Server Management Studio" directory to somewhere else.
    2. Deny Create Directory right to the "%MyDocuments%" directory for Everyone.
    3. Start SSMS

    Down below please find a screencast showing the results

    (It's in German as I'm always running everything in German,
    but you can easily see the problem
    from reproducing the above three steps by yourself)
    .

    Click to enlarge:

    (The original file is rather large. Let it load a couple of seconds for being displayed.)

    • Edited by BetterToday Wednesday, January 03, 2018 9:45 PM
    Wednesday, January 03, 2018 9:36 PM
  • If you feel that it is important that this should work, you can file a bug on
    https://feedback.azure.com/forums/908035-sql-server

    But for now, the sole recommendation I can give is "don't do that!".

    Wednesday, January 03, 2018 10:48 PM
  • Of course this is important.

    If the "A" key on your keyboard wouldn't be recognized by SSMS, wouldn't you feel this should work, too? Your sole recommendation surely wouldn't be "don't hit that".

    This is no improvement suggestion, this is a plain bug report about a bug that needs to be fixed.

    The use of directories and the determination of where to store user files is up to the administrator of a machine park, it's not up to a tool like SSMS.

    SSMS' quality degrades with every year. It now doesn't even adhere to Microsoft's own programming guidelines, made for administrators.


    https://feedback.azure.com/forums/908035-sql-server/suggestions/32811088-bug-report-ssms-fails-to-open-object-explorer
    • Edited by BetterToday Wednesday, January 03, 2018 11:36 PM
    Wednesday, January 03, 2018 11:18 PM
  • I have voted this problem, if many people meet a similar problem, the product team will pay attention to it and fix it.

    "SSMS' quality degrades with every year." It's sorry to hear that 


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, January 11, 2018 7:14 AM
  • Thanks, Teige :)
    Thursday, January 11, 2018 2:25 PM