none
Given project already has a web associated with it RRS feed

  • Question

  • Hello!

    We recently migrated our Project Server 2007 to Project Server 2010 using the full Database Migration method. Now when someone tries to publish one of their Enterprise projects on the new 2010 server, they receive an e-mail stating:

    ----------------------------------------------------

    Your queue job CreateWssSite failed. Please contact your administrator for assistance

    Your CreateWssSite job failed.  Its current state is FailedNotBlocking.  It was 0% complete.  It entered the queue at 09/13/2010 11:45:00.

     

    To get more information about the job failure, please go to Project Web App.  Select Personal Settings from the left menu.  Then select My Queued Jobs.

     

    The errors returned from the queue are as follows:

     Error ID: 16404

     Error ID: 26000

     

    Detailed error below - send it to the administrator for more detailed troubleshooting.

     

    <?xml version="1.0" encoding="utf-16"?>

    <errinfo>

      <general>

        <class name="Given project already has a web associated with it">

          <error id="16404" name="WSSProjectAlreadyHasSpWeb" uid="7a7bc48f-6b10-4a7a-9216-317f428b6c04" projectUID="937ab104-54ed-44b4-a8c8-3eed4b8ad568" />

        </class>

        <class name="Queue">

          <error id="26000" name="GeneralQueueJobFailed" uid="ccce8e04-3d28-43c7-b4d2-723b93fffa9e" JobUID="dc619203-6325-4ddf-812a-9825aa036fac" ComputerName="SD-SPERP01V" GroupType="CreateWssSite" MessageType="CreateWssSiteMessage" MessageId="1" Stage="" />

        </class>

      </general>

    </errinfo>

     

    You can do the following:

    1. Try troubleshooting using the error IDs, error XML.

    2. Contact administrator with your jobID (dc619203-6325-4ddf-812a-9825aa036fac) and error XML.

     

    To turn off these notifications, go to Project Web App, click Personal Settings on the left menu, and then click Manage My Alerts and Reminders.

     

    From this page, you can clear the check box for those notifications you no longer want to receive.

     

    Microsoft Office Project Server

     

    ----------------------------------------------------

     

    Annoying! It looks like it's complaining that a published project already has a workspace site associated with it, which is true. But how do I make this error shut up?

     

    Thanks!

    Ken

    Monday, September 13, 2010 9:53 PM

Answers

All replies

  • Hello Kleung,

    Somehow during your migration, you have made the web sites or workspaces orphaned.  I haven't found a good solution for resolving this and saving all your documents in old workspaces.  You might found some help in the SharePoint forums.

    I had a similar situation but I didn't need the old workspaces.  The way I resolved, it was I went into Server Settings/ Workspaces.  (going from memory).  Selected the workspace, Edit the workspace and removed the link, then I recreated the workspace.

    Cheers!

    Michael wharton, MBA, PMP, MCT

     


    Sincerely, Michael Wharton, MBA, PMP, MCT, MCSD, MCSE+I, MCDBA www.WhartonComputer.com
    Thursday, September 16, 2010 2:14 PM
    Moderator
  • Hmmm. The error message seems to indicate Project knows there's already a web associated with the project and is just notifying you.

        <class name="Given project already has a web associated with it">

    I would think by this message that in fact Project sees the web is linked with the project and not orphaned.

    I would post in the SharePoint forum but the moderators would scream at me for posting Project Server topics there, lol.

    Thursday, September 16, 2010 4:52 PM
  • Hello kleung,

    Do the project workspace links still work to the project workspace when you click on them from PWA?

    Does this on just new published projects?

     

    Cheers!

    Michael Wharton, MBA, PMP, mCT

     


    Sincerely, Michael Wharton, MBA, PMP, MCT, MCSD, MCSE+I, MCDBA www.WhartonComputer.com
    Thursday, September 16, 2010 6:40 PM
    Moderator
  • So far we're only trying it with old projects migrated from 2007. The links to the project workspaces in the PWA quick launch menu do work. But when I select the project from Project Center, the Project Site option in the ribbon bar is grayed out and says "This control is currently disabled". I wonder if it's because we're running in BCM.
    Thursday, September 16, 2010 9:12 PM
  • I can give two options to resolve the issue.

    Option 1: (Recommended)

    Attach the 2007 content db in 2010. Export the project workspace from 2007. Import the workspace under the new project PWA.

    Later run the Project workspace relink tool to link the workspaces with the project plan.

    Option 2: (Try on your test machine before production)

    In Project server published database, following fields are holding the workspace information, you can create workspace after making the values as NULL.

    Update MSP_PROJECTS SET WPROJ_STS_SUBWEB_NAME = NULL,WSTS_SERVER_UID = NULL,WPROJ_ISSUE_LIST_NAME = NULL,WPROJ_RISK_LIST_NAME = NULL,PROJ_TOTAL_DOC_COUNT = 0,PROJ_ACTIVE_ISSUE_COUNT = 0,PROJ_ACTIVE_RISK_COUNT = 0,WSS_PWA_ADMIN_ROLE_ID = NULL,WSS_PWA_PROJECT_MANAGER_ROLE_ID = NULL,WSS_PWA_TEAM_MEMBER_ROLE_ID = NULL,WSS_PWA_READER_ROLE_ID = NULL where PROJ_NAME = 'Project Name'

     


    Cheers. Happy troubleshooting !!! Sriram E - MSFT Enterprise Project Management
    Friday, September 17, 2010 1:23 AM
    Moderator
  • Sriram,

    Thank you for the suggestions. Maybe it would help me if I understood what the underlying problem is we are solving. Did our Project workspaces become unlinked after doing the full database migration from Project Server 2007 to 2010, even though we followed Microsoft's own technet instructions? I see in your Option 1 that you are recommending exporting the Project workspaces after the migration and re-importing them, is that right? Why is this necessary after running a full migration to 2010 and all the Project workspaces are already accessible in the new PWA site?

    Thanks!

    Ken

    Monday, September 20, 2010 5:01 PM
    • Marked as answer by kleung Monday, September 20, 2010 10:27 PM
    Monday, September 20, 2010 7:09 PM
  • Thank you Christophe, Brian's blog post led me to the solution.

    I had to run the Bulk Update Project Sites tool in Server Settings for the PWA site.

    The Previous Site Path had the GUID of the old Project Server 2007 web app. The New Site Path had my new 2010 web application. Both values were pre-populated and I didn't change either of these. I just clicked on the Update button.

    This effectively relinked all our project workspaces to the Project 2010 databases. Now we can publish projects without that error message being reported.

    Thanks to all.

    Ken

    • Marked as answer by kleung Monday, September 20, 2010 10:27 PM
    Monday, September 20, 2010 10:26 PM