locked
Audit Log reports RRS feed

  • Question

  • I have enabled Audit log reports for site collections and only for one site collection, when I click 'Content viewing' I am getting a timeout exactly after 5 minutes.

    Reports are properly working for all other site collections and reports other than 'Content viewing' are working properly for the affected site colection.

    Below is the link from the 'Content viewing'

    javascript:SubmitFormToRunReport('c1ca0b91-30fc-43e8-9ae8-83b40d51e9e8','Content_viewing.xml','');

     

    And the script in Reporting.Aspx is as given below...

    function SubmitFormToRunReport(reportId, reportName, reportSubcategory)
    {
    var form = document.forms[0];

    var elReportId = document.getElementById(<% SPHttpUtility.AddQuote(SPHttpUtility.HtmlEncode(GenerateReport.ParamReportId),Response.Output); %>);

     elReportId.value = reportId;

     <% if (strCategory.ToLower().Equals(strParamCategoryWorkflow)) { %>
     var elReportSubcategory = document.getElementById(<% SPHttpUtility.AddQuote(SPHttpUtility.HtmlEncode(WorkflowReport.strParamAssociationId),Response.Output); %>);

     elReportSubcategory.value = reportSubcategory;

     <% } %>

     form.action = "RunReport.aspx/" + reportName;

     form.submit();

    }

     

    Please help me...

     


    Regards Rahul A
    • Moved by Mike Walsh FIN Tuesday, July 5, 2011 9:21 AM admin q (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Tuesday, July 5, 2011 9:02 AM

Answers

  • HI,

    Check the audit log table size.

    Do a trimming and then try once again.

    Also chack in uls logs for more details.

     

    I hope this will help.

    Thanks,

    Rahul Rashu

    • Marked as answer by Peng Lei Wednesday, July 13, 2011 1:55 AM
    Tuesday, July 5, 2011 12:33 PM

All replies

  • HI,

    Check the audit log table size.

    Do a trimming and then try once again.

    Also chack in uls logs for more details.

     

    I hope this will help.

    Thanks,

    Rahul Rashu

    • Marked as answer by Peng Lei Wednesday, July 13, 2011 1:55 AM
    Tuesday, July 5, 2011 12:33 PM
  • Rashu, Thank you for the reply. Could you please tell where is that table ?

    Thank you


    Regards Rahul A
    Wednesday, July 6, 2011 4:29 AM
  • I finally trimmed the audit logs and there were more than 180 thousand rows... thats why it was causing timeout after 5 minutes...Thank you Rashu, your post helped.
    Regards Rahul A
    Sunday, July 17, 2011 5:30 PM