locked
Linux Integration service installation is failing with PAE kernel ( Centos 5.8 ) RRS feed

  • Question

  • Hello All ,

    While installing LSI3.4 on a hyper v image ( windows 2012 ) , installation throwing the following error and hence it causing "Kernel Panic "

    ===================

    -hyperv RHEL58]# ./install-rhel58.sh
    Installing the Linux Integration Services for Microsoft Hyper-V...
    Preparing...                ########################################### [100%]
       1:kmod-microsoft-hyper-v ########################################### [100%]
    Preparing...                ########################################### [100%]
       1:microsoft-hyper-v      ########################################### [100%]
    No module hv_storvsc found for kernel 2.6.18-308.el5PAE, aborting.
    cp: cannot stat `initrd-2.6.18-308.el5PAE.img': No such file or directory
            Done.
    Adding KVP Daemon to Chkconfig....
    Starting KVP Daemon....
     Linux Integration Services for Hyper-V has been installed. Please reboot your system
    ===================

    Any idea ?  , or is there any way to manually compile these modules with a PAE kernel .

    Awaiting your reply .

    Sincerely ,

    Hari

    Friday, December 14, 2012 10:23 AM

All replies

  • Experts ,

    Any idea ?

    Sincerely ,

    Hari

    Monday, December 17, 2012 3:37 AM
  • Hi Hari,

    is there any solution for this problem?

    Thanks

    Vavo

    Tuesday, April 23, 2013 7:23 AM
  • is there any solution for this problem?

    ~

    EL 5.8+LIS3.4 -- is _old_ / oudated

    Please, use _latest_ EL 5.9  ( or EL 6.4) with _integrated_ Hyper-V support

    ~

    it is true, but I need RHEL 5.8 32-bit,

    because Oracle eBS 11i seem s to be supported only on RHEL 5.8 or even older RHEL 5.4.

    Actually Oracle doesn't support eBS on Hyper-V (if I'm not wrong) but it will be OK, for Test environment.

     

    ~

    IMHO, look like, what people from Oracle not tested eBS on RHEL v5.9 at _this_ time,
    but in future do this and upgrade info in documentation

    ~


    Wednesday, April 24, 2013 8:20 AM
  • Hi Viktor,

    it is true, but I need RHEL 5.8 32-bit,

    because Oracle eBS 11i seem s to be supported only on RHEL 5.8 or even older RHEL 5.4.

    Actually Oracle doesn't support eBS on Hyper-V (if I'm not wrong) but it will be OK, for Test environment.

    Thanks

    Wednesday, April 24, 2013 10:59 AM
  • The Microsoft product team that builds the Linux Integration Services has recently become aware that the binary packages in LIS 3.4 don't work with PAE kernels.  So this is a known limitation.   But indications are that the LIS source code does work if you are willing/able to recompile it for your PAE kernel.   The source code is included with the LIS 3.4 download, so it's available to you.

    We're looking at providing a binary package of LIS that works with the PAE kernel in a future update to LIS for RHEL 5.8 and earlier.


    Michael Kelley, Lead Program Manager, Open Source Technology Center


    Wednesday, May 1, 2013 4:08 PM
    Moderator