locked
Azure Management Pack, not getting state changes on monitored objects RRS feed

  • Question

  • Hi.

    Azure Management Pack 1.6.0.7 in SCOM 2012 R2

    Following is working fine:

    - Subscription configurations

    - Configuring of Microsoft Azure Monitoring templates, choosing service type: "metricalerts (microsoft.insights)"

    - All Alert Rule objects are found, and populated in SCOM with a healthy state

    Though, when an alert rule (both static and dynamic) changes state to unhealthy in Azure and an Azure alert is generated, the corresponding object in SCOM stays healthy, and thus no alarm is generated in SCOM.

    This used to work when I configured it last time. As action to remedy, we've deleted all configuration and management packs from SCOM, and started afresh, but still the same issue. Azure alert rule state changes are not comming down to the SCOM environment.

    Looking to learn known issues, how to troubleshoot this situation, and also suggestions for other ways to get Azure Alert Rule states or Alert rule alerts down to SCOM. I've tried searching for the issue, but I can't seem to find anything.

    Wednesday, April 10, 2019 6:57 AM

Answers

  • Microsoft has confirmed this is an issue, unresolved as of now.
    Friday, May 24, 2019 11:01 AM

All replies

  • Hello Pål,

    Microsoft released an update for the Azure Management Pack two days ago (8 April 2019) which includes a few fixes and improvements, you can read about the fixes in the 1.7.0.0 MicrosoftAzureManagementPackGuide.docx.

    You'll find the new version 1.7.0.0 of the management pack here:

    Microsoft System Center 2016 Management Pack for Microsoft Azure
    https://www.microsoft.com/en-us/download/details.aspx?id=50013

    You could try out the updated management pack to check if it works better.

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Wednesday, April 10, 2019 7:56 AM
  • Hi,

     

    Based as I know, only monitor can change state. we can see more details as below:

     

    https://blogs.technet.microsoft.com/nathangau/2016/10/26/monitors-vs-rules-and-how-they-affect-alert-management/

     

    To change the state, we suggest to replace necessary rules with monitors which can close alert automatically once the error is resolved.

     

    Best regards.

    Crystal


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, April 10, 2019 8:59 AM
  • Thank you, Leon! Following your blog now. :)

    I've been testing an hour with the new management pack, but see the same results. Alerts fired in Azure does not change states of the Microsoft.Insights/metricalerts objects in SCOM.

    I unchecked metricalerts in config before updating, and added them back after the upgrade. All objects came back fine with a healthy state, but stays that way no matter what actually happens to them in the Azure subscriptions.

    I'm wondering if this is related to the following: when trying to run the following PS commands towards the subscriptions, I get no results in return:

    Get-AzAlertRule -ResourceGroupName ****

    Get-AzAlertHistory -StartTime 2019-04-09T00:00 -EndTime 2019-04-10T00:00

    Get-AzLog -StartTime 2019-04-01T00:00 -Caller "Microsoft.Insights/alertRules"

    Although, Get-AzLog without caller gives alot of log information, so that seems to be working. According to this site, the above commands should return useful results. Can anyone help me to test the Powershell commands on their subscription(s)? If it's working elsewhere, this will point me in the direction of Azure not giving the right results, and not the Management Pack itself doing something wrong.

    https://github.com/MicrosoftDocs/azure-docs/blob/master/articles/azure-monitor/platform/powershell-quickstart-samples.md

    Wednesday, April 10, 2019 10:09 AM
  • Same here, alertrules are working in SCOM, but not metricalerts.

    I already have a support case opened with Microsoft, and working on it.

    Monday, May 6, 2019 10:47 AM
  • Thanks for informing, Hubo Bomo. I also have a support ticket open, but no progress so far. Let's keep each other updated here.
    Monday, May 6, 2019 6:26 PM
  • Microsoft has confirmed this is an issue, unresolved as of now.
    Friday, May 24, 2019 11:01 AM
  • Thank you for sharing this Pål!

    Blog: https://thesystemcenterblog.com LinkedIn:

    Friday, May 24, 2019 11:05 AM
  • Hi, is this still unresolved?
    Wednesday, August 21, 2019 3:14 PM
  • Hi

    You mentioned "it used to work before", can you please tell us when and how?

    Thanks in advance!

    Cheers


    Sam (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" wherever applicable. Thanks!) Blog:AnalyticOps Insights Twitter:Sameer Mhaisekar

    Thursday, August 22, 2019 6:43 AM
  • The issue is still unresolved as far as I know. Been working on other projects while I wait for a solution, so haven't checked myself.

    Last I got from Microsoft Customer Service and Support was 20. of May 2019,

    "As we spoke, I am updating you on the current development of the new Azure MP. Nothing new I am afraid, no news from the product group."

    and

    "I am not aware for this issue to have being publically announced, hence the only way to have it confirmed is by opening a case with us, just as you did."

    As for when it stopped working, I'm not exactly sure, but somewhere between January and March this year.

    Thursday, August 22, 2019 1:12 PM
  • Also got a new answer from Support now when asked for update - still no update:

    "

    Thank you for reaching out. I have checked with the product group, on the behalf of ***, who is on vacation currently, and there is no update.

    Anytime we receive their feedback we will make you aware.

    "

    Thursday, August 22, 2019 1:27 PM