none
Installation of Skype for Business Server 2015 Resource Kit Tools RRS feed

  • Question

  • Hi,

    Previously, I've installed 

    https://www.microsoft.com/en-us/download/details.aspx?id=47263

    which just contains Snooper\CLSLogging

    This required Visual C++ 2015 to be installed.

    I now want to install

    https://www.microsoft.com/en-us/download/details.aspx?id=52631

    This contains the rest of the Debugging tools (not sure why Microsoft couldn't put it in 1 install with Snooper\CLS??)

    However when trying to run the install for this it complains that it requires Visual C++ 2013 is installed.

    Can I install Visual C++ 2013 on top of 2015 does anybody know or is there a workaround\later version so it can use the Visual C++ 2015 that's been installed?

    Thanks

    Kevin

    Thursday, June 7, 2018 7:24 AM

Answers

  • Hi Kevin,

     

    When you install the Resource Kit Tools ,you must install the Microsoft Visual C++ 2013,install the Debugging Tools ,you should install Microsoft Visual C++ 2015.

    You should install Microsoft Visual C++ 2013 and Microsoft Visual C++ 2015 Simultaneously like the following screenshot.



    Best Regards,
    Leon Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, June 12, 2018 10:01 AM
    Moderator

All replies

  • Hi Kevin,

     

    When you install the Resource Kit Tools ,you must install the Microsoft Visual C++ 2013,install the Debugging Tools ,you should install Microsoft Visual C++ 2015.

    You should install Microsoft Visual C++ 2013 and Microsoft Visual C++ 2015 Simultaneously like the following screenshot.



    Best Regards,
    Leon Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, June 12, 2018 10:01 AM
    Moderator
  • Thanks Leon. So you can install Visual C++ 2013 and 2015 simultaneously.

    Thank you.

    Wednesday, June 13, 2018 3:34 PM
  • Yes ,we can  install Visual C++ 2013 and 2015 simultaneously. if the reply is helpful to you, please try to mark it as an answer, it will help others who has similar issue.

    Best Regards,
    Leon Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, June 14, 2018 9:11 AM
    Moderator
  • Hi,

     

    Are there any update for this issue, if the reply is helpful to you, please try to mark it as an answer, it will help others who has similar issue.


    Best Regards,
    Leon Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, June 15, 2018 11:41 AM
    Moderator
  • Hi Leon,

    I don't have exact issue but on similar grounds. When I try to install Skype for Business Server 2015, Resource Kit Tool it errors that "Visual c++2013 x64 Minimum Runtime- 12.0.21005 package is required" however it is already installed. Infact there is a latest version -12.0.40660. I tried uninstalling latest version but still same error.

    Any help would be highly appreciated.

    Regards,

    Kavita Oak

    Thursday, October 3, 2019 3:08 AM
  • Hi Kavita,

    Have a look at this post, sounds like the same issue:

    https://x500.co.uk/2018/02/12/debugging-tools-install-error-visual-c-2015-x64-minimum-runtime-14-0-23026/

    -Steve

    Thursday, October 3, 2019 10:20 AM
  • Hi Steve,

    No luck with the provided link (https://x500.co.uk/2018/02/12/debugging-tools-install-error-visual-c-2015-x64-minimum-runtime-14-0-23026/).

    The issue is the setup prompts to install -Visual c++2013 x64 Minimum Runtime- 12.0.21005 package is required" which is already installed. It doesnot install it because it's already installed

    I have tried un-installing and reinstalling Visual c++2013 x64 12.0.21005 with no luck.

    Any help would be appreciated.

    Regards,

    Kavita Oak.

    Monday, October 14, 2019 3:11 AM
  • Hi Kavita

    I found this article, having the exact same issue with the correct Visual C++ version installed from the Skype 2015 installation media.

    What finally solved the issue for me was to uninstall all 12.X versions of Visual C++ along with the correct one.

    Ran setup.exe from the installation media (as admin), it installed 12.0.21005.1 x64, and i was now able to install the OCSReskit.

    Not sure if even newer versions of VC++ also interfere with the installer, but now you have something to go on if so.

    I hope this helps :)

    Wednesday, October 30, 2019 9:21 AM