none
There is a delivery delay with third party Applications once sending mails using Exchange relay . RRS feed

  • Question

  • Hi All ,

    I have Exchange 2013  running on windows 2012 server , we have some applications using Exchange Server to relay the mails , but there is delay for delivering the mail , normal  mailboxes users sending and receiving mails  normally without any delay only this issue with applications .

    BR,

    Mohammad

    Monday, August 28, 2017 4:28 PM

All replies

  • Hi,

    Thanks for contacting our forum.

    Please help to verify the following information:

    How much time were the messages delayed?

    Does the Apps use the same receive connector with normal mailboxes or different connector for relay?

    You can run the command to set the tarpitinterval for specific receive connector: The TarpitInterval parameter specifies the period of time to delay an SMTP response to a remote server that may be abusing the connection. The default value is 5 seconds.

    get-ReceiveConnector | set-ReceiveConnector -tarpitinterval 00:00

    You can use the RCA tool to analysis the message header of the relayed messages and check in which step the messages are delayed.

    And please check if this issue affect all the message sent by the App of specific message? If the delayed messages with specific attachments or size?

    If the App in the same site with the Exchange server or not.

    Thanks for your effort and hope it helps.


    Regards,

    Jason Chao


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, August 29, 2017 2:59 AM
    Moderator
  • Hi Jason , Thank u for ur help , regarding the receive connector I have created another one for the applications , I will go a head for the steps and update u . The applications in another site , need to change any registry key in cas servers ? BR, Mohammad .
    • Edited by Mohammad B Wednesday, August 30, 2017 9:13 AM
    Wednesday, August 30, 2017 8:59 AM
  • Thanks for your response.

    Per my experience, we needn't add the registry key. Please keep updateing.

    Thanks.


    Regards,

    Jason Chao


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Sunday, September 3, 2017 3:48 PM
    Moderator
  • ok 

    Tuesday, September 5, 2017 5:52 PM
  • Thanks, if you have any results, please post back.

    Regards,

    Jason Chao


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, September 12, 2017 8:01 AM
    Moderator
  • check the protocol logging for SMTP relay and see when did exchange received email from application. it might be an issue with application where it delay generating email.

    thanks

    zak


    ZakBhai

    Tuesday, September 12, 2017 3:50 PM
  • Thanks for your response.

    Could you please post out the message header of the delayed message? We need to check in which step the message was delayed.

    Thanks.


    Regards,

    Jason Chao


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, September 18, 2017 6:03 AM
    Moderator