none
PS2013 - When creating a new instance of Project Server hangs in 'Waiting for resources' status RRS feed

  • Question

  • Hi,

    I have one instance of Project Server 2013 fully operational and I tried to duplicate the instance to make some tests. As I know the issue of using the same Content Database of Project Server in the same Server Farm, I used the powershell  backup/restore/dismount and mount the content database to change the site IDs to avoid index duplication. The Project server database was a regular SQL backup and restore in another database.

    I created a new Web App in the port 90 as show below.

    Web Apps

    Then I included the Content database of Project Server as separated DB from SharePoint for this new SharePoint -acme90 and I tried to create the new instance. The creation hanged in "Waiting for Resources" status.

    To make another check excluding the reuse of the SharePoint-80 I tried to create another instance both in the SharePoint-80 where is the working instance and in the SharePoint-90, everything default and again they all hanged in Waiting for Resource.

    Hanged instance creations

    If I try to create the instance using PowerShell I got the following error:

    PS C:\Users\epm_setup> Mount-SPProjectWebInstance -DatabaseName Test_EPM -SiteCo
    llection http://acme02/epm -Lcid 1046
    Mount-SPProjectWebInstance : Cannot find an SPSite object with Id or Url:
    http://acme02/epm.
    At line:1 char:1
    + Mount-SPProjectWebInstance -DatabaseName Test_EPM -SiteCollection
    http://acme02/ ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ~~~
        + CategoryInfo          : InvalidData: (Microsoft.Offic...ountPwaInstance:
       PSCmdletMountPwaInstance) [Mount-SPProjectWebInstance], SPCmdletPipeBindEx
      ception
        + FullyQualifiedErrorId : Microsoft.Office.Project.Server.Cmdlet.PSCmdletM
       ountPwaInstance

    All SharePoint and Project Server services are running, all App Pools and sites are started at the IIS. I could not find a hanging timer job.

    I cannot stop the hanged process or dismount the instances using Powershell since no instance created.

    How should I solve the hanging status of creation of the instance? As they are in Hyper-V I can go back using one snapshot.

    Thank you.


    Best regards, Ricardo Segawa - Segawas Projetos / Microsoft Partner



    • Edited by R.Segawa Thursday, March 20, 2014 10:31 PM
    Thursday, March 20, 2014 10:19 PM

Answers

All replies

  • Ricardo,

    From reading, it would seem you have done a few things, let's confirm:  1. you have made copies of the content db and restored in the same farm.  2. you have made copies of the project db and restored in the same farm.  And you are trying to attach the same DB's to a different web app, even multiple copies.

    OK, so, what happens if you just provision plain / fresh / new instances on the port 90 web app?  does that work?  it should.

    Overall, I have yet to attempt what you show in 2013, but based on 2010, this is not going to work out well.

    I know you can accomplish (well, what you really want are clones of your existing pwa) if you use fresh instances.

    Cloning into the same farm I typically dont' do.  Many PWA instances, sure, but not clones.

    You can create the empty instances and use our friends over at FluentPro - FluentBooks to migrate configuration, if required.

    http://www.fluentpro.com/productsfluentbooks2013.html

    Hope this helps,


    Thanks, Eric S. Pcubed

    Friday, March 21, 2014 3:35 PM
  • Hi Eric,

    Thank your for your interest in this case.

    I checked for running and crashed PWA jobs and deleted all of them just after restoring the snapshot and tried to create the new instance in the new web app in port 90 (besides the existing and working instance in port 80), but again it hanged in "waiting for resources". There is not any timer job hanging, no error in event viewer or in log. So the error is well before working with cloned dbs.

    Answering your questiion, I am working all on 2013. My intention is backup one instance of the port 80 and copy to the instance of port 90, changing of course the url and the index of the content db of SharePoint. The process I used was:

    1. Create a new web app in port 90, creating a new SharePoint_Content_2 on a http://server:90 site.
    2. Created the top level site called Portal using the Team Site template.
    3. Create a new content db for new instance of Project Server named EPM_Content_2 using Central Admin.
    4. Backup content db from port 80 instance of Project Server and restore to this EPM_content_2 using PowerShell cmd.
    5. Dismounted and mounted this Project Server content db to create new index for existing sites to avoid index conflicts.
    6. Backup the Project Server DB from port 80 using SQL backup and restored as ProjectWebApp2 db for port 90 instance.
    7. Tried to create a new instance of Project Server http://server:90/pwa on web app of port 90 using the ProjectWebApp2 db and using the same app pool of the other instance. But as in the previous case, it hang out in "Waiting for resources".


    Best regards, Ricardo Segawa - Segawas Projetos / Microsoft Partner


    • Edited by R.Segawa Monday, March 24, 2014 7:22 PM
    Monday, March 24, 2014 7:20 PM
  • I think you will find this helpful.  Applies to 2010 or 2013.

    http://anexinetsp.blogspot.com/2013/10/issues-with-cloning-existing-content.html

    Thanks,


    Thanks, Eric S. Pcubed

    • Marked as answer by R.Segawa Tuesday, March 25, 2014 6:34 PM
    Monday, March 24, 2014 7:51 PM
  • Hi Eric,

    Thank you for the reference.

    Although my instance is very small, the steps are the same I am using.

    I think I need to solve another question before cloning the instance, which is make the create a new instance run with or without cloning an instance.

    I will open another question about it.

    Thank you for your help.


    Best regards, Ricardo Segawa - Segawas Projetos / Microsoft Partner

    Tuesday, March 25, 2014 6:37 PM