none
[Exchange 2013]Does not exchange support widecard smtp address?

    Question

  • Hi ,everyone,

    I am trying to make exchange 2013 works in following way:

    We have several email address for public , like  

    help@mycustomersupport.com,

    help1@mycustomersupport.com,

            ........

    I want all of above email received, go to  the mailbox with default smtp address customersupport@mydomain.com.

    I am trying to accomplish in this way:

    1.  the exchange default domain is mydomain.com

    2. Add  mycustomersupport.com as authorized accept domain.

    3. update mailbox customersupport@mydomain.com, add a  smtp address binging to "*@mycustomersupport.com

    But it does not work,

    Exchange reply NDR for user mailbox not found , testing with email send to help@mycustomersupport.com

    Would anyone suggest any approach? Does exchange support widecard smtp like *@mycustomersupport.com?

    Thursday, September 24, 2015 1:39 AM

Answers

All replies

  • That is not supported.  You might be able to accomplish what you want with a transport rule.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Thursday, September 24, 2015 3:35 AM
    Moderator
  • Hi,

    For your question, I want to ensure some points, please help to collect answers for further troubleshooting:
    1. How about mail flow to help@mycustomersupport.com before add mycustomersupport.com as accept domain?
    2. Do you add relevant MX record and A record for mycustomersupport.com, also point to your Exchange server?

    If you want send message from external to mycustomersupport.com and redirect message to customersupport@mydomain.com, we need ensure the mail flow between external and mycustomersupport.com first.
    Then we can use transport rule to redirects the email message to one or more specified recipients, more details about it, please refer to: https://technet.microsoft.com/en-us/library/aa998315(v=exchg.150).aspx


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Allen Wang
    TechNet Community Support

    Friday, September 25, 2015 5:41 AM
    Moderator
  • Thanks Ed and Allen,

    1. the email will just lost, as the exchange server has open reply disabled.

    2. Yes, DNS has been setup correctly.

    Actually , I have tried with transport rules, which redirect email to customersupport@mydomain.com

    However, since I have too many  helpXXXXXXX@mycustomersupport.com and these email addresses actually do not have related mailbox.

    Although email can be delivered to customersupport@mydomain.com, Exchange will still reply NDR anyway, with user does not exist.

    Friday, September 25, 2015 6:59 AM
  • Hi Jun,

    Since those email address do not have related mailbox, Exchange server will reply NDR with user do not exist. It's normally. For your question, you can create relevant mailbox for @mycustomersupport.com address by email address policy.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Allen Wang
    TechNet Community Support

    Tuesday, September 29, 2015 2:05 AM
    Moderator
  • What you want is a "catch-all" mailbox.  Here's one article that describes a potential solution, and there may be others.

    http://www.techieshelp.com/create-a-catch-all-mailbox-in-exchange-2013/


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    • Marked as answer by Jun Zhou Wednesday, October 7, 2015 1:46 AM
    Tuesday, September 29, 2015 3:26 AM
    Moderator