none
https://support.microsoft.com/en-au/help/4009938/january-10-2017-kb3213986-os-build-14393-693 RRS feed

  • General discussion

  • Addressed issue that prevents users from opening Internet shortcut (.URL) files with Internet Explorer when Enhanced Protected Mode is enabled. 

    Seems to be breaking Zone 'Protected Mode', When turned Off, all websites show navigator.platform as Win32, expected Win64 for Internet and Restricted zones, expected Win32 for intranet and restricted zones.

    Seems to be causing Tasks manager to show 100% disk usage When turned on.


    Rob^_^

    Tuesday, January 24, 2017 11:29 PM

All replies

  • Seems to be breaking Zone 'Protected Mode', When turned Off

    You just made me check.  I left EPM on because it seemed innocuous but now I see using Alt-F r that Protected Mode is (being reported) Off!  WTH?  I didn't use the EPM=64-bit thing because I thought mixed would be more interesting.  I use wmic or PowerShell (or just Task Manager) for Commandline to show which platform iexplore.exe tab tasks are on. 

    We told them that using Administrator mode was a workaround for the problem.  Is this how they implemented the fix?  Internet Options still show that Internet zone sessions should be opened in Protected Mode, so something is definitely "off".   ; )

    Task Manager is slow starting but I don't have any kind of Disk problem with it.  I have been assuming that my performance issues were only due to being stupid about not closing things as soon as possible but letting some tasks, especially IE, build up a ridiculous number of open tabs.



    Robert Aldwinckle
    ---

    Thursday, January 26, 2017 4:47 AM
    Answerer
  • Hi Robert,

    this blog post will clear things up -

    https://blogs.msdn.microsoft.com/asiatech/2013/12/25/how-internet-explorer-enhanced-protected-mode-epm-is-enabled-under-different-configurations/

    you can use proc explorer to indeed confirm the bit-ness and integrity of tabs.

    Unfortunately I also did an Advanced settings reset at the same time, and the default settings for EPM and PM features were blown away... and the require x64 processes was unchecked, making x64 iexplore only load 32bit low tabs for all security zones.. (viz: x86 emulation on a x64 CPU)


    Rob^_^

    Thursday, January 26, 2017 9:46 PM
  • blog post will clear things up -

    Yes.  I have EPM in IE10 functionality burnt in my brain apparently

    <quote>

    Is it IE10 or IE11?

    The final decision will be 64bit process + AppContainer IL, if it is IE10.

    • However if it is IE11, it will check if “Enable 64-bit processes for Enhanced Protected Mode*” is enabled in Internet Options.

    It will be 64bit, only when this feature is checked, otherwise IE will still use a 32bit process.

    </quote>

    Thanks.



    Robert Aldwinckle
    ---

    Friday, January 27, 2017 6:47 PM
    Answerer
  • I left EPM on because it seemed innocuous but now I see using Alt-F r that Protected Mode is (being reported) Off!

    So what is the point of EPM if, by default, it will run 32-bit tasks without normal Protected Mode?  I suppose I will have to run ProcMon to try to understand what is really happening with this set of options but it certainly doesn't give me any comfort running like this.  I only tried it to observe some quirks that others had reported.


    Robert Aldwinckle
    ---

    Saturday, January 28, 2017 2:11 PM
    Answerer