none
Farm backup giving error RRS feed

  • Question

  • Hi all,

    I am trying to taking backup using farm backup in central admin site. but the backup is not complete successfully and its giving error not found specified path like that..

    I want to share some information. Actually i re installed sharepoint server 2010 and project server 2010 but my database server remain same. and i didn't delete previous database like config database of previous sharepoint site and search service database and secure service database. and configure sharepoint site and PWA site again. so now in my database server there are so many database like 2 secure store and 2 admin content etc. and i found error occurred only with new database which has created after re instillation. so i want to know can i delete older databases.   it is safe for my all site?? it is working fine or not..after deleting these databases i would take a farm backup??

    Please suggest me what should i do...please help me ASAP...

    Thanks

    Wednesday, December 19, 2012 7:49 AM

Answers

  • Hi Vivek,

    First of all, you want to clean up the SharePoint2010/PS2010 farm. There are several Windows PowerShell cmdlets you can use to find all of the SharePoint databases and then print this report to a text file. The quickest and perhaps easiest cmdlet is “Get-SPDatabase”. Run this cmdlet in the SharePoint 2010 Management Shell to list all of the SharePoint Server databases with properties for each one.

    if the Old databases are not used by Web app/Central Admin & Secure Store, You can safely delete these DBs.
    Please see below artcile that will help you to clean up the Farm. 
    http://blogs.technet.com/b/tothesharepoint/archive/2011/12/19/find-active-databases-used-by-sharepoint-server-2010.aspx

    Once you get the Farm cleaned up, you may want to use the Farm backup using CA, Please make sure that you give the correct UNC path & permissions of SQL account to the shared folder.

    Please let us know the result, Will try to help.

    Thanks,


    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”. Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82

    • Marked as answer by Vivek S Tomar Wednesday, December 19, 2012 10:32 AM
    Wednesday, December 19, 2012 10:01 AM

All replies

  • Hi Vivek,

    First of all, you want to clean up the SharePoint2010/PS2010 farm. There are several Windows PowerShell cmdlets you can use to find all of the SharePoint databases and then print this report to a text file. The quickest and perhaps easiest cmdlet is “Get-SPDatabase”. Run this cmdlet in the SharePoint 2010 Management Shell to list all of the SharePoint Server databases with properties for each one.

    if the Old databases are not used by Web app/Central Admin & Secure Store, You can safely delete these DBs.
    Please see below artcile that will help you to clean up the Farm. 
    http://blogs.technet.com/b/tothesharepoint/archive/2011/12/19/find-active-databases-used-by-sharepoint-server-2010.aspx

    Once you get the Farm cleaned up, you may want to use the Farm backup using CA, Please make sure that you give the correct UNC path & permissions of SQL account to the shared folder.

    Please let us know the result, Will try to help.

    Thanks,


    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”. Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82

    • Marked as answer by Vivek S Tomar Wednesday, December 19, 2012 10:32 AM
    Wednesday, December 19, 2012 10:01 AM
  • Hi Amit,

    Thanks for reply. it is helpful to me.

    I want to ask one thing that you mentioned if the old database are not used by your farm or PWA or share point, delete it. 

    But i want to know , how can i know it is usable or not. and one more thing i want to share, i have checked same database name with their Property and also check the date of creation of these databases. then i think, can i delete those database which are created previously.

    Actually it happens with my Live and clients Production server. that is why i am very careful to do anything . so please suggest me can i delete the old database??

    Thanks

    Wednesday, December 19, 2012 10:32 AM
  • Hi Vivek,

    Yes, This activity is associated with the Risks so Please make sure that you have the backups ready for any diasters..
    Ok, For project server, You can easily check the database used. You can go to the CA> manage web application & see what is the Content database used. Ok, Now, You can go to Manage Service applications & go to PWA site & try to view the details of PWA site using item level menu . You can see what are the project server databases (Draft/Published/Reporting & Archieve) associated with PWA instance. 

    Note down all the related databases & have a Database Admin with you to make it safe process. may be you can take the database offiline where you have any doubt & check the application. 

    Hope that helps.


    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”. Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82

    Wednesday, December 19, 2012 11:28 AM
  • Hi Amit,

    I have deleted older database successfully and CA and PWA is working fine. but still i am unable to take a farm backup. i have created new shared folder but it is giving error regarding my sharepoint config database and others. the error is:

    Object MY_SharePoint_Config failed in event OnBackup. For more information, see the spbackup.log or sprestore.log file located in the backup directory.

    SqlException: Cannot open backup device 'E:\new Farm Backup\spbr0000\000000A7.bak'. Operating system error 3(The system cannot find the path specified.).

    BACKUP DATABASE is terminating abnorsmally.

    Please let me know what should i do.

    Thanks

    Thursday, December 20, 2012 10:36 AM
  • Great!!!

    having said that please use the UNC path.(\\SharedDrive\Folder) where you want to get the backup. keeping the Direct Drive name (E:\) sometimes doesn't work.
    You may try first giving the E:\new Farm Backup & SQL account with Write permissions on "new Farm Backup " folder (May be you can remove the spaces in new Farm Backup  ).

    If that doesn't work, Please create a shared folder on server & keep the SQL account with Write permissions.

    Hope that helps.


    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”. Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82


    Thursday, December 20, 2012 11:01 AM
  • Hi, 

    sorry, but i am not getting what you want to say. because except this database all database and other thing is backed up. and before my re installation, i had already given similar path and it was working fine. but now i am getting problem. i am totally confused.

    Please suggest...

    Thanks

    Thursday, December 20, 2012 11:06 AM
  • Thanks.

    I was doing a silly mistake...thanks for you help....

    Backup successful.

    Friday, December 21, 2012 6:06 AM
  • Cheers !!

    Glad that I was able to help.

    Thanks.


    If you found this post helpful, please “Vote as Helpful”. If it answered your question, please “Mark as Answer”. Thanks, Amit Khare |EPM Consultant| Blog: http://amitkhare82.blogspot.com http://www.linkedin.com/in/amitkhare82

    Friday, December 21, 2012 6:50 AM