none
Issue with Capture Task Option showing correctly in MDT 2013 RRS feed

  • Question

  • I am aware that having the variable of DomainJoin will prevent the capture dialog from appearing when running the task. The problem is, even when the options are greyed out due to the domain settings not being applied from a different setting in the workflow it still breaks the task. 

    E.G.

    I am using the database, and have my workflow as such:

    [Settings]
    Priority=Model, TaskSequenceID, LSettings, CRoles, RApps, LApps, MMApps, MMSettings, Default
    Properties=MyCustomProperty

    DataBase:

    Location Settings: Overall settings for Domain join, wizard skips, etc info per gateway 

    Role Apps: Apps per role

    Make/Model Apps: Apps specific to a piece of hardware

    CustomSettings INI:

    Model/Task Sequence/Default:  I have tried to null out the DomainJoin settings with these variables by adding workgroup join by task ID, Model, etc and nothing seems to work. I've verified in other tasks that these settings take place of  what's in the DB, but the DB settings are still there, greyed out and causing an issue. 

    [X86SYSANDCAP]
    JoinDomain=
    JoinWorkgroup=WORKGROUP

    [VMware Virtual Platform]
    JoinDomain=
    JoinWorkgroup=WORKGROUP

    As shown below the model/TS specify the workgroup  (1st pic is normal deploy, 2nd is cap) but the greyed out settings are still having an effect. Skip Capture is set to NO at each level, and when I remove the Domain from the DB it shows up correctly. 

    Not sure what to do besides removing the domain everytime I want to do a capture, which seems a bit unreasonable and I don;t want my T1s in the DB. 





    • Edited by Scrivnet78 Saturday, December 20, 2014 5:36 PM
    Saturday, December 20, 2014 5:36 PM

Answers

  • I appreciate both the replies, however it seems as though this is an issue within MDT itself and cannot be overcome. 

    It doesn't matter whether you use a native capture task, or modify a standard task, the result is the same if JoinDomain is populated in any way. I saw a blog post on the "Microsoft Deployment Toolkit Team Blog" stating this but of course I can't find it now. 

    It'd be nice if MDT could recognize when you are trying to null out a variable when it doesn't apply, but it doesn't seem to have the ability. 

    At this point my options are a second share just for caps, or remove the gateway from the database for the duration of the task. 


    Nathaniel Scriven


    Monday, December 22, 2014 11:41 AM

All replies

  • I believe that checkbox is controlled by the "DoCapture" setting.  Maybe try setting that to "YES" when running a Task Sequence from Windows and NOT WinPE.

    Priority=OSVersion, Default

    ...

    [WinPE]
    DoCapture=NO

    [Default]
    DoCapture=YES


    -BrianG (http://supportishere.com)

    Sunday, December 21, 2014 2:57 AM
  • I highly recommend to always use the standard Client task sequence for a build and capture. Much more reliable.

    Check out these Resources, the info is also valid for Windows 7:

    TechNet Docs - Create a Windows 8.1 Reference Image
    http://technet.microsoft.com/en-us/library/dn744290.aspx

    Virtual Hands-On-Labs - Creating a Windows 8.1 reference image  
    http://go.microsoft.com/?linkid=9845755

    How to deploy Windows 8.1 (and Windows 7) with MDT 2013 - The Resources
    http://www.deploymentresearch.com/Research/tabid/62/EntryId/186/How-to-deploy-Windows-8-1-and-Windows-7-with-MDT-2013-The-Resources.aspx

    / Johan


    Regards / Johan Arwidmark Twitter: @jarwidmark Blog: http://www.deploymentresearch.com FB: www.facebook.com/deploymentresearch

    Monday, December 22, 2014 1:12 AM
    Moderator
  • I appreciate both the replies, however it seems as though this is an issue within MDT itself and cannot be overcome. 

    It doesn't matter whether you use a native capture task, or modify a standard task, the result is the same if JoinDomain is populated in any way. I saw a blog post on the "Microsoft Deployment Toolkit Team Blog" stating this but of course I can't find it now. 

    It'd be nice if MDT could recognize when you are trying to null out a variable when it doesn't apply, but it doesn't seem to have the ability. 

    At this point my options are a second share just for caps, or remove the gateway from the database for the duration of the task. 


    Nathaniel Scriven


    Monday, December 22, 2014 11:41 AM
  • A few years back, for one customer we wrote a userexit that set joindomain value for most machines, but replaced it with joinworkgroup for some specific mac addresses, including different wizard panes, so it's doable to have a single deployment share, it's just ugly.

    In the end we created two deployment shares which most MDT customers have. One for build and capture, and one for production deployment. Much easier to manage and troubleshoot.

    / Johan


    Regards / Johan Arwidmark Twitter: @jarwidmark Blog: http://www.deploymentresearch.com FB: www.facebook.com/deploymentresearch

    Monday, December 22, 2014 2:58 PM
    Moderator