none
No data in enterprise custom field after publish RRS feed

  • Question

  • Hello,  we're running Project Server 2010 with Project Professional 2010 as well.

    On our test server, I created an enterprise custom field:  Entity - Task.  Type - Text.  No formula, no lookup table.

    I added that field to one of our test projects in Project Professional and added values for each task.  I saved the project and then published it without any issues.

    I added that custom field to the view for Tasks and Timesheet but when I view either one, the field is there but there's no data.  It's blank for every task.

    When I reopen the project in Project Professional, the values are still there for that custom field and I can't understand why it's not populating in PWA.

    Any help would be greatly appreciated!

    Thanks,

    Andre

    Friday, August 23, 2013 6:18 PM

Answers

  • Hi Andre --

    When you configure the Enterprise Task Custom Field, you will need to set the following in order to see the data on the 'Tasks' or 'Timesheet' page in PWA:

    • Calculation for Assignment Rows: Roll down, unless manually specified

    The information on those two PWA pages represents assignments... not tasks that you would normally see in an MS Project task view. Therefore, when you select or enter a value into the custom field at the task level, you need to ensure that the value cascades down to the assignment level (one level "deeper") in order for it to appear on the PWA 'Tasks' or 'Timesheet' page. You can see this in action by applying an assignment view in MS Project such as the 'Task Usage' view.

    Also be sure to do the following after making the change to the custom field definition via PWA Server Settings:

    • Restart MS Project and connect to the Project Server.
    • Open the project and force a project recalculation ('Project' ribbon > 'Calculate Project').
    • Save and publish the project.

    Finally, if the value appears on the PWA 'Tasks' page but not on the 'Timesheet' page, try deleting the timesheet and re-creating it.

    Good luck!

    -- tz


    Tony Zink | Vice President, EPMA | http://www.epmainc.com | Blog: http://www.epmablog.com | Training: http://www.epmainstitute.com

    Tuesday, August 27, 2013 3:09 PM

All replies

  • Anyone?
    Tuesday, August 27, 2013 1:25 PM
  • Hi Andre --

    When you configure the Enterprise Task Custom Field, you will need to set the following in order to see the data on the 'Tasks' or 'Timesheet' page in PWA:

    • Calculation for Assignment Rows: Roll down, unless manually specified

    The information on those two PWA pages represents assignments... not tasks that you would normally see in an MS Project task view. Therefore, when you select or enter a value into the custom field at the task level, you need to ensure that the value cascades down to the assignment level (one level "deeper") in order for it to appear on the PWA 'Tasks' or 'Timesheet' page. You can see this in action by applying an assignment view in MS Project such as the 'Task Usage' view.

    Also be sure to do the following after making the change to the custom field definition via PWA Server Settings:

    • Restart MS Project and connect to the Project Server.
    • Open the project and force a project recalculation ('Project' ribbon > 'Calculate Project').
    • Save and publish the project.

    Finally, if the value appears on the PWA 'Tasks' page but not on the 'Timesheet' page, try deleting the timesheet and re-creating it.

    Good luck!

    -- tz


    Tony Zink | Vice President, EPMA | http://www.epmainc.com | Blog: http://www.epmablog.com | Training: http://www.epmainstitute.com

    Tuesday, August 27, 2013 3:09 PM
  • Thanks Tony..all I had to do was select the 'Roll Down' option for each custom field and voila!  It works!

    Thanks again Tony!

    André

    Tuesday, August 27, 2013 4:25 PM
  • You're welcome, Andre!

    -- tz


    Tony Zink | Vice President, EPMA | http://www.epmainc.com | Blog: http://www.epmablog.com | Training: http://www.epmainstitute.com

    Tuesday, August 27, 2013 4:46 PM