Microsoft Machine Learning Server 9.3.0 install failure on windows 10. RRS feed

  • Question

  • Hello,

    When attempting to install ML server 9.3 on windows 10 I get an error that results in a rollback (which also deletes R for any SQL server I attempt to bind to).  I am on a development environment and 9.3 install has worked in the past so I am fairly confused by the error.  I can post the full log if need be but the error seems to be here:

    MSI (s) (34:10) [08:48:20:050]: Executing op: ActionStart(Name=InstallAdminCliExtension,Description=Installing operationalization admin extension,)
    CAQuietExec:  Configuration completed: MslServer
    MSI (s) (34:10) [08:48:20:051]: Executing op: CustomActionSchedule(Action=InstallAdminCliExtension,ActionType=3073,Source=BinaryData,Target=CAQuietExec,CustomActionData="cmd.exe" /c start /wait /min /D "C:\Program Files (x86)\Microsoft SDKs\Azure\CLI2" Scripts\az extension add -y -s "C:\Program Files\Microsoft\ML Server\\Setup\azure_ml_admin_cli-0.0.1-py2.py3-none-any.whl" --debug)
    MSI (s) (34:4C) [08:48:20:054]: Invoking remote custom action. DLL: C:\WINDOWS\Installer\MSIA2C7.tmp, Entrypoint: CAQuietExec
    CAQuietExec:  The system cannot find the file Scripts\az.
    CAQuietExec:  Error 0x80070001: Command line returned an error.
    CAQuietExec:  Error 0x80070001: QuietExec Failed
    CAQuietExec:  Error 0x80070001: Failed in ExecCommon method
    CustomAction InstallAdminCliExtension returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
    MSI (s) (34:10) [08:48:20:107]: Note: 1: 2265 2:  3: -2147287035 
    MSI (s) (34:10) [08:48:20:108]: User policy value 'DisableRollback' is 0
    MSI (s) (34:10) [08:48:20:108]: Machine policy value 'DisableRollback' is 0
    Action ended 8:48:20: InstallFinalize. Return value 3.

    something about being unable to find the file scripts\az.  I have no idea where it's looking but scripts\az seems to be located in the azure CLI2 location.  Either way there seems to be a problem.  There are two windows 10 PCs that are having this error now and they used to not have this error.

    Any help would be appreciated



    Wednesday, April 3, 2019 2:04 PM

All replies

  • can you check this path exists? 
    "C:\Program Files (x86)\Microsoft SDKs\Azure\CLI2"
    Thursday, May 16, 2019 9:33 PM
  • C:\Program Files (x86)\Microsoft SDKs\Azure\CLI2 exists and in that directory \scripts\az also exist.

    Edit: Oh I also tried it in my system paths environment.

    Right now the only workaround I've found is to install it with the group policy for rollback disabled and since I don't need Azure running I don't go through the steps to activate anything.  If needed I can manually activate things using cmd or powershell.

    • Edited by Nicholas Skradski Friday, May 17, 2019 1:10 PM path may mean env var not folder location. Also added info on workaround.
    Thursday, May 16, 2019 9:38 PM