locked
Adding new server to farm: Configuration failed. GUID should contain 32 digits RRS feed

  • Question

  • Hello -

    I was trying to add a new app server to our existing SP2013 farm.   Got all of the KBs installed, entered the passphrase, and finally errors out with configuration failed error.   The PSC Diag log oddly shows SP 2010 in the beginning of the trace log.   See below.   I did not copy over any of the files from old app to new app server in the 14.0 directory.   Is that required? 

    Begin trace logging for SharePoint 2010 Products Configuration Wizard.  Version 15.0.4881.1000

    .

    .

    .

    11  ERR                                                Exception: System.FormatException: Guid should contain 32 digits with 4 dashes (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx).
       at System.Guid.GuidResult.SetFailure(ParseFailureKind failure, String failureMessageID, Object failureMessageFormatArgument, String failureArgumentName, Exception innerException)

    Saturday, October 5, 2019 2:08 PM

Answers

  • I was able to resolve error by deleting the 0 from here:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server extensions\15.0\WSS\InstalledProducts

    • Marked as answer by XRS Saturday, October 5, 2019 2:18 PM
    Saturday, October 5, 2019 2:18 PM

All replies

  • Saturday, October 5, 2019 2:17 PM
  • I was able to resolve error by deleting the 0 from here:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server extensions\15.0\WSS\InstalledProducts

    • Marked as answer by XRS Saturday, October 5, 2019 2:18 PM
    Saturday, October 5, 2019 2:18 PM