locked
Microsoft store instantly crashes. RRS feed

  • Question

  • TO START OFF, I AM ON WINDOWS 10! I'd be more than happy to repost this elsewhere if given the proper forum but I couldn't find it.

    So this all started when i noticed Skype was constantly opening on startup(even though i never downloaded it nor do i even have a cam or mic but okay) so i went ahead and uninstalled it. After doing so I noticed that even after deleting it it had still left two folders within the hidden "WindowsApps" folder under Program Files, So i tried deleting those and was prompt with something like "Access Denied you have no permissions blah blah" anyway so I changed the owner of the entire folder to myself and clicked "Replace owner on subcontainers and objects". was able to delete it and tried opening the microsoft store just on a whim and there it begun, I clicked it, It showed the blue background and logo on screen and probably 2 seconds later it just vanished. No trail left behind.. Since then i've been messing with the permissions and all that and tried to uninstall and reinstall it in powershell(and yes i made sure i opened as admin just in case) and entered the following lines of code:

    Get-AppxPackage *windowsstore* | Remove-AppxPackage

    then at this point I was told to restart but didn't. But anyway I then entered what i assume was the reinstall code:

    Get-AppXPackage *WindowsStore* -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

    I THEN shut down my pc and turned it back on. Didn't work... Now I was at a loss.. So I then messed around with the permissions again with no avail so i retried the powershell method and now i'm at where i'm at now which is the Microsoft Store is completely freaking gone.. I assumed maybe i forgot to type in the reinstall code so i tried that and now i'm getting this error: 

    Add-AppxPackage : Deployment failed with HRESULT: 0x80070005, Access is denied.
    error 0x80070005: Opening file from location: AppXManifest.xml failed with error: Access is denied.
    .
    NOTE: For additional information, look for [ActivityId] 7b1eada8-758d-0000-6cd0-1e7b8d75d401 in the Event Log or use
    the command line Get-AppxLog -ActivityID 7b1eada8-758d-0000-6cd0-1e7b8d75d401
    At line:1 char:61
    + ...  | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.I ...
    +                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : SecurityError: (C:\Program File...ppXManifest.xml:String) [Add-AppxPackage], PSSecurityE
       xception
        + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand
    

    Throughout this entire process i've tried resetting the store threw the info tab and i believe that's what i've done to get here. i think what happened is i uninstalled and reinstalled it. turned off my pc and back on and then reset the store. After doing so it completely reset the permissions of the "WindowsApps" folder so i set them back to what i've seen online. The owner being "NT Service\TrustedInstaller" I also clicked "Replace owner on subcontainers and objects" again and made sure that went threw. Since the reset though there were no one on the security tab of that folder i added myself with full control. Anyway that's where i'm at right now.. 

    Tuesday, November 6, 2018 6:02 AM

All replies

  • I am facing the same problem. i tried all the given troubleshooting method. i even reset my whole system.

    Tuesday, April 2, 2019 1:34 PM