locked
Shutdown not displayed RRS feed

  • Question

  • Hi,
    I have a Windows XP Pro VM running on a Windows 64 Bit host.

    I don't see Shutdown in the start menu and when I close it from the Windows Virtual PC menu, I get a prompt about "If you shut down this remote computer, no one can use it until someone ath the remote location manually restarts it. Do you want to continue shutting down?"

    What is going on!?

    I acts like it is running in an RDP session.


    Best regards,
    Ken
    Friday, January 29, 2010 4:45 PM

Answers

  • Enabling Integration features does it!
    I disabled them and now it works correctly.

    Can you explain that for me?

    Thanks Brian.

    Best regards,
    Ken



    • Marked as answer by iatricKK Friday, January 29, 2010 8:00 PM
    Friday, January 29, 2010 5:50 PM

All replies

  • Technically, you are running in an RDP session.  Therefore it behaves that way.

    You can modify the behavior through Group Policy (using the standard Terminal Server behavior tweaks).

    Brian Ehlert (hopefully you have found this useful)
    Friday, January 29, 2010 5:17 PM
  • Thanks for taking the time to reply Brian.

    I am still "green" on virtualization. Are you saying the virtualization technology itself is based on RDP technology?
    I don't have this problem on any other VM's I use.

    I tried this method...but no luck.
    http://superuser.com/questions/65096/why-does-windows-7s-virtual-pc-running-win-xp-professional-have-no-shut-down-b

    Still only displays Log Off and prompts me about other users being connected.

    Friday, January 29, 2010 5:44 PM
  • Enabling Integration features does it!
    I disabled them and now it works correctly.

    Can you explain that for me?

    Thanks Brian.

    Best regards,
    Ken



    • Marked as answer by iatricKK Friday, January 29, 2010 8:00 PM
    Friday, January 29, 2010 5:50 PM
  • Virtualization isn't based on the RDP technology, but Windows VPC uses RDP as the graphical interface for the VM if you're running with the Integration components (IC) enabled. 

    If you disable the IC, you disable RDP and the VM is displayed differently.  With the IC disabled you have "native" access to the VM, you get shutdown, etc.

    The easiest and quickest way to add shutdown to your VM is to create a shutdown.cmd file on your desktop and add this line

    shutdown -s -t 00



    Why do you need to shutdown the VM?

    • Proposed as answer by BrianEhMVP Friday, January 29, 2010 10:26 PM
    Friday, January 29, 2010 5:54 PM
  • I was actually trying to start a secure VPN connection from the VM and it complained that it couldn't run in a remote session.

    Thanks for your reply smjain.

    Best regards,
    Ken
    Friday, January 29, 2010 8:00 PM
  • In that case, just turn off the IC, and you will be out of the remote session.
    Friday, January 29, 2010 9:38 PM
  • @BrianEh - what are "the standard Terminal Server behavior tweaks"?  I've been Binging this all morning and this is the only reference I've found to turning it off with group policy.
    Sunday, August 12, 2012 6:41 AM
  • @BrianEh - what are "the standard Terminal Server behavior tweaks"?  I've been Binging this all morning and this is the only reference I've found to turning it off with group policy.

    http://tinyurl.com/8lpu42f

    http://technet.microsoft.com/en-us/library/cc770884(v=WS.10).aspx



    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Sunday, August 12, 2012 3:03 PM