none
Symbolic link type changed

    Question

  • We have been using symbolic intensively to archive historic files. An automatic script would create symbolic links regularly based on certain criteria. Users don't experience inconvenience as the soft links can be opened as regular files, programs will run without issues, and the type of those soft links are identical to the type of file it has a link to (for example, a symbolic link to an Excel file will have Excel file type in its properties). However, recently we have noticed that the type of links has changed to SYMLINK which makes Windows to ask users to choose what program to open with by popping up the "Open With.." window.

    Do you guys what will affect the file server to change its behavior and represent symbolic links type as SYMLINK and create additional troubles?

    Tuesday, April 14, 2015 4:40 PM

Answers

  • Hello Frank,

    The problem is solved by uninstalling the following update on both the file server and a client computer: KB3039066.

    Frank,

    Is there any way to report this to Microsoft ? And probably include a fix into future updates?

    Thanks

    • Marked as answer by SkunkWorker Monday, May 11, 2015 10:23 AM
    Monday, May 11, 2015 10:23 AM

All replies

  • Hi,

    >>recently we have noticed that the type of links has changed to SYMLINK which makes Windows to ask users to choose what program to open with by popping up the "Open With.." window.

    Were the file type of all symbolic links changed or just some ones? Besides, can we change the file type back? If this happened to all symbolic links, it's suggested that we can check the recent changes we made to the computer and see if they are related to this. If this just happened to some symbolic links and in case that this was done by some user,  we can try to enable audit for these links to record who modifies the files in the future.

    Best regards,

    Frank Shen


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, April 16, 2015 8:11 AM
    Moderator
  • Hi Frank,

    Thanks for your reply. It has happened to all symbolic links residing on one file server. The only change to the server I can think of is Windows Updates which have been installed two weeks earlier the day we noticed the problem. And now the task is to identify which update has affected this. I will get back once we find out. Cheers.

    Monday, April 20, 2015 2:23 PM
  • Hello Frank,

    The problem is solved by uninstalling the following update on both the file server and a client computer: KB3039066.

    Frank,

    Is there any way to report this to Microsoft ? And probably include a fix into future updates?

    Thanks

    • Marked as answer by SkunkWorker Monday, May 11, 2015 10:23 AM
    Monday, May 11, 2015 10:23 AM
  • Hi ,

    I have been experiencing the same problem in my environment . All vista users are getting Open with box while opening symbolic links which have been created in Linux environment.

    I have uninstalled the patch too but same issue .

    Same link works fine on WIn  7 .

    Please help as there are many users who are facing the issue.

    Thanks

    Friday, October 02, 2015 12:22 PM
  • I have tried the same thing with no luck.

    Can you  please help ?

    Tuesday, October 27, 2015 2:18 PM