none
DPM Azure Configuration Passphrase RRS feed

  • Question

  • Hi 

    My Backup Config:
    1. Disk backups with DPM
    2. Then cloud backups to Azure Recovery Vault.

    I have been struggling with my DPM reconfiguration. 
    My backups failed because of a "Volume missing" error and I have checked and rechecked logs, I have tried repairing my OS, did hardware checks (Got Dell out to check the hardware), everything works fine for a few hours, when the replica is uploaded to Azure the volume crashes. Deleted the volume from DPM and from windows. Recreated it and works fine, as soon as it is uploaded it crashes and the OS becomes non responsive.

    I went so far to reinstall the Azure Agent and reconfigured the the Azure Connection and asked me to generate a new Passphrase but it gives me an "incorrect passphrase used".

    I have all the passphrases for the previous config, and that doesn't work either. I am puzzled. Please help..

    I have search how to change the passphrase, but the only results I could find is for Azure backup Manager

    Tuesday, December 3, 2019 2:56 PM

All replies

  • Hi,

    Could you give more information about your DPM environment?

    • DPM Server version and build.
    • DPM Server operating system.
    • DPM SQL Server version.
    • How many drives in the DPM pool.
    • How big is the DPM pool.
    • How big is the Scratch folder.
    • Is the DPM server physical / virtual.
    • What workloads are you trying to back up to Azure.

    Which logs did you check?

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Tuesday, December 3, 2019 4:52 PM
  • Hi Leon

    1. System Center 2019 ver: 10.19.58.0
    2. Windows Server 2016 Standard
    3. SQL Server 2017 v14.0.3238.1
    4. 1 drive
    5. 9TB which DPM uses 1.5TB
    6. Scratch folder 161MB
    7. DPM is a physical server
    8. Replica DATA Sizes up to 1.5TB, types are bare metals, DBs, flat Data, 

    I have checked Hardware logs, Raid logs, Diagnostic logs, eventvwr logs and DPM logs. I also checked CMS logs when running repairs to check if the are any corruption.

    Kind Regards

    Virgel

    Wednesday, December 4, 2019 6:41 AM
  • Thank you for the detailed information!

    I believe the Scratch folder is a bit small, the recommendation is for the scratch folder to be at least 5% of the data backed up to the cloud in size, preferably more. Try increasing the size of it, then try backing up again.

    If it doesn't help, could you upload the DPM log to OneDrive and I can try to have a look at it?

    The log is located here:

    • C:\Program Files\Microsoft System Center\DPM\DPM\Temp\MSDPMCurr.errlog

    It would be great if you could first move (cut > paste) the log, then let DPM create a new one and then reproduce  the "Volume missing" error within the DPM Console, this is only to avoid having excess events in the DPM log.


    Blog: https://thesystemcenterblog.com LinkedIn:

    Wednesday, December 4, 2019 7:58 AM
  • 

    Hi Leon

    I haven’t chosen the size of the folder. That’s the content of it.

    Below is my Crash logs.. I have uploaded it to my onedrive account and want to share it but I don’t have your email address.


    Wednesday, December 4, 2019 8:15 AM
  • Upload the log to a Google Drive or OneDrive, then share the link to it (you can share documents freely to anyone).

    Each machine you want to back up must have local free storage that's at least 5% of the size of the data that is being backed up. For example, backing up 100 GB of data requires a minimum of 5 GB of free space in the scratch location.

    The scratch location is defined when you register DPM to the Recovery Services Vault, the location can also be changed later on.


    Blog: https://thesystemcenterblog.com LinkedIn:

    Wednesday, December 4, 2019 8:46 AM
  • The Scratch location is on a drive with 8TB. Nothing else on the drive.

    https://drive.google.com/open?id=1-SascTxmqGTjwguoAbACvQbAxeugrOqu

    Wednesday, December 4, 2019 9:03 AM
  • Hi Leon

    I haven't heard from you since yesterday. Are you ok?

    Thursday, December 5, 2019 5:44 AM
  • I had a short look in the logs you've provided, I see there are a lot of "access is denied" messages.

    Could you provide some more detailed information on how the errors happen? What exactly are you doing when the errors occur?

    So you have DPM registered to a Log Analytics workspace but you cannot back anything up to Azure?

    Is the connection healthy between DPM and Azure? What is the registration status under Management > Online?

    If you could provide screenshots it would also help to better understand.


    Blog: https://thesystemcenterblog.com LinkedIn:

    16 hours 29 minutes ago
  • Hi Leon

    This is the reason for my request.
    I haven't changed my Azure Recovery Vault credentials, I haven't changed my Azure recovery passphrase, but I get access denied. 

    Yesterday I rebuilt my DPM server. New OS(Still W2016STD), DPM 2019, and SQL2017.

    I also downloaded the Azure agent after installing DPM and tried to register the Azure connection again. It successfully registered the connection but I still received the passphrase incorrect failure.

    I went so far to re-register the vault with a new passphrase, new scratch folder etc. Still the same.
    I am now in the process of creating a new Recovery vault and will see if this works. 

    Will my previous recovery points be lost? If so, could I delete the Old Recovery Vault
    • Edited by Virgel Jane 2 hours 1 minutes ago More info
    2 hours 4 minutes ago
  • Hi Leon

    Thanks for the help, I created a new Recovery Vault and now my DPM is finally backing up to the cloud.

    You may mark this as un-answered request as answered. 

    Thanks

    1 hour 34 minutes ago