locked
Exchange 2010 SP1 RU3 update database copy RRS feed

  • Question

  • LS,
    we have Exchange 2010 SP1 RU3 2 mailbox servers within DAG. Witin DAG 4 databases. All Databases are replicated except one.
    It says that a reseec update-mailbxox database copy is needed. When we do this via EMC we get the following error.
    ErrorMessage                     : The required log file 833638 for DAG01_DB01\
                                       servername is missing on the active copy. If
                                        you removed the log file, please replace it
                                       . If the log file is lost, the database copy
                                        will need to be reseeded using Update-MailboxDatabaseCopy.
    The log file is missing; so I want to do the update-mailboxdatabasecopy command. Removing off files is working after 4 hours the database is in the correct file location correct size. But we still have the same error. So upate command is not working correctly. De database is in failed and suspended mode. (resume copy is not working either
    The last log created and inspected and replayed is all 834618 Can I translate this number into a file name?
    Contentindexstate is healthy
    Th event log does not show many information then above mentioned log file is mising Eventid 4113 of the msexchangerpl service
    Hope to hear from you

     

     

    Saturday, August 20, 2011 5:13 PM

Answers

  • Hi Peter,

    Make sure that you run the below command first:
    Suspend-MailboxDatabaseCopy -Identity "Mailbox Database\ServerName"

    Did you tried with -DeleteExistingFiles switch?
    Update-MailboxDatabaseCopy -Identity DB1\MBX1 -DeleteExistingFiles
    http://exchangeserverpro.com/how-to-reseed-a-failed-mailbox-database-copy-in-exchange-server-2010


    Gulab | MCITP: Exchange 2010-2007 | Lync Server 2010 | Windows Server 2008 | Skype: Exchange.Ranger | Blog: www.ExchangeRanger.Blogspot.com
    • Edited by Gulab Prasad Sunday, August 21, 2011 5:28 AM update
    • Marked as answer by Gavin-Zhang Wednesday, August 31, 2011 1:48 AM
    Sunday, August 21, 2011 5:26 AM
  • Hi peter747,

    Please follow the link above:
    1. Confirm you have used the -deleteexistingfiles, and then make some tests.
    2. Confirm the resource active database healthy.

    Regards!
    Gavin

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.


    • Marked as answer by Gavin-Zhang Wednesday, August 31, 2011 1:48 AM
    Monday, August 22, 2011 9:20 AM
  • Hello Gavin,

    The issue is solved. I created 2 times a full backup on the active node. Update of the database copy then succeeded.

    Regards
    Peter

     

    • Proposed as answer by Martina_Miskovic Tuesday, August 30, 2011 9:02 AM
    • Marked as answer by Gavin-Zhang Wednesday, August 31, 2011 1:47 AM
    Tuesday, August 30, 2011 8:56 AM

All replies

  • Hi Peter,

    Make sure that you run the below command first:
    Suspend-MailboxDatabaseCopy -Identity "Mailbox Database\ServerName"

    Did you tried with -DeleteExistingFiles switch?
    Update-MailboxDatabaseCopy -Identity DB1\MBX1 -DeleteExistingFiles
    http://exchangeserverpro.com/how-to-reseed-a-failed-mailbox-database-copy-in-exchange-server-2010


    Gulab | MCITP: Exchange 2010-2007 | Lync Server 2010 | Windows Server 2008 | Skype: Exchange.Ranger | Blog: www.ExchangeRanger.Blogspot.com
    • Edited by Gulab Prasad Sunday, August 21, 2011 5:28 AM update
    • Marked as answer by Gavin-Zhang Wednesday, August 31, 2011 1:48 AM
    Sunday, August 21, 2011 5:26 AM
  • Hello Gulab,
    Offcourse the database was suspended; otherwise you don't have de update available as a menu option. (via the gui)

    Yes we used de deleteexistingfiles which works correctly db is gone a temp_seed directory exist with the database which is later on the de DB folder

    Regards
    Peter

     

    Sunday, August 21, 2011 11:02 AM
  • I would remove the database copy and remove all the files from the passive server and then add it back again.


    Martina Miskovic
    Sunday, August 21, 2011 12:12 PM
  • Hi peter747,

    Please follow the link above:
    1. Confirm you have used the -deleteexistingfiles, and then make some tests.
    2. Confirm the resource active database healthy.

    Regards!
    Gavin

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.


    • Marked as answer by Gavin-Zhang Wednesday, August 31, 2011 1:48 AM
    Monday, August 22, 2011 9:20 AM
  • Hi Peter,

    Any udpate for your issue?

    Regards!
    Gavin

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, August 25, 2011 7:05 AM
  • Hello Gavin,

    The issue is solved. I created 2 times a full backup on the active node. Update of the database copy then succeeded.

    Regards
    Peter

     

    • Proposed as answer by Martina_Miskovic Tuesday, August 30, 2011 9:02 AM
    • Marked as answer by Gavin-Zhang Wednesday, August 31, 2011 1:47 AM
    Tuesday, August 30, 2011 8:56 AM