locked
Finding and reconnecting a deleted mailbox RRS feed

  • Question

  • One of our admins accidentally deleted a user's AD account, which also deleted the associated mailbox on our Exchange 2007 server.  The Exchange message database is configured to keep deleted mailboxes for 14 days, but this mailbox does not appear in "Disconnected Mailboxes" in EMC, nor does it appear in the results when I search for disconnected mailboxes in Exchange Shell.

    Am I doing something wrong?  Does some period of time have to pass before I can see that mailbox?  If so, can I force it to be displayed sooner?

    Thank you very much for your help.

    Friday, June 24, 2011 2:49 PM

Answers

  • Hello Logan,

    Run the below command and check in Disconnected Mailbox.
    Clean-MailboxDatabase "Mailbox Database"

    Post the update. 


    Gulab | MCITP: Exchange 2010-2007 | Skype: Gulab.Mallah | Blog: www.ExchangeRanger.Blogspot.com
    • Marked as answer by Logan Burt Friday, June 24, 2011 3:03 PM
    Friday, June 24, 2011 2:54 PM

All replies

  • Hello Logan,

    Run the below command and check in Disconnected Mailbox.
    Clean-MailboxDatabase "Mailbox Database"

    Post the update. 


    Gulab | MCITP: Exchange 2010-2007 | Skype: Gulab.Mallah | Blog: www.ExchangeRanger.Blogspot.com
    • Marked as answer by Logan Burt Friday, June 24, 2011 3:03 PM
    Friday, June 24, 2011 2:54 PM
  • Hi,

    Please refer to the link below to get more information.

    http://technet.microsoft.com/en-us/library/bb124076(EXCHG.80).aspx


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, June 30, 2011 8:05 AM
  • Many thanks for the answer.  That immediately took care of the problem. 

    I had actually posted (or at least thought I had posted) a reply thanking you shortly after you posted this.  I'm not sure why it didn't actually post, maybe becuase I marked your reply as the answer at the same time.  Anyway, thank you!

    Thursday, June 30, 2011 9:28 AM