locked
When working remotely, incoming calls go to the phone and not communicator RRS feed

  • Question

  • When VPN'd in working remotely, incoming calls pop two 'incoming call' alert boxes. One box has the extension # (e.g., Incoming Call 7712). The other has 6+extension # (e.g., Incoming Call 67712).  The 6 is for the second line on the phone.

    When I click on the extension-only box, the call connects, but I can't communicate with anyone because the physical phone answer on speaker but I am not there.

     When I click on the 6+extension box, the call connects briefly, then disconnects.

    I then have to initiate a call back to the extension that called me, and everything works fine when I'm initiating the call.  I have verified that I have the default preferred calling device set as computer, and I have verified this with multiple accounts. 

    We are running OCS 2007 R2 with a Nortel CS1000 phone system.   Both were just recently patched and should be on the recent version of code.

    Thanks,

    Mark Wiseley

     


    Mark Wiseley
    Monday, March 29, 2010 6:57 PM

All replies

  • If you have configured PBX Integration with RCC you have 2 toasters, so that is normal.

    When picking up via RCC your desk phone goes off hook so that is also normal.

    When picking up via OCS then you disconnect, obviously that is not normal, you should check the SIP trunk between OCS & Nortel (any firewall in between?)


    - Belgian Unified Communications Community : http://www.pro-exchange.be -
    Wednesday, March 31, 2010 12:36 AM
  • There is no firewall and we are running RCC w/ Enterprise voice so this "should" work.  If we use the communicator call it works fine and if we initiate a call it works fine.  The only problem is on incoming calls. 

     

    Thanks,

    Mark


    Mark Wiseley
    Wednesday, March 31, 2010 8:04 PM
  • Hi Mark,

    Could you check your MCM configuration under "Incoming Call Processing Parameters" and the "Caller Phone Prefix Insert" field. Make sure that the digit "6" is not there. I think by the default it is.

    If it is the case, remove it and restart your MCM and make a test.

    Quang.

    Wednesday, March 31, 2010 9:33 PM
  • Ok, well, you were right about the 6, but it did not resolve the issue.  Here is a little more information that might help.  I have removed the 6 and restarted the MCM and restarted the OCS client.  If I make a call, it works, if I receive a call and click the button on my USB headset to answer the call, it works.  If I click the onscreen popup that shows the incoming call, then it answers at the deskphone and not with the headset or speakerphone on the computer.  Strange.  I'm assuming this is just a setting somewhere.  I have verified this is the same on the network and VPN'd.
    Mark Wiseley
    Wednesday, April 7, 2010 4:16 PM
  • Hi Mark,

    2 questions:

    1. When you receive a call and a screen popup is displayed on your computer, can you click on the "Redirect" and what do you see? Can you something like: "Answer the call using the Computer" or "Answer the call using the phone"?

    2. What is the setting for "Preferred calling device"? If it is set to "Phone" then this is the normal behavior. You can change it to Computer and this should fix your problem.

    Quang.  

    Wednesday, April 7, 2010 4:25 PM
  • Redirect is other 1000, mobile, answer using communicator, Reply with IM, and Do Not disturb.  Also the "Preferred calling device" is set to computer. 

     

    Mark


    Mark Wiseley
    Thursday, April 8, 2010 6:08 PM
  • Strange behavior... If you can observe "Answer using communicator" when clicking on Redirect then your "Preferred calling device" should normally be set to "Phone" and not "Computer".

    1. Change the "Preferred calling device" to Phone, make some test calls.

    2. Change it back to Computer, make some test calls.

    3. Click on Redirect and choose "Answer using Communicator" or "Answer using Phone" to see if you manage to answer with the right device.

    If the problem still exists... I don't have any other idea. You may contact your Nortel/Avaya integrator for support.

    Quang.

     

    • Proposed as answer by Jitreddy[Arkadin] Thursday, April 15, 2010 12:01 PM
    • Unproposed as answer by MarkWiseley Tuesday, May 11, 2010 2:09 PM
    Friday, April 9, 2010 6:01 PM
  • Still the same results.

     

    Mark


    Mark Wiseley
    Tuesday, May 11, 2010 2:09 PM
  • We have just moved to CS1000 7.5 and MCM version 4.50.0.5 and we are having exactly the same problem. Did you get this fixed?

    Sunday, November 13, 2011 10:17 AM
  • Hi Mark,

    If you use the VPN, are the ports for the RTP stream open from the MCM to your client?

    You can activate on your Lync client the logging and use the snooper tool from the OCS reskit to find some errors on the cleint.

    Also you can use the Ocslogger on teh OCS proxy and mediation server to find some errors with the ocslogger tool.


    regards Holger Technical Specialist UC
    Sunday, November 13, 2011 10:29 AM