none
Windows Explorer Displays Redirected Folders as a Different Name

    Question

  • Hi Guys,

    Windows 2008 and Windows 2008 R2 has this new feature where it displays folders in which you have ownership of as "Documents" or "Start Menu" for Folder Redirection.

    This only renames it when browsing it through Windows Explorer (explorer.exe).  If you browse the folders through a command prompt using DIR, it will display the correct name... %username%.

    I think Microsoft did this to make it more user friendly, but HOW DO I TURN IT OFF its annoying!

    I wrote this program in visual basic that takes ownership of a folder, Grants Administrators, SYSTEM and %username% full control.  It grabs %username% from the folder name as ususally with redirection the folder in which the data is redirected to = %username%.  After setting the permissions correctly the program then gives ownership BACK to the user.

    Anyway upon running my little application... look what explorer did.  I had Ownership of the folder for a split second before the application gave ownership back.  Because of this when I opened up the folder Explorer populated many of the folders as "Application Data" when they should be displayed as %username%.

    Even though the user now has ownership of the folders now, it still displays them as Application Data!  If I log into the file server as another user account, it displays them correctly.  Explorer is caching this meta data under the users profile somewhere.

    There is NO information on this on the internet.  Can someone at Microsoft give me some information to turn this functionality of explorer.exe off or tell me where this meta data is stored so I can blow it away without having to re-create the entire profile?


    Clint Boessen MCSE, MCITP: Messaging
    Perth, Western Australia

    Blog: http://clintboessen.blogspot.com/
    Tuesday, April 20, 2010 9:08 AM

All replies

  • Hi Clint,

    I tried to reproduce the issue but failed. It seems that the issue will not occurs all the time.

    Here is an KB article which descripted a similar issue as yours. Please try the steps provided to see if we can git it fixed:

    When you redirect the Documents folder on a Windows Vista-based computer to a network share, the folder name unexpectedly changes back to Documents

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;947222

    • Proposed as answer by Karon W Thursday, December 8, 2011 1:40 PM
    Thursday, April 22, 2010 8:15 AM
    Moderator
  • Thanks for your response Shaon,

    I modified the desktop.ini permissions as per KB947222:

    Note If more than one Desktop.ini file exists, follow these steps for all the Desktop.ini files.

    1. Right-click the Desktop.ini file, click Properties, and then click the Security tab.
    2. In the Group or user names pane, click Administrators.
    3. Click to select the Deny check box for the Read permission.
    4. Click OK.

    This did not resolve my problem.  Microsoft's solution is to create each users documents folder in a "sub folder" under %username% which is a bit silly.  This issue looks like a bug in the windows vista/win7/2008/2008 R2 platform.  I have seen this multiple times on different 2008 servers at seperate companies! :(


    Clint Boessen MCSE, MCITP: Messaging
    Perth, Western Australia

    Blog: http://clintboessen.blogspot.com/
    Friday, April 23, 2010 3:29 AM
  • Hi Client,

    As you said it should be a problem. I will log the issue and report it to see if there is any update on it.

    Meanwhile, how about take ownership of such folders (with the administrator account)?

    Monday, April 26, 2010 1:32 AM
    Moderator
  • I have tried taking ownership.

    This file server had all the permissions set wrong on user profiles and redirected folders.  A junior administrator took ownership at the root of the drive as Administrator and inherited this ownership change throughout the file hierarchy.  Users NEED to have ownership of redirected folders and user profiles otherwise the redirection and profiles will fail upon loading.  Note there are group policy settings to allow users to not require ownership of redirected folders such as:

    Computer Configuration --> System --> User Profiles

    "Do not check for user ownership of Roaming Profile Folders"

    To resolve this I set all users back to having ownership of their redirected folder.  I did this by creating a vbs script using both:

    - xcacls.exe (To set Permissions)

    - subinacl.exe (To take ownership as xcacls.exe cannot do this).

    What the script does is ask for the directory on the file server for example "d:\companydata\users\documents" the folder containing everyones my documents redirection.  It then goes through each folder in the given directory:

    Set oFSO = CreateObject("Scripting.FileSystemObject")
    Set oShell = CreateObject("WScript.Shell")
    Set oRoot = oFSO.GetFolder(InputBox("Enter Full Directory Path"))
    Set oFolders = oRoot.SubFolders
    For Each oFolder in oFolders
    
    
    Next

    Inside the loop the following things occur for each individual folder:

    1. subinacl.exe takes ownership of the folder as "Administrators" which in effect gives Administrators "full control" to the folder as well.
    2. give ownership back to the user using subinacl.exe.  Because each folder name matches the %username%, it does this by simply setting the ownership to oFolder.Name.
    3. Now that administrators have full control, but the user has ownership!  Lastly the script runs xcacls.exe setting the %username% (oFolder.Name), Administrators, and SYSTEM to full control to the folder.  (Yes I know that Administrators and %username% already had full control from taking ownership but xcacls.exe does it again anyway hehe).

    Then the script moves onto the next folder and performs the same procedure.

    Many companies I deal with administrators do not understand that by default the user needs ownership to their roaming profiles and redirected problems, so I have needed to fix up permissions on more then one occasion.  This problem has only occured in windows server 2008 and windows server 2008 R2.  2003 server was fine.

    If you "dir" the directories from a command prompt, they display correctly.  It is only windows explorer that displays the folders incorrectly. 

    Sorry for the late reply, I have been very busy as of late.


    Clint Boessen MCSE, MCITP: Messaging
    Perth, Western Australia

    Blog: http://clintboessen.blogspot.com/

    Saturday, May 8, 2010 2:05 AM
  • Hi Shaon Shan,

    Has there been any progress with this?

    Kind Regards,


    Clint Boessen MCSE, MCITP: Messaging
    Perth, Western Australia

    Blog: http://clintboessen.blogspot.com/
    Thursday, May 20, 2010 11:01 AM
  • Hello?
    Clint Boessen MCSE, MCITP: Messaging
    Perth, Western Australia

    Blog: http://clintboessen.blogspot.com/
    Sunday, June 6, 2010 4:40 AM
  • Microsoft is there any other updates on this issue, I have another client complaining.
    Clint Boessen MCSE, MCITP: Messaging
    Perth, Western Australia

    Blog: http://clintboessen.blogspot.com/
    Monday, June 14, 2010 7:08 AM
  • Hi Clint,

     

    Above all please accept my apoligy for taking such a long time to reply.

     

    Product group is aware this issue. This issue happens on Windows Vista and later machines due to a design change. As you mentioned, mostly the issue is caused that some customers modified the ownership of the redirected folder incorrectly. Considering that customers who follow guideline will not experience this issue,  and it demands very high development cost to fix it, our PG finally determined to not fix this issue at this time after very hot and serious discussion.

     

    Sorry for the inconvenience.

    Tuesday, June 15, 2010 7:31 AM
    Moderator
  • Ah that is very frustrating.  I have other clients that have this issue, and we have not done anything out of the ordinary.  Ie we did not run the above script.!  I'll just have to tell the clients that Microsoft has decided not to fix this bug!


    Clint Boessen MCSE, MCITP: Messaging
    Perth, Western Australia

    Blog: http://clintboessen.blogspot.com/
    Sunday, June 27, 2010 8:16 AM
  • Hi there,

    We are seeing the same problem Clint Reported with a NEW Windows 2008 R2 environment involving Citrix.  So the file server, domain controllers, and citrix servers (Terminal servers) are all 2008 R2.  We are redirecting documents to the user's home drive and upon the first login, the folder name changes over to My Documents.  

    This is Unacceptable Microsoft and this really needs to be fixed.  This worked fine in Windows 2003 R2 and earlier and we did NOT create the home drives in any special manner.  Think of the case where we map the home drive share to a group of users who need to access other peoples data and they have to deal with this new behavior?  Yes we have tried the workarounds in http://support.microsoft.com/kb/947222

    We do see the folder names fine under command prompt BUT we want the correct old behavior back.

    **A tip to everyone else, you can see the correct folder name if you change the columns in the explorer view and ADD Filename.  But still, a workaround as you'll have to add on every server/user assuming you don't change default user.

    Please revisit this issue Microsoft as more people will be seeing this in the near future.

    thanks,

    Larry H

    Friday, July 9, 2010 3:29 PM
  • I "third" that request.  This is silly not to fix.  It's hard enough trying to explain redirected folders without this little quirk.
    Wednesday, July 28, 2010 6:32 PM
  • Any update Microsoft?
    Monday, August 9, 2010 1:58 PM
  • I 4th the request for this issue to be fixed. 
    Friday, August 13, 2010 3:11 PM
  • 15th!

     

    Monday, August 23, 2010 11:33 AM
  • And I 6th this!!!!

    We are getting this exact same problem now on our File cluster where we have the My Documents folders redirected to.

    This is not happening on all users however and this is so anoying!!

    Please get this fixed Microsoft!!

    Wednesday, August 25, 2010 12:06 PM
  • I found that by overwriting the desktop.ini file of the folder displaying "My Documents" as it's title with the Desktop.ini file from a correctly displaying folder, this would fix the problem.

    I used a utility to do this in bulk (Fileboss) but you could script it just as easily.  I have tried logging in as the affected user and the fix seems to stick.

    Hope this helps.

    • Proposed as answer by carmeruk Thursday, November 18, 2010 3:20 PM
    Thursday, November 18, 2010 3:18 PM
  • I'm trying to find a powershell script that will delete all desktop.ini files from our user directory on our file server.  Here is what I'm trying:

    get-childitem "e:\users\" -include desktop.ini -recurse | Remove-Item -recurse -force

    After running, I still have about 43 objects named "My Documents" rather than their correct folder name (ie their username)

    Can anyone share their script that deletes these desktop.ini files?

    We'll probably just run this on a nightly basis once we have it figured out.

    Thanks.

    Monday, November 22, 2010 9:09 PM
  • I am having this same trouble - 2008 R2 - user home drives.  I have been able to temporarily resolve the issue by running a simple DOS command at the root of home:

    DEL desktop.ini /S /A:H

    Windows explorer now displays the correct name but I'd really like to understand why. 

    RE: the above "... mostly the issue is caused that some customers modified the ownership of the redirected folder incorrectly."  My folders have been created by using Active Directory Profile tab and setting Connect H: to \\server\path\userID 

    Is there a way I can confirm that AD is in fact creating these Home folders with the correct permissions?


    G
    Tuesday, December 28, 2010 7:19 PM
  • Also having the same kind of issue with an added twist.

    1. Redirected My Documents and Profiles to 2 locations via Group Policy and redirect home folders with AD.

    2. Server that maintains the home and profile folders is 2008 AND 2003 file servers (2003 is at a remote site and this one is really bad - 3 home directories display the same name, altho in the address bar they show the correct names).

    4. Domain is currently at 2003 level, we have 2 2008 r2 AD servers and one 2003 AD server. We will be removing the 2003 soon and raising the functional level to 2008.

    5. MANY windows XP machines are displaying their C:\Documents and Settings\%username%\Application Data folders as a redirected home directory name from the 2003 remote site file server. We do have vista and windows 7 machines, but since the location of "Application Data" is different, apparently they are not being affected.

    6. We have made NO changes to how the redirected folders/profiles are established.

    7. When you open properties on the misrepresented folder - the bad name is displayed, but if you try to change it to Application Data, then you get a pop-up saying you can't change the name because it is the same name.

    8. I have found in the registry for my pc the following:

    hkcu\software\mirosoft\windows\shell\localizedresourcename\ @shell32.dll,-21765 reg_sz <bad name for application data>

    hku\s-1-5-21-<etc>software\mirosoft\windows\shell\localizedresourcename\ @shell32.dll,-21765 reg_sz <bad name for application data>

    9. I changed it in hku to Application Data (which changed for current user) and the display is now correct on my pc.

    Again - this is a fix for the pc's. For the server I had to do the above, but since the users home folder name displayed incorrectly (they were now Application Data) , I had to manually remove the 3 folders and let the home folders get rebuilt by the users logons.

    There has got to be an easier fix than manually touching the registry on 2000 pcs and possibly 200 servers


    Karon W
    Wednesday, January 5, 2011 3:38 PM
  • Turns out the display issue was from my pc only.
    Karon W
    Wednesday, January 5, 2011 5:26 PM
  • I'm Having the Same Problem with My Documents Folders Redirected.  Please help.
    Friday, January 28, 2011 6:52 PM
  • Throwing this out there hoping someone can help me build on this. The problems happens with early version of microsoft that default folder redirection as \\server\folder\%username and newer operation systems defauly \\server\folder\%username\My Document. When not in the standard newer operating systems input the desktop.ini that alters the name.

    So it should be as easy as just going into your redirection policy and adding in the subfolder My Document, but it will not build the extra level. You can easly direct it to another folder in your share but change for users is the worst thing you can do.

    In a test enviroment I decided to try using IP instead of the servername ex. \\192.168.1.1\server\folder\%username%\My Document. After numerious test and alterations to try to find a flaw, everything seemed to work amazing in the test enviroment.

    I applied the changer to an OU that contains a couple domain admins and it seemed to cause a number of issues. One user ended up with no mapping for his My Documents, another user was mapped correctly but only had sub folders documents but any  document that was on the root was not there, and the last problem was that the user was mapped but everything in the my document folder was gone. None of my 4 users got it right but the one who got mapped it created the sub folder in the users folder just the document did not want to transfer.

    I had it set to

    Basic - Redirect everyones folder to the same location

    Create a folder for each user under the root path /(and)/ redirect to the following location

    with the boxes chaked for move the content and also apply.

    Any help or idea would be greatly appricated!

     

    Tuesday, February 8, 2011 2:09 PM
  • I am having the same issue. Is there any update on this?
    Monday, February 28, 2011 4:23 PM
  • With the length of time this has been going on i dont think there will be a resolution to this, in server 2008 at least.
    Wednesday, March 16, 2011 1:08 PM
  • We had a similar problem with multiple "My Documents" folders appearing on a 2008 R2 server. We followed Method 3 in the MS arcitle http://support.microsoft.com/default.aspx?scid=kb;EN-US;947222 and this resolved the problem.

    Points to note - we only had to do this on the root of the users home folder. We did not have to edit permission on any sub folders underneath desktop.ini folders...

    I got this to script via Powershell, where the multiple "My Documents" folders were appearing in the D:\Data\Private folder. Hope this helps:

    $usernames = get-childitem D:\Data\Private\* 
    foreach ($name in $usernames ){icacls $name\desktop.ini /deny "Administrators:(R)"}

    Only just ran it tonight but I went from 38 My Documents folders to none immediately. Will double check in the morning to see if its still there.

    Mick

    {Updated: typo}
    • Proposed as answer by WestNab Monday, September 3, 2012 11:27 AM
    Monday, May 9, 2011 9:14 AM
  • We also have this issue.  It seems any new Windows 7 computer we put on the network does this to the users folder in our users directory.  Which makes this an ongoing battle.

    Monday, July 25, 2011 2:32 PM
  • We had a similar problem with multiple "My Documents" folders appearing on a 2008 R2 server. We followed Method 3 in the MS arcitle http://support.microsoft.com/default.aspx?scid=kb;EN-US;947222 and this resolved the problem.

    Points to note - we only had to do this on the root of the users home folder. We did not have to edit permission on any sub folders underneath desktop.ini folders...

    I got this to script via Powershell, where the multiple "My Documents" folders were appearing in the D:\Data\Private folder. Hope this helps:

    $usernames = get-childitem D:\Data\Private\* 
    foreach ($name in $usernames ){icacls $name\desktop.ini /deny "Administrators:(R)"}

    Only just ran it tonight but I went from 38 My Documents folders to none immediately. Will double check in the morning to see if its still there.

    Mick

    {Updated: typo}
    Worked perfectly for me - this is the easiest fix out there...

    -Pete
    • Proposed as answer by RAMII Sunday, May 18, 2014 11:56 AM
    • Unproposed as answer by RAMII Sunday, May 18, 2014 11:57 AM
    Wednesday, August 24, 2011 1:34 PM
  • We had a similar problem with multiple "My Documents" folders appearing on a 2008 R2 server. We followed Method 3 in the MS arcitle http://support.microsoft.com/default.aspx?scid=kb;EN-US;947222 and this resolved the problem.

    Points to note - we only had to do this on the root of the users home folder. We did not have to edit permission on any sub folders underneath desktop.ini folders...

    I got this to script via Powershell, where the multiple "My Documents" folders were appearing in the D:\Data\Private folder. Hope this helps:

    $usernames = get-childitem D:\Data\Private\* 
    foreach ($name in $usernames ){icacls $name\desktop.ini /deny "Administrators:(R)"}

    Only just ran it tonight but I went from 38 My Documents folders to none immediately. Will double check in the morning to see if its still there.

    Mick

    {Updated: typo}
    Worked perfectly for me - this is the easiest fix out there...

    -Pete


    Not too good with PowerShell yet but I get an error when I try this command.

    Unexpected token 'in' in expression or statement.

    What doe this mean?

    Tuesday, September 13, 2011 1:39 PM
  • Did you copy and paste?  Single and double quotes can be misinterpreted when copy+pasting.  What EXACTLY did you type?   Might be worth manually typing in the code.
    Tuesday, September 13, 2011 10:55 PM
  • I also have this issue which started when clients were upgraded to Win7.  The server that holds the home directories is Win 2003.  I think that there should be a fix from microsoft on this also.  Like many we do not backup client PC and since Windows automatically uses local C drive for "my documents" it can be a problem.  Most users feel that they just need to hit save for their documents like they do at home and cannot be relied upon to save their documents properly. So again it is up to IT to protect the user against themselves because if that important file is deleted we all know who's fault it is - not the user of course!  So we were given a gp that looked to solve this problem and allow these files to be saved to their home directory.  But then a wrinkle is added to cause IT again another headache - the folder names can change!  So now the user who used to look for their name as their home directory now see's documents - then another solution causes them to now have some of their files under this new "documents' folder and then within this folder another new folder called "my documents"  so now they don't know where to save things and have some things in the documents folder and others within the my documents folder under the documents folder.  And if you do not use roaming profiles and need to keep other user profile settings in the home directory folder they also need to be redirected.   It seems like a pretty straightforward need has become a nightmare.  Yes when you do a dir lookup the folders show the correct name - so why can't they just dispaly correctly without having to manipulate data - or have to create scripts that may or may not work for everyone!!

        Does anyone have something that will work for 2003 server to get these folders to show correctly?  Does anyone know when and if Microsoft will be fixing this issue.


    • Edited by llre Friday, October 21, 2011 12:09 PM
    Tuesday, October 4, 2011 5:25 PM
  • All,

     

    We have numerous customers running W2K8 SP & R2 environments, none of which have reported this issue. Oddly enough though we have recently provisioned a W2K8 R2 remote desktop host farm for a custom who has a w2k3 R2 environment.

     

    We performed all the pre requisites to host the farm in the W2K3 R2 domain, and added the GPO structure to one of the W2K8 R2 servers as you cannot make remote desktop GPO’s with W2K3 R2 GPO’s.

     

    • User do not have profile or home directory paths defined in AD
    • Profile and home folder paths are defined in the GPO
    • Folder redirection is enabled for Documents and Application Data

     

    BEHAVIOR:

    To start with when users logged onto the RD Farm they had their home folder path correctly set and the folder names in the root of the share was correct.

    \\server\share\username1\ect

    Then after 3 months we noticed that users home folder path was no longer being created with the %username% structure and looked like this

    \\server\share\my documents\ect

     

    The profile and application data folder redirection is working  as expected by creating a folder with the username.

    The document folder redirection is not working correctly.

     

    CONFIGURATION:

    Set path for Remote Desktop Services Roaming User Profile

    Enabled

     

    Profile path

    \\SERVER\profileshare\

    Specify the path in the form, \\Computername\Sharename

     

    Set Remote Desktop Services User Home Directory

    Enabled

     

    Location:

    On the Network

    Home Dir Root Path:

    \\SERVER\homeshare\

    If home path is on the network, specify drive letter for the mapped drive.

    Drive Letter

    U:

     

     

    Current GPO Settings:

    AppData(Roaming)hide

    Setting: Basic (Redirect everyone's folder to the same location)hide

    Path: \\SERVER\SHARE1\%USERNAME%\AppData\Roaming

     

    Documentshide

     

    Setting: Basic (Redirect everyone's folder to the same location)hide

    Path: %HOMESHARE%%HOMEPATH%

    ISSUE:

    When enumerating via windows explorer on the Windows 2003 R2 or Windows 2008 R2 servers you see some document folders with the correct %username% name, but mostly they are all enumerating as My Documents.

    If you open a command prompt on the W2K3 R2 server and perform a DIR you will see a list of %username% folders correctly.

    CONCLUTION:

    I am going to dig deeper into file/folder level attribute flags set by default when creating folders by windows 2008, as I feel there is a problem with windows 2008 Server creating data in a windows 2003 R2 server ntfs folder structure. I am aware NTFS has been upgraded and the version used in 2003 is not the same as 2008 and above.

     

    If I find a solution I will update this ticket

     

    Friday, October 7, 2011 11:44 AM
  • I have this exact problem and so far have found it to be specific to folders that are redirected from a Windows 7 environment. Windows XP is okay. I can not go any farther with the mirgration to folder redirection until this is resolved. Does anyone have a proper solution to this issue yet?

    Likewise once I find the fix I will post it.

     

    Thursday, October 20, 2011 9:13 PM
  • Same here !
    Friday, October 21, 2011 7:50 AM
  • Hi Guys,

    Windows 2008 and Windows 2008 R2 has this new feature where it displays folders in which you have ownership of as "Documents" or "Start Menu" for Folder Redirection.

    This only renames it when browsing it through Windows Explorer (explorer.exe).  If you browse the folders through a command prompt using DIR, it will display the correct name... %username%.

    I think Microsoft did this to make it more user friendly, but HOW DO I TURN IT OFF its annoying!

    I wrote this program in visual basic that takes ownership of a folder, Grants Administrators, SYSTEM and %username% full control.  It grabs %username% from the folder name as ususally with redirection the folder in which the data is redirected to = %username%.  After setting the permissions correctly the program then gives ownership BACK to the user.

    Anyway upon running my little application... look what explorer did.  I had Ownership of the folder for a split second before the application gave ownership back.  Because of this when I opened up the folder Explorer populated many of the folders as "Application Data",you can also prevent your data by finding duplicate files with easy & Free Duplicate File Finder when they should be displayed as %username%.

    Even though the user now has ownership of the folders now, it still displays them as Application Data!  If I log into the file server as another user account, it displays them correctly.  Explorer is caching this meta data under the users profile somewhere.

    There is NO information on this on the internet.  Can someone at Microsoft give me some information to turn this functionality of explorer.exe off or tell me where this meta data is stored so I can blow it away without having to re-create the entire profile?


    Clint Boessen MCSE, MCITP: Messaging
    Perth, Western Australia

    Blog: http://clintboessen.blogspot.com/
    Meta-data server meta-data server storage management server hsm & backup meta-data control network (ip) nfs cifs ftp http data data data security assists. Introduction to metadata elements: library of congress existing meta data services packages should be moved to sql server storage. Meta data storage azure storage samples are windows azure storage code samples they show how to get container metadata get container properties get page get page regions lease blob. Metadata - gis wiki the gis encyclopedia a window for edit default will be seen having three panel for editing default acl ,metadata and storage policy panel on bucket this window shows existing default acls. Storage architecture administrative metadata is used for managing and preserving objects in the repository structural metadata is used primarily for storage of objects.
    Friday, October 21, 2011 11:54 AM
  • Shaon,

    What is the proper guidline for this issue to not occur? We are experiencing the same issue and we have not utilized any scripts or modifed ownership of redirected folders. We are trying to migrate from XP to Windows 7 and use Roaming Profiles.

    We have redirected the users 'My Documents' in XP to be the user's Home directory on the network. Now that we are trying to migrate to Windows 7, the Parent folder where all user home directories are located are being renamed to 'My Documents'. Are you saying that there is no solution to this?

    Thursday, December 8, 2011 9:48 PM
  • Paul,

    Were you able to find a solution for this?

    Thanks,

    Darrin

    Monday, February 6, 2012 10:34 PM
  • I am having the same issue. Is there any update on this?

    Paul M. Joseph

    Thursday, February 9, 2012 7:45 PM
  • I found a nice workaround from a post from AlexB here:  http://www.edugeek.net/forums/windows-server-2008/53755-home-folders-renames-my-documents-2.html

    The workaround is to use File Server Resource Manager to create a file screen at the root of the folder to block the creation of any files named desktop.ini.  I've been using this for a month at one customer site and it seems to be working well.

    To remove the existing desktop.ini files I just used the command prompt to CD into the folder and del all the desktop.ini files with any attribute in all subfolders.

    Example:

    cd /d d:\home
    del desktop.ini /s /a

    • Proposed as answer by Threonine Thursday, March 15, 2012 2:29 PM
    Thursday, March 15, 2012 2:27 PM
  • Greetings all,

    This issue has been on going for awhile now.  Yes, deleting the desktop.ini file does fix this, on a per person basis.  So as each new user is added, the issue is always going to happen.  Based on the many posts and descriptions on how people set up their redirection, I don't believe this many people all did the exact same thing wrong. 

    Will I take the time to prevent the desktop.ini from being created for each folder?  No.  The reason being is that Microsoft is just a huge disappointment, and this only compounds that belief.  So far, when I see a reply from them, their excuse for no fix is that they can't repeat the same issue in their environment, which MUST mean all of us are just ignorant and doing things horribly wrong. 

    This is an obvious issue that should have been fixed a LONG long long....long time ago.  And yet all we get are headaches. 

    Anyways, I'm done with my rant.  And I'm done with Microsoft.  Seeing as this is a business setting, and I can't rely on them to be professional by doing their job, I will be removing all Windows from our business.  If they can't take responsbility for any of their own work, then I refuse to assist in their profitting.

    Thursday, March 29, 2012 3:10 PM
  • Hey,
    We had it too, i used a User GPP .INI extension to remove the property: LocalizedResourceName (which causes this)
    GPP XML form:
    <Ini clsid="{XXXXXXXXXXX}" name="LocalizedResourceName" status="LocalizedResourceName" image="3" changed="2012-08-29 14:38:38" uid="{xxxxxxxxxxx}" userContext="1" bypassErrors="1"><Properties path="\\share\home$\%username%\desktop.ini" section=".ShellClassInfo" value="" property="LocalizedResourceName" action="D"/><Filters/></Ini>


    • Proposed as answer by Joe Krilov Tuesday, September 10, 2013 6:14 PM
    Thursday, August 30, 2012 9:10 AM
  • Hello Everyone,

    First off thanks for all the posts here; I was really impressed with the different workarounds/repairs that have been discovered along the way.  Although many of the posts have a method for repairing the issue or working around it (FSRM method was my favorite!) I haven't seen a solution that resolves the main issue yet; I think I may have I've found one.

    The issue as I see it is that redirected folders get renamed to their "special folder" names when browsing in Explorer.exe on a Win7/W2K8/W2K8R2 system.  The mechanism causing this in my mind is UAC; when it hits a folder you don't have access to browse it takes ownership and adds a Full Control ACE to the folder's ACL for the logged on account.  Windows then sees this special folder you have ownership of and visually renames it in Explorer via a desktop.ini file; althought this isn't desirable for administrators we DO want this behaviour to occur when a user browses their own redirected folders.

    When I started using W2K8/W2K8R2 I struggled with understanding why I needed to take control of a folder that has an Administrators Full Control ACE present already; recently I found an article that explains this behaviour.  The local Administrators group is actually denied everything by default and UAC adds the necessary admin token in when you authorize it.  You can "view" this restriction by starting a command prompt (NOT elevated) and typing "whoami /all".  Look at the output and see that the BUILTIN\Administrators group alias is "Group used for deny only".  Now kick off an elevated command prompt and do the "whoami /all" again; you get "Mandatory group, Enabled by default..."  So that's what's up with the UAC prompt on folder permissions, built-in groups and/or default NTFS ACLs don't provide you the appropriate NTFS access.

    So the fix is really simple.  Create a new security group to replace the local Administrators ACE on your folders; I made one called "File and Folder Administrators" in Active Directory (instead of on the local servers so I can use it everywhere).  Place your "Administrator" groups/users inside this group (you can add Domain Admins, local Administrators group, etc.) and add a Full Control ACE for the new group to the top level of your file server drives (I removed the local Administrators group after doing this); don't forget to logoff and logon once after creating the group so your logon has the new group token.  Now when you browse folders you'll notice 2 things, the lock icon overlay disappears and you don't get UAC prompts when drilling down; behaves just like it did back in NT/W2K/W2K3/W2K3R2 (grumble, grumble)!

    The advantage of using this method over the FSRM fix and/or blocking the desktop.ini file is that users will continue to see the special folder name on their redirected folders.  Not a really big deal but I absolutely LOVE being able to browse folders again without adding ACEs and taking ownership, drove me bonkers for a bit.  Hope this helps out a few folks....

    Wednesday, October 24, 2012 6:01 PM
  • This worked for me:

    We have students and staff folders under the home folder, and desktop.ini files within, document redirection drops them right into the U drive, without altering the end-user's experience I've found this works the best for my situation.

    Subinacl /subdirectories c:\home\desktop.ini /deny=Administrators=R

    This recursively removes read permissions from the desktop.ini files in all the subfolders within the home folder.

    Friday, January 25, 2013 10:59 PM
  • Thank you, using GPP to modify the desktop.ini file worked perfectly.  

    I changed the settings slightly to give the "LocalizedResourceName" a value of "%username%'s Documents".  This works but really offers no benefit over just deleting that property, so I may change it back.

    Tuesday, September 10, 2013 6:14 PM
  • As you mentioned, mostly the issue is caused that some customers modified the ownership of the redirected folder incorrectly. Considering that customers who follow guideline will not experience this issue,  and it demands very high development cost to fix it, our PG finally determined to not fix this issue at this time after very hot and serious discussion.

    Hi Shaon,

    Just for the record could you clarify the "guideline".

    And if "some customers modified the ownership of the redirected folder incorrectly", what is the approved procedure to restore the expected configuration? (correct the ownership, delete the desktop.ini file, then the correct desktop.ini will be created next time the user logs on again?)

    Thanks, Barnaby

    Monday, October 14, 2013 4:01 AM
  • This worked for me also, it is a bind having to replace the ini files for all my users.  I cant believe that MS have said that it will cost too much! You should fix the issues you create especially as it affects your customers.
    Thursday, February 20, 2014 10:37 AM
  • Joe Krilov's solution is the best among the proposed ones here, including the ones in the KB for it, as it doesn't futz about with ACLs and happens as soon as the user logs on; no scheduling of scripts required.

    I went a step further and specified %homeshare%\desktop.ini for the file and had the Group Policy Preference for it update the value LocalizedResourceName to %username%. This lets the GPP work for any user with any home folder on any server. It was especially elegant in that I could put this GPP in the same GPO as the one I made especially for folder redirection. Environment variables only seem to be available if you turn on "Run in logged-on user's security context" under the Common tab.

    Of course this assumes you specified %homeshare% (or \\server\share\%username% in ADUC) as the redirection target for folder redirection for "My Documents" or "Documents." If you wanted to do this for other redirection targets you could have the GPP delete the value or put in some other value like, "%username%'s desktop". In a multi-domain environment one could use %username%@%userdomain%'s desktop.

    --



    • Edited by Gordon Fecyk Wednesday, April 9, 2014 6:44 PM Punctuation fix
    Wednesday, April 9, 2014 6:39 PM
  • Bumping Mick's solution as the simplest(I posted another using subinacl earlier, but it's not standard in some servers), you have to be in the folder in question for the script to work or you can do something like this:

    $usernames = get-childitem "C:\Network\Faculty Home Drive"
    foreach ($name in $usernames ){icacls "C:\Network\Faculty Home Drive\$name\desktop.ini" /deny "Administrators:(R)"}
    

    • Proposed as answer by thugpac Wednesday, January 3, 2018 12:07 PM
    Wednesday, August 13, 2014 2:47 PM