none
Error when running Sign.cmd RRS feed

  • Question

  • I receive the following error when attempting to run the Sign.cmd:

    PS C:\MIMWAL-2.16.0320.0\src\SolutionOutput> .\Sign.cmd
    ERROR: File '"C:\MIMWAL-2.16.0320.0\src\SolutionOutput\\MicrosoftServices.IdentityManagement.WorkflowActivityLibrary.dll
    "' Not Found. You need to compile WAL solution first!

    I have confirmed that the file is indeed not there (Screen shot below)

    Why is the file not getting copied to the expected location on a BUILD|REBUILD?

    Thank you,

    Matt

    Wednesday, April 6, 2016 3:23 PM

Answers

  • Matt,

    It looks like not all of the DLLs are present in your solution output folder.   It looks like you are missing the MicrosoftServices.IdentityManagement.WorkflowActivityLibary.dll which is the main DLL.

    Perhaps you had an error on build in visual studio?  Try building the projects one by one, and see if there are errors during the build process.

    Thanks,

    Jef

    Wednesday, April 6, 2016 3:35 PM

All replies

  • Matt,

    It looks like not all of the DLLs are present in your solution output folder.   It looks like you are missing the MicrosoftServices.IdentityManagement.WorkflowActivityLibary.dll which is the main DLL.

    Perhaps you had an error on build in visual studio?  Try building the projects one by one, and see if there are errors during the build process.

    Thanks,

    Jef

    Wednesday, April 6, 2016 3:35 PM
  • Hi Jeff,

    I'm not sure what you mean by build the projects one by one. Here is the output from the build which might help determine what's wrong. By the way, you all are very responsive on this Forum. Thank you for that!

    1>------ Rebuild All started: Project: WorkflowActivityLibrary, Configuration: Release Any CPU ------
    1>  WorkflowActivityLibrary -> C:\MIMWAL-2.16.0320.0\src\WorkflowActivityLibrary\bin\Release\MicrosoftServices.IdentityManagement.WorkflowActivityLibrary.dll
    1>  Does C:\MIMWAL-2.16.0320.0\src\SolutionOutput specify a file name
    1>  or directory name on the target
    1>  (F = file, D = directory)? ?  Gv      Gv      Does C:\MIMWAL-2.16.0320.0\src\SolutionOutput specify a file name
    1>  or directory name on the target
    1>  (F = file, D = directory)? Does C:\MIMWAL-2.16.0320.0\src\SolutionOutput specify a file name
    1>  or directory name on the target
    1>  (F = file, D = directory)? ?      Gv      Does C:\MIMWAL-2.16.0320.0\src\SolutionOutput specify a file name
    1>  or directory name on the target
    1>  (F = file, D = directory)? C:\MIMWAL-2.16.0320.0\src\Scripts\CaptureTrace.cmd
    1>  C:\MIMWAL-2.16.0320.0\src\Scripts\CompileLanguagePack.cmd
    1>  C:\MIMWAL-2.16.0320.0\src\Scripts\EncryptData.ps1
    1>  C:\MIMWAL-2.16.0320.0\src\Scripts\gacutil.exe
    1>  C:\MIMWAL-2.16.0320.0\src\Scripts\Register.ps1
    1>  C:\MIMWAL-2.16.0320.0\src\Scripts\RunPSLoggingSample.ps1
    1>  C:\MIMWAL-2.16.0320.0\src\Scripts\Sign.cmd
    1>  C:\MIMWAL-2.16.0320.0\src\Scripts\sn.exe
    1>  C:\MIMWAL-2.16.0320.0\src\Scripts\TestLogger.ps1
    1>  C:\MIMWAL-2.16.0320.0\src\Scripts\UpdateWorkflowXoml.ps1
    1>  10 File(s) copied
    2>------ Rebuild All started: Project: WorkflowActivityLibrary.UI, Configuration: Release Any CPU ------
    2>  WorkflowActivityLibrary.UI -> C:\MIMWAL-2.16.0320.0\src\WorkflowActivityLibrary.UI\bin\Release\MicrosoftServices.IdentityManagement.WorkflowActivityLibrary.UI.dll
    2>  C:\MIMWAL-2.16.0320.0\src\WorkflowActivityLibrary.UI\bin\Release\MicrosoftServices.IdentityManagement.WorkflowActivityLibrary.UI.dll
    2>  1 File(s) copied
    2>  C:\MIMWAL-2.16.0320.0\src\WorkflowActivityLibrary.UI\bin\Release\MicrosoftServices.IdentityManagement.WorkflowActivityLibrary.UI.pdb
    2>  1 File(s) copied
    2>  C:\MIMWAL-2.16.0320.0\src\Scripts\CaptureTrace.cmd
    2>  C:\MIMWAL-2.16.0320.0\src\Scripts\CompileLanguagePack.cmd
    2>  C:\MIMWAL-2.16.0320.0\src\Scripts\EncryptData.ps1
    2>  C:\MIMWAL-2.16.0320.0\src\Scripts\gacutil.exe
    2>  C:\MIMWAL-2.16.0320.0\src\Scripts\Register.ps1
    2>  C:\MIMWAL-2.16.0320.0\src\Scripts\RunPSLoggingSample.ps1
    2>  C:\MIMWAL-2.16.0320.0\src\Scripts\Sign.cmd
    2>  C:\MIMWAL-2.16.0320.0\src\Scripts\sn.exe
    2>  C:\MIMWAL-2.16.0320.0\src\Scripts\TestLogger.ps1
    2>  C:\MIMWAL-2.16.0320.0\src\Scripts\UpdateWorkflowXoml.ps1
    2>  10 File(s) copied
    ========== Rebuild All: 2 succeeded, 0 failed, 0 skipped ==========

    Wednesday, April 6, 2016 3:48 PM
  • I think there was an issue where Visual Studios was compiling in Debug mode even though the GUI interface said Release. Anyways, I was able to recompile successfully. Thank you.
    Wednesday, April 6, 2016 4:14 PM
  • The issue was not Debug or Release mode, but that you did not use "Rebuild solution".
    Thursday, April 7, 2016 5:28 AM
    Owner
  • Hey Nilesh,

    I ran into this today (in 2018) and I am certain I ran Build -> Rebuild Solution in Release mode.  I guess I'll second Ma11Br00ks same assessment from 2016.  

    You know another few months passed since installing MIMWAL...

    Thanks,
    Bryan

    Tuesday, October 16, 2018 5:27 PM