none
How to disable Microsoft Store option RRS feed

  • Question

  • Hi Team,


    How to disable Microsoft Store option on my system for all the users

    Thanks in advance

    Bhaskar G R

    Tuesday, July 16, 2019 10:46 AM

All replies

  • Hello,

    If you're using Windows 10 Education or Enterprise edition, you can turn off access to Microsoft Store app via GPO setting. Refer this guide:

    https://www.kapilarya.com/how-to-disable-microsoft-store-in-windows-10

    Let us know if this helps!

    Note: Included link in this reply refers to blog post by a trusted Microsoft MVP. 


    Microsoft MVP (Windows and Devices for IT)

    Windows Insider MVP

    Windows Help & Support [www.kapilarya.com]

    Tuesday, July 16, 2019 1:00 PM
  • Hi Kapil,

    I am using windows 10 professional. Same option i enabled, after rebooting store option working as normal, is there any alternative option to disable

    Thanks in advance

    Bhaskar 

    Wednesday, July 17, 2019 4:39 AM
  • Thanks for reply!

    Unfortunately, the GPO method no longer works on Professional edition. In this case, you'll need to remove Store app from your system. See Method 2 in the link I've shared you previously. Note that if you remove Store app, you need to perform repair upgrade to get it back, if you need it later.

    Regards.


    Microsoft MVP (Windows and Devices for IT)

    Windows Insider MVP

    Windows Help & Support [www.kapilarya.com]

    Wednesday, July 17, 2019 4:48 AM
  • Hi Kapil,

    I removed store as per second method, if i login with other user its showing again, please suggest me any other option

    Thanks in advance

    Bhaskar 

    Wednesday, July 17, 2019 4:58 AM
  • Enable or Disable Microsoft Store Apps in Local Group Policy Editor

    1. Open the Local Group Policy Editor.

    2. In the left pane of Local Group Policy Editor, navigate to the location below. (see screenshot below)

     Computer Configuration\Administrative Templates\Windows Components\Store

    Name:  Microsoft_Store_apps_gpedit-1.jpg
Views: 7869
Size:  48.1 KB

    3. In the right pane of Store, double click/tap on the Disable all apps from Microsoft Store policy to edit it. (see screenshot above)

    4. Do step 5 (enable) or step 6 (disable) below for what you would like to do.


     5. To Enable Microsoft Store Apps

    A) Select (dot) either Not Configured or Enabled, click/tap on OK, and go to step 7 below. (see screenshot below)

     Not Configured is the default setting.


     6. To Disable Microsoft Store Apps

    A) Select (dot) Disabled, click/tap on OK, and go to step 7 below. (see screenshot below)

    Name:  Microsoft_Store_apps_gpedit-2.png
Views: 7911
Size:  15.7 KB

    7. When finished, you can close Local Group Policy Editor if you like.

    Nour

    Wednesday, July 17, 2019 5:16 AM
  • Hi Thabit,

    Thanks for the reply..I did all the steps still same issue.

    Thanks in advance

    bhaskar

    Wednesday, July 17, 2019 5:20 AM
  • Hi Kapil,

    I removed store as per second method, if i login with other user its showing again, please suggest me any other option

    Thanks in advance

    Bhaskar 

    It seems you used get-appxpackage *windowsstore* | remove-appxPackage cmdlet.

    You need to instead use get-appxpackage -allusers *windowsstore* | remove-appxPackage cmdlet to get Store app removed for all users.

    Regards.


    Microsoft MVP (Windows and Devices for IT)

    Windows Insider MVP

    Windows Help & Support [www.kapilarya.com]

    Wednesday, July 17, 2019 11:52 AM
  • Hi,

    If the issue persists, you can use logon scripts to assign tasks that will be performed when a user logs on to the computer. 

    Best Regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, July 18, 2019 7:42 PM
    Moderator
  • Hi,
    Was your issue solved?
    If yes, would you like to share your solution in order that other community members could find the helpful reply quickly.
    If no, please reply and tell us the current situation in order to provide further help.
    Best Regards,

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Sunday, July 21, 2019 7:07 PM
    Moderator
  • Hi Team,

    Same issue not yet resolved

    Thanks,

    Bhaskar

    Wednesday, July 24, 2019 11:27 AM
  • Hi,

    Have you tried using a logon script?

    Best Regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, August 9, 2019 4:06 PM
    Moderator