locked
Turning off Program Compatibility Assistant RRS feed

  • Question

  • Hi! I've been trying to turn off Program Compatibility Assistant via gpedit.msc in my Vista machine. So I went to Computer Configuration -> Administrative Templates -> Windows Components -> Application Compatibility, and then set "Turn Off Program Compatibility Assistant" to "Enabled". This also gets reflected in the registry HKLM\SOFTWARE\Policies\Microsoft\Windows\AppCompat!DisablePCA of value 1.

     

    But when I install an application with known compatibility issues such as SQL Server 2005, I still get the PCA window Sad

     

    Help please! I would like to find a way to turn off PCA (tried turning off the Application Compatibility Engine. No PCA window, but I'm getting an error that I need to run with admin priviledges even though I'm an admin user). This is working in a Windows Server 2008 machine, but can't make it work in Vista.

     

    Thanks in advance...

    Friday, September 5, 2008 12:21 AM

Answers

  • Hi,

     

    Yes, Domain Policy may override Local Group Policy.

     

    You can refer the following link:

     

    Group Policy processing and precedence

    http://technet.microsoft.com/en-us/library/cc785665.aspx

     

    Hope it helps.

     

    Tuesday, September 9, 2008 9:46 AM
    Moderator

All replies

  • Hi,

     

    Normally, the changes will disable the PCA. However, in your case, I suggest you check whether the new group policy apply to your computer.

     

    Check group policy result

    ========================

    1.Click Start, type rsop.msc and press Enter.

    2.Please check Computer Configuration -> Administrative Templates -> Windows Components -> Application Compatibility. Does it exist?

     

    Thank you for your cooperation.

     

    Monday, September 8, 2008 8:53 AM
    Moderator
  •  

    "Turn Off Program Compatibility Assistant" is there with a value of "Enabled" and GPO Name of "Local Group Policy". My computer is joined to a domain, and someone told me that the local policy could have been overriden by the domain policy. Haven't tried it with a different machine though, will try it with one that is not connected to a domain Smile

     

    Thanks!

    Monday, September 8, 2008 11:02 PM
  • Hi,

     

    Yes, Domain Policy may override Local Group Policy.

     

    You can refer the following link:

     

    Group Policy processing and precedence

    http://technet.microsoft.com/en-us/library/cc785665.aspx

     

    Hope it helps.

     

    Tuesday, September 9, 2008 9:46 AM
    Moderator
  • I see... Thanks much!

    Tuesday, September 9, 2008 11:33 PM
  • That should be gpedit.msc
    Monday, December 27, 2010 12:53 AM
  • There's actually a much simpler way of turning off this annoying nuisance of a program : go to your service manager (services.msc, or just install administrator tools on your start menu and choose "Services"), and stop the "Program Compatibility Assistant" service. Woo Hoo! End of frustration and waste of my life! ;)

    I'm not sure if this solution is applicable on Vista, but it saved my sanity when I found this cathartic alternative!

    Perhaps the PCA should have been called "Annoying Waste of Irrelevant Code". Of the 70 or so machines I know of with Win7 or Vista on them, running (at a minimum guess) 350 various applications, in no case (apart from the simplest and most incompatible [i.e. old or poorly written] installer applications) does the PCA offer sufficient assistance to warrant its being enabled by default. In fact, on my 3 machines, it has never, ever, correctly identified a problematic app, nor does it fix any issues other folks have had (with the possible exception of users running without admin privileges)!

    At least we should have had the option to turn the damn POSW off permanently via the AGUI (annoying GUI). :)

    As a developer, I don't see any need to have to manually work around yet another layer of "protection" outside the installer mechanism. That's what the Windows Installer is supposed to be able to handle... or at least, that's my understanding. Perhaps I'm wrong?

    I hope this helps other folks in the same situation.

    -PCP

    Saturday, February 5, 2011 11:09 PM
  • It worked like a charm. I had uninstalled the program I was having problems with twice but the compatibility issue would not go away. Now it has. Thanks a lot.
    Tuesday, November 22, 2011 6:09 AM