locked
VM-Type Computer Name RRS feed

  • Question

  • I am trying to deploy VMs with MDT but Sysprep breaks because VMWare machine names are generated automatically with very long strings with spaces (it is due to the customization file as i use the service tag to generate computer names).

    I use the same naming convention for Desktop and laptops (WK-ServiceTag and LT-ServiceTag), VMs have very long strings for service tags so it makes the computer name faulty.

    I am trying to make an exception and have MDT ask for a computer name if the deployed machine is a VM but it does not work, the VM name is still automatically generated.

    Can someone see what am i missing in my customization file:

    [Settings]
    Priority=DefaultGateway,ByLaptopType, ByDesktopType, ByVMType, ByServerType, HardwareInfo,Default
    Properties=Type,MakeAlias,ModelAlias,MyCustomProperty
    
    [DefaultGateway]
    10.8.255.254=Paris
    10.2.255.238=WTC
    
    [WTC]
    DeployRoot=\\REMCORPMIG01\MDTProduction$
    WSUSServer=http://NLWUSSV02:8530
    SLSHARE=\\REMCORPMIG01\Logs$\%ComputerName%
    UDShare=\\REMCORPMIG01\MigData$
    BackupShare=\\REMCORPMIG01\MigData$
    EventService=http://REMCORPMIG01:9800
    
    [Paris]
    DeployRoot=\\FRPARSV11\MDTProduction$
    WSUSServer=http://FRPARSV11:8530
    SLSHARE=\\FRPARSV11\Logs$\%ComputerName%
    UDShare=\\FRPARSV11\MigData$
    BackupShare=\\FRPARSV11\MigData$
    EventService=http://FRPARSV11:9800
    
    [HardwareInfo]
    UserExit=ModelAliasExit.vbs
    MakeAlias=#SetMakeAlias()#
    ModelAlias=#SetModelAlias()#
    
    [Default]
    _SMSTSOrgName=IT TEAM - Production
    
    UDDIR=%ComputerName%
    BackupDir=%ComputerName%
    
    ScanStateArgs=/ue:*\* /ui:Corp\* /uel:30
    USMTMigFiles001=MigApp.xml
    USMTMigFiles002=MigUser.xml
    USMTMigFiles003=MigDocs.xml
    USMTMigFiles004=WNB.xml
    
    HideShell=YES
    ApplyGPOPack=NO
    
    SkipUserData=NO
    UserDataLocation=AUTO
    SkipApplications=YES
    SkipAppsOnUpgrade=NO
    SkipPackageDisplay=NO
    SkipAdminPassword=YES
    SkipProductKey=YES
    SkipComputerName=YES
    SkipDomainMembership=YES
    SkipLocaleSelection=YES
    SkipTaskSequence=NO
    SkipTimeZone=YES
    SkipBitLocker=YES
    SkipSummary=YES
    SkipBDDWelcome=YES
    SkipCapture=YES
    SkipFinalSummary=YES
    
    TimeZoneName=W. Europe Standard Time
    
    JoinDomain=corp.rem.local
    DomainAdmin=JoinAccount
    DomainAdminDomain=corp.rem.local
    DomainAdminPassword=ABC-123
    
    
    BitsPerPel=32
    VRefresh=60
    XResolution=1
    YResolution=1
    
    [ByLaptopType]
    SkipComputerName=YES
    OSDComputerName=%Type%-%SerialNumber%
    Subsection=Laptop-%IsLaptop%
    MandatoryApplications001={1aa3bdbb-5f84-4256-aafb-e237abbf6f39}
    
    
    [ByDesktopType]
    SkipComputerName=YES
    OSDComputerName=%Type%-%SerialNumber%
    Subsection=Desktop-%IsDesktop%
    
    
    [ByVMType]
    Subsection=VM-%IsVM%
    
    
    [ByServerType]
    Subsection=Server-%IsServer%
    
    
    [Laptop-True]
    Type=LT
    
    [Desktop-True]
    Type=WK
    
    [VM-True]
    Type=VM
    SkipComputerName=NO
    
    [Server-True]
    Type=Server
    SkipBDDWelcome=NO
    SkipComputerName=NO




    Friday, May 1, 2015 12:10 PM

Answers

  • It looks like your VM falls under laptop, workstation and VM.

    All you have to do is change priority to set ByVMType first and set all properties under ByVMType:

    [ByVMType]
    Subsection=VM-%IsVM%
    SkipComputerName=NO

    [Settings]
    Priority=DefaultGateway,ByVMType, ByLaptopType, ByDesktopType, ByServerType, HardwareInfo,Default
    Properties=Type,MakeAlias,ModelAlias,MyCustomProperty
    Friday, May 1, 2015 5:24 PM

All replies

  • [ByVMType]
    Subsection=VM-%IsVM%
    SkipComputerName=NO
    Friday, May 1, 2015 1:15 PM
  • [ByVMType]
    Subsection=VM-%IsVM%
    SkipComputerName=NO
    I tried that still the same problem, no prompt for computer name
    Friday, May 1, 2015 1:32 PM
  • Do you get prompt for server builds?

    On a side not, this is great article how to test your customsettings.ini on the fly and make sure your types are actually recognized:

    https://anothermike2.wordpress.com/2011/04/27/quick-and-dirty-testing-customsettings-ini-variables-in-mdt/

    Friday, May 1, 2015 1:34 PM
  • The only prompt i get is for the task sequence and user data.

    I have tried your link but as it runs on the deployment server it does not process the VMType part.


    Friday, May 1, 2015 2:02 PM
  • I got some bdd.log bizarely it processes the BYLAPTOPTYPE section

    <![LOG[------ Processing the [BYLAPTOPTYPE] section ------]LOG]!><time="15:59:56.000+000" date="05-01-2015" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">
    <![LOG[------ Processing the [Laptop-False] section ------]LOG]!><time="15:59:56.000+000" date="05-01-2015" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">
    <![LOG[Property OSDCOMPUTERNAME is now = %Type%-VMware-42 2e b7 df df 0c 07 78-c1 73 b7 3e e1 9e 93 87]LOG]!><time="15:59:57.000+000" date="05-01-2015" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">
    <![LOG[Using from [BYLAPTOPTYPE]: OSDCOMPUTERNAME = %Type%-VMware-42 2e b7 df df 0c 07 78-c1 73 b7 3e e1 9e 93 87]LOG]!><time="15:59:57.000+000" date="05-01-2015" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">
    <![LOG[Property SKIPCOMPUTERNAME is now = YES]LOG]!><time="15:59:57.000+000" date="05-01-2015" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">
    <![LOG[Using from [BYLAPTOPTYPE]: SKIPCOMPUTERNAME = YES]LOG]!><time="15:59:57.000+000" date="05-01-2015" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">
    <![LOG[Property MANDATORYAPPLICATIONS001 is now = {1aa3bdbb-5f84-4256-aafb-e237abbf6f39}]LOG]!><time="15:59:57.000+000" date="05-01-2015" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">
    <![LOG[Added value from [BYLAPTOPTYPE]: MANDATORYAPPLICATIONS = {1aa3bdbb-5f84-4256-aafb-e237abbf6f39}]LOG]!><time="15:59:57.000+000" date="05-01-2015" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">
    <![LOG[------ Processing the [BYDESKTOPTYPE] section ------]LOG]!><time="15:59:57.000+000" date="05-01-2015" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">
    <![LOG[------ Processing the [Desktop-False] section ------]LOG]!><time="15:59:57.000+000" date="05-01-2015" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">
    <![LOG[------ Processing the [BYVMTYPE] section ------]LOG]!><time="15:59:58.000+000" date="05-01-2015" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">
    <![LOG[------ Processing the [VM-True] section ------]LOG]!><time="15:59:59.000+000" date="05-01-2015" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">
    <![LOG[Property TYPE is now = VM]LOG]!><time="15:59:59.000+000" date="05-01-2015" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">
    <![LOG[Using from [VM-True]: TYPE = VM]LOG]!><time="15:59:59.000+000" date="05-01-2015" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">
    <![LOG[------ Processing the [BYSERVERTYPE] section ------]LOG]!><time="16:00:00.000+000" date="05-01-2015" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">
    <![LOG[------ Processing the [Server-False] section ------]LOG]!><time="16:00:00.000+000" date="05-01-2015" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">
    <![LOG[------ Processing the [HARDWAREINFO] section ------]LOG]!><time="16:00:01.000+000" date="05-01-2015" component="ZTIGather" context="" type="1" thread="" file="ZTIGather">

    Friday, May 1, 2015 2:23 PM
  • Yeah, that is where I was going with this. I thought something was not discovered properly.

    Spin up a VM that you've already built, and use that link I gave you for additional testing.
    You will be able to see exactly what the output is and adjust your settings accordingly.


    Friday, May 1, 2015 2:39 PM
  • I do not have a VM that built correctly , they all have the same problem

    I have put the ZTIGather.log file on one drive

    https://onedrive.live.com/redir?resid=6939864fa71683d8!1336&authkey=!AGgWDoZIxQf5UsE&ithint=file%2ctxt

    Friday, May 1, 2015 2:57 PM
  • It looks like your VM falls under laptop, workstation and VM.

    All you have to do is change priority to set ByVMType first and set all properties under ByVMType:

    [ByVMType]
    Subsection=VM-%IsVM%
    SkipComputerName=NO

    [Settings]
    Priority=DefaultGateway,ByVMType, ByLaptopType, ByDesktopType, ByServerType, HardwareInfo,Default
    Properties=Type,MakeAlias,ModelAlias,MyCustomProperty
    Friday, May 1, 2015 5:24 PM
  • Yes! Thanks skywalker123

    Just had to change the setting section as you advised and now it works as expected.

    Cheers..

    Friday, May 1, 2015 5:53 PM
  • Cool, make sure your laptops and workstations didn't go sideways now, but they really should be ok since none of those types will fall under VMType.
    Friday, May 1, 2015 5:55 PM