locked
Client machine is not getting updates RRS feed

  • Question

  • Hi,

    We are facing an issue on one machine at this moment to install updates:

    -Package deployement was successful
    -Updates deployement -> no patches are available in software center, not a single patch was already installed on this machine.

    -See windowsupdate.log below:

    2014-11-07 08:12:27:616  908 2a54 Agent   * Added update {0EBA3DFE-6E54-4BD0-83D2-5DE7D019481D}.204 to search result
    2014-11-07 08:12:27:616  908 2a54 Agent   * Found 211 updates and 71 categories in search; evaluated appl. rules of 720 out of 1179 deployed entities
    2014-11-07 08:12:27:616  908 2a54 Agent Reporting status event with 245 installable, 2 installed,  0 installed pending, 0 failed and 0 downloaded updates
    2014-11-07 08:12:27:616  908 2a54 Agent *********
    2014-11-07 08:12:27:616  908 2a54 Agent **  END  **  Agent: Finding updates [CallerId = CcmExec]
    2014-11-07 08:12:27:616  908 2a54 Agent *************
    2014-11-07 08:12:27:616 5300 2a04 COMAPI >>--  RESUMED  -- COMAPI: Search [ClientId = CcmExec]
    2014-11-07 08:12:28:147 5300 2a04 COMAPI   - Updates found = 211
    2014-11-07 08:12:28:147 5300 2a04 COMAPI ---------
    2014-11-07 08:12:28:147 5300 2a04 COMAPI --  END  --  COMAPI: Search [ClientId = CcmExec]
    2014-11-07 08:12:28:147 5300 2a04 COMAPI -------------
    2014-11-07 08:12:27:616  908 2bf0 Report REPORT EVENT: {3BC201C0-EEF4-4E0E-82BD-5D7ADB7F5E23} 2014-11-07 08:12:27:616+0100 1 147 [AGENT_DETECTION_FINISHED] 101 {00000000-0000-0000-0000-000000000000} 0 0 CcmExec Success Software Synchronization Windows Update Client successfully detected 211 updates.
    2014-11-07 08:12:27:616  908 2bf0 Report REPORT EVENT: {565004FD-A0FC-4500-8488-E55605FBD670} 2014-11-07 08:12:27:616+0100 1 156 [AGENT_STATUS_30] 101 {00000000-0000-0000-0000-000000000000} 0 0 CcmExec Success Pre-Deployment Check Reporting client status.
    2014-11-07 08:12:27:632  908 2bf0 Report CWERReporter finishing event handling. (00000000)

    2014-11-07 08:12:32:616  908 2bf0 Report CWERReporter finishing event handling. (00000000)
    2014-11-07 08:14:24:610  908 2914 AU #############
    2014-11-07 08:14:24:610  908 2914 AU ## START ##  AU: Install updates
    2014-11-07 08:14:24:610  908 2914 AU #########
    2014-11-07 08:14:24:610  908 2914 AU   # Initiating scheduled install
    2014-11-07 08:14:25:134  908 2914 AU WARNING: There are no approved updates to install
    2014-11-07 08:14:25:134  908 2914 AU   # Exit code = 0x8024000C
    2014-11-07 08:14:25:182  908 2914 AU #########
    2014-11-07 08:14:25:182  908 2914 AU ##  END  ##  AU: Install updates

    It is a Windows 2012 server and we are using WSUS 3.0 SP2 to update our servers.

    Any ideas?

    Thanks

    Friday, November 7, 2014 9:30 AM

Answers

  • Steven,

    Last week I was busy rolling out some urgent patches so I did not investigate further. As strange as it was that patches were not getting installed, as surprised I was to see now that the patches got installed on thursday 20/11/2014... without changing configuration or reinstalling the agent.

    Problem is solved but not sure what was the cause.

    Thanks again

    • Marked as answer by Steven_Lee0510 Monday, November 24, 2014 1:34 PM
    Monday, November 24, 2014 1:30 PM

All replies

  • Why do you use wsus 3.0 sp2 with 1012 server. There is a role in the console server manager
    Saturday, November 8, 2014 1:28 PM
  • nicolas,

    our wsus 3.0 SP2 is running on w2K8 R2 server. The server that I'm trying to update is a W2K12 machine.

    Any ideas?

    Sunday, November 9, 2014 7:08 PM
  • 2014-11-07 08:14:25:134  908 2914 AU WARNING: There are no approved updates to install

    It is a Windows 2012 server and we are using WSUS 3.0 SP2 to update our servers.

    The error message seems pretty self-explanatory. What have you done to investigate this condition?

    Have you installed KB2734608 on the WSUS Server and performed all required post-installation instructions?

    Have you actually approved any Windows Server 2012 updates? for a group that the WS2012 Server belongs to? Is this actually a WS2012 server, or a WS2012R2 server?


    Lawrence Garvin, M.S., MCSA, MCITP:EA, MCDBA
    SolarWinds Head Geek
    Microsoft MVP - Software Packaging, Deployment & Servicing (2005-2014)
    My MVP Profile: http://mvp.microsoft.com/en-us/mvp/Lawrence%20R%20Garvin-32101
    http://www.solarwinds.com/gotmicrosoft
    The views expressed on this post are mine and do not necessarily reflect the views of SolarWinds.


    Sunday, November 9, 2014 7:16 PM
  • Lawrence,

    not that self-explanatory I think...

    We are using this environment to update few thousand machines, including more than 100 windows 2012 machines. Only this one machine is not getting the updates. I forgot to mention that we use SCCM2012R2CU1

    Regards

    Monday, November 10, 2014 4:28 AM
  • Hi WiM8,

    So if you use sccm2012 R2, can you look on log wsyncmgr and WCM.log.

    if the wsus server is not on the sccm server, it is necessary to add a distribution point on the wsus server

    Monday, November 10, 2014 9:59 AM
  • I forgot to mention that we use SCCM2012R2CU1

    Yeah.. kinda critical in this scenario. It certainly explains why there are no approved updates.

    Deployment in an SCCM environment is not a WSUS issue, which begs the question of why this client is trying to deploy updates FROM WSUS. My guess would be that it's not properly configured as a ConfigMgr client.

    You may find more relevant help in the Configuration Manager forums.


    Lawrence Garvin, M.S., MCSA, MCITP:EA, MCDBA
    SolarWinds Head Geek
    Microsoft MVP - Software Packaging, Deployment & Servicing (2005-2014)
    My MVP Profile: http://mvp.microsoft.com/en-us/mvp/Lawrence%20R%20Garvin-32101
    http://www.solarwinds.com/gotmicrosoft
    The views expressed on this post are mine and do not necessarily reflect the views of SolarWinds.

    • Proposed as answer by Steven_Lee0510 Monday, November 24, 2014 11:48 AM
    Monday, November 10, 2014 4:56 PM
  • Hi,

    I’m writing to just check in to see if the suggestions were helpful. If you need further help, please feel free to reply this post directly so we will be notified to follow it up.

    Best Regards



    Steven Lee

    TechNet Community Support

    Monday, November 24, 2014 11:48 AM
  • Steven,

    Last week I was busy rolling out some urgent patches so I did not investigate further. As strange as it was that patches were not getting installed, as surprised I was to see now that the patches got installed on thursday 20/11/2014... without changing configuration or reinstalling the agent.

    Problem is solved but not sure what was the cause.

    Thanks again

    • Marked as answer by Steven_Lee0510 Monday, November 24, 2014 1:34 PM
    Monday, November 24, 2014 1:30 PM
  • Hi,

    Glad to hear that your issue is resolved and thanks for the feedback.

    Best Regards.



    Steven Lee

    TechNet Community Support

    Monday, November 24, 2014 1:35 PM