locked
SCCM 2012 on SQL 2008 R2 cluster RRS feed

  • Question

  • Hello,

    I have a problem installing SCCM 2012 on the SQL 2008 R2 cluster. When it goes through the prerequisites, and I specify my SQL server, it connects fine, but when it comes to creating the database on the server it fails, saying that it can’t connect to the server.

    I tried a different approach and installed a local copy of SQL 2008 R2. SCCM installed fine. I moved the database to the SQL cluster, tried to re-point to use cluster and it failed again. Here is some log from the attempt to re-point to cluster:

    INFO:  SQL Connection succeeded. Connection: clustername.domain MASTER, Type: Unsecure  $$<Configuration Manager Setup><04-27-2012 10:32:34.107-60><thread=4056 (0xFD8)>

    INFO: SQL Server clustername.domain is clustered.  $$<Configuration Manager Setup><04-27-2012 10:32:34.193-60><thread=4056 (0xFD8)>

    *** [08001][-2146893022][Microsoft][SQL Server Native Client 10.0]SSL Provider: The target principal name is incorrect.~~  $$<Configuration Manager Setup><04-27-2012 10:32:34.202-60><thread=4056 (0xFD8)>

    *** [08001][-2146893022][Microsoft][SQL Server Native Client 10.0]Client unable to establish connection  $$<Configuration Manager Setup><04-27-2012 10:32:34.202-60><thread=4056 (0xFD8)>

    *** Failed to connect to the SQL Server.  $$<Configuration Manager Setup><04-27-2012 10:32:34.202-60><thread=4056 (0xFD8)>

    INFO:  SQL Connection failed. Connection: SMS ACCESS, Type: Secure  $$<Configuration Manager Setup><04-27-2012 10:32:34.202-60><thread=4056 (0xFD8)>

    I tried to connect using the ODBC connection, name resolution and it was ok. Then I tried to use IP address instead of the name and I also used domain admin account and the same result.

    I would appreciate your help.

    Friday, April 27, 2012 10:00 AM

Answers