locked
Set-PhysicalDisk -MediaType XXXX -UniqueId abcdefgh --- Reverts after restart. RRS feed

  • Question

  • Hey All,

    In an attempt to change the media type of my different VHDs, I'm making this change within the VM.

    Set-PhysicalDisk -MediaType HDD -UniqueId 6xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxA
    Set-PhysicalDisk -MediaType SCM -UniqueId 6xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxF
    Set-PhysicalDisk -MediaType SSD -UniqueId 6xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx4

    But after a restart its all lost and MediaType is switched back to Unspecified.

    Any advise to keep this in place.

    Thanks


    yup

    Friday, November 2, 2018 8:53 AM

All replies

  • Hi,

    Thanks for posting in our forum.

    I have tested it in my lab, it’s working as expected on windows server 2016 Std (1607) and windows 10 Pro (1803). So, would you mind clarify the current OS version as I could perform further research?

    Best Regards,

    William


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, November 5, 2018 7:42 AM
  • Hi,

     

    Just want to confirm the current situations.

    Please feel free to let us know if you need further assistance.

     

    Best Regards,

    William


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, November 6, 2018 7:45 AM
  • Hey William,

    Thanks for your response & sorry I couldn't revert earlier.

    The change MEDIATYPE works well with 10.0.14393 but not on 10.0.17763.


    yup

    Thursday, November 8, 2018 5:28 AM
  • Hi,

    Thanks for your update.

    I will setup a new lab for test it, it may need some time delay.

    Appreciate your patience.

    Best Regards,

    William


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, November 12, 2018 10:06 AM
  • Hi,

    I would apologize for the delayed reply.

    I have tested in my lab with the same result as you mentioned.

    I will discuss it with other engineer to see if someone else have the same issue.

    Appreciate your patience.

    Best Regards,

    William


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, November 14, 2018 9:54 AM
  • Hi,

    I would apologize for the delayed reply.

    I have tested in my lab with the same result as you mentioned.

    I will discuss it with other engineer to see if someone else have the same issue.

    Appreciate your patience.

    Best Regards,

    William


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, November 14, 2018 10:11 AM
  • Hi,

    we are facing the very same issue. Windows server 2019 Std, server part of DAG cluster for Exchange 2019.

    we removed server from DAG/cluster, set the mediatype to SSD on virtual disk, after reboot the mediatype property is back to unspecified.

    we installed the latest security patches, Win 2019 is with full desktop experience...

    any help is appreciated ..



    PeBe

    Monday, June 24, 2019 8:51 PM
  • Same problem.

    Windows Server 2019 datacenter version 17763.1012 reverts physical disks to -mediatype unspecified and friendlyname to "VMware, VMware virtual S" after reboot.

    Not iet verified on 2016.

    Monday, January 27, 2020 9:32 AM
  • following command on windows server 2019 works but revert to unspecified after reboot

    get-physicaldisk | where size -eq 250GB | set-physicaldisk -mediatype SSD

    get-physicaldisk | where size -eq 500GB | set-physicaldisk -mediatype HDD

    same commands not working on windows server 2016

    any help appreciated.

    Regards.

    Thursday, February 6, 2020 1:33 PM
  • Same problem.

    Windows Server 2019 datacenter version 17763.1012 reverts physical disks to -mediatype unspecified after reboot.

    following command on windows server 2019 works but revert to unspecified after reboot

    get-physicaldisk | where size -eq 250GB | set-physicaldisk -mediatype SSD

    get-physicaldisk | where size -eq 500GB | set-physicaldisk -mediatype HDD

    same commands not working on windows server 2016
    Thursday, February 6, 2020 3:11 PM