none
Microsoft Edge Can't Open Local Domains RRS feed

  • Question

  • Hi Everyone,
    I've finally got my Windows 10 Pro installation up and running fairly smoothly. I have run into one problem, however, that I hope you can help me with. I am a web developer so I've setup a virtual instance of CentOS 7 (using VirtualBox) as my local testing server for my projects. It isn't anything too glamorous, but I have things setup so that 192.168.56.101 goes to the VM's web server. I've also setup a record in the Windows 10 host file to forward the domain "local" to this IP address. I'm able to SSH to this domain or IP with Putty. I'm able to access the VM's web server using the domain or IP with FireFox, Chrome, and Internet Explorer. However, if I try to access either the domain or IP address with the Edge browser, I'm told "Hmm, we can't reach the page." It's obviously something to do with Edge, but I'm not entirely sure what that might be. Anyone know what's going on?

    Thursday, August 6, 2015 8:39 PM

Answers

  • None of the above suggestions worked for me, but the comment about trusted sites by The Real Evan de la Cruz lead me to a solution:  unchecking the auto-detection for intranet sites from the (IE) internet options.

    To do this, I went to Control Panel > Internet Options > Security > Local Intranet  > Sites

    and unchecked "include all local (intranet) sites not listed in other zones" and "Include all sites that bypass the proxy server".

    I then saved my settings and restarted Edge.Internet Options Local Intranet site detection with first two settings unchecked

    • Proposed as answer by awe Friday, November 6, 2015 9:42 AM
    • Marked as answer by Michael_LSModerator Wednesday, December 30, 2015 5:50 AM
    Wednesday, October 21, 2015 5:54 PM

All replies

  • Hi IntegrityDC,

    Thank you for your question.

    if the Window Edge could not open this page, the issue could be caused by compatibility, we could see all intranet sites to automatically open with IE by the following link:

    https://technet.microsoft.com/en-us/library/mt270205.aspx

    If there are any questions regarding this issue, please be free to let me know.

    Best Regard,

    Jim


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Friday, August 7, 2015 6:33 AM
  • Thanks for your reply, Jim. But I don't think it's a compatibility problem. Edge isn't even bringing up any content at all. Even if I go to a simple "Hello world" script, it can't find the page. Anyway, using IE11 isn't really a solution as I need to use Edge for browser testing for my clients.
    Friday, August 7, 2015 3:28 PM
  • exactly the same... I think that I have troubles with my SQLSERVER instance and I  almost lost my head on this...

    Them I try Internet Explorer and the content renders on it...

    Same Chrome, Firefox, etc. But EDGE....

    Any possible reason?

    I have this site on my developer machine with HOST file edited to render my test web site on my local IP.

    By the way I'm using local IIS10. So all the services are running at the same machine.

    Thanks you and join to IntegrityDC in this looking forward...

    Monday, August 10, 2015 5:09 PM
  • Maybe this is related to the "Localhost-Loopback" restriction of "about:flags"?

    Possibly the browser identifies the IP as a local one and prevents loading withouch checking the setting?

    Wednesday, August 12, 2015 12:49 PM
  • NEatMaxworx,
    Thanks for your suggestion. I had checked about:flags and verified that loopback addresses were allowed. It doesn't look like Edge filters out 192.168.* IPs because I can access my router and modem (192.168.0.1; 192.168.100.1)

    Wednesday, August 12, 2015 2:46 PM
  • It was a suggestion where I think MS should take a look into.

    Most of our software is initial created for IE6-7, so I can´t use FF or something else. Because MS pages don´t let me download IE11 for Win10 (they didn´t detect the OS), I have to use a virtual machine to connect to my local websites until MS fixes edge :(

    Wednesday, August 12, 2015 3:20 PM
  • When I first installed Windows 10, everything was working fine. However, I must have pulled down an update that prevents Edge from connecting to the IP address of the local machine. I can connect to anything else on my local network. I can also connect to localhost. However, I have software that specifically invokes the default browser with the local IP address (i.e. 192.168.1.101), and this fails. No other browser in my system fails with this.
    Monday, August 17, 2015 6:37 PM
  • Same problem here. Thank you Microsoft for making testing locally on a development PC in Edge impossible: that really helps us out! :-p
    Tuesday, August 18, 2015 7:25 PM
  • Well, I found the source of my problem. Apparently, Edge had decided to blacklist my local IP address. I found my IP address in a list under [HKEY_CURRENT_USER\SOFTWARE\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppContainer\Storage\microsoft.microsoftedge_8wekyb3d8bbwe\MicrosoftEdge\TabProcConfig]. I deleted the entry matching my IP address and it started working again. Hope this might help somebody else with the same problem. I have no idea why it even added the entry.
    • Proposed as answer by bgnicoll Monday, April 11, 2016 4:04 PM
    Tuesday, August 18, 2015 11:32 PM
  • codewright2000, that's bizarre! I wish that would work for me, but no dice. Hopefully, it will help other folks though.
    Wednesday, August 19, 2015 3:43 PM
  • IntegrityDC, I have confirmed that the about:flags setting "Allow localhost loopback (this might put your device at risk)" will cause the same behavior, if unchecked. An additional thing you might want to check is to see if the same entry I listed above is in HKEY_LOCAL_MACHINE. Just spit-balling, but worth a check.
    Wednesday, August 19, 2015 5:52 PM
  • Thanks, codewright2000, but no luck. I had checked the about:flags->Allow localhost loopback before, and it's checked like it is supposed to be. Also there was nothing for Microsoft Edge in the HKEY_LOCAL_MACHINE registry entry. Thanks for the effort!
    Wednesday, August 19, 2015 7:25 PM
  • It worked for me.

    We could access sites hosted on our local domain using Edge as soon as I removed my local domain name from:

    HKEY_CURRENT_USER\SOFTWARE\Classes\

    Local Settings\Software\Microsoft\Windows\

    CurrentVersion\AppContainer\Storage\

    microsoft.microsoftedge_8wekyb3d8bbwe\MicrosoftEdge\TabProcConfig

    Tuesday, August 25, 2015 5:42 PM
  • I see that this is marked as an answer, but this actually doesn't fix the problem mentioned in the original post. "TabProcConfig" doesn't exist in my registry nor does the IP address or local domains that I can't access. Thanks for your input anyway, Zooper.
    • Proposed as answer by JohnRom.com Thursday, August 27, 2015 7:19 PM
    • Unproposed as answer by JohnRom.com Thursday, August 27, 2015 7:19 PM
    Thursday, August 27, 2015 3:52 PM
  • Hi IntegrityDC,

    If that, we suggest you run “SFC /ScanNow” in CMD to check if there are some corrupted files. Then post the result for our troubleshooting.

    If there are any questions regarding this issue, please be free to let me know.

    Best Regard,

    Jim

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Sunday, August 30, 2015 2:46 AM
  • No luck with the SFC /ScanNow utility. Is it safe to post the resulting log here?
    Sunday, August 30, 2015 3:47 AM
  • Hi IntegrityDC,

    You could post it to Onedriver and then shared it. Please don’t forget to give a link for us.

    If there are any questions regarding this issue, please be free to let me know.

    Best Regard,

    Jim

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Sunday, August 30, 2015 6:51 AM
  • Here are the results of the scan:

    CBS Log

    Sunday, August 30, 2015 9:12 PM
  • Hi IntegrityDC,

    We could try to the following solution:

    Please run gpedit.msc to open Group Policy Editor, then switch to Computer Configuration---> Windows Settings---> Security Settings ---> Local Policies---> Security Options, then enable "User Account Control: Admin Approval Mode for the Built-in Administrator account", after all restart Windows to take effect. Figure as below:

    If there are any questions regarding this issue, please be free to let me know.

    Best Regard,

    Jim


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Wednesday, September 2, 2015 3:13 AM
  • Hi Jim,

    I am not sure what the policy change is meant to do, but it does not make me able to browse to local virtual machines, nor does it make the aforementioned registry keys appear.

    I have the exact same problem as IntegrityDC, same setup as well. Neither the domain nor the IP address exist anywhere in the registry. Localhost loopback is enabled. Works fine in any browser I try, except Edge. It responds so fast, it does not even seem to be trying.

    Makes it incredibly difficult for me to fix an Edge-specific bug in one of my web applications. I was really looking forward to taking Edge for a spin but I've been stuck since day one.

    Thursday, September 3, 2015 11:31 AM
  • I have the same problem.

    Windows 10 Pro, running Wamp on local machine, having set up a virtual host-file in the Apache-config, and modified the hosts-file in Windows to match.

    I can reach my local domains (I only use the name it self, not TLD-ending, or any ending at all) via Firefox, Opera, Chrome or any other browser (including IE 11).

    Seems this is a problem with Edge being an App, instead of a desktop-program (for some reason).

    The interesting bit is that I _can_ reach localhost - that's not a problem (but due to the setup, it won't really help me view my sites, because if I go via localhost/domain, it breaks the pages internal structure).

    This needs to be fixed.

    Monday, September 7, 2015 8:35 AM
  • Just to follow up on these instructions provided by Jim, as expected, this change had no effect.
    Wednesday, September 9, 2015 3:53 PM
  • Hi IntegrityDC,

    Did you mean the solution didn’t work for you?

    If there are any questions regarding this issue, please be free to let me know.

    Best Regard,

    Jim

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Thursday, September 10, 2015 8:57 AM
  • Jim,

    That is correct. Adjusting the setting in Group Policy had no effect. It did not work.

    Thursday, September 10, 2015 6:21 PM
  • Hi IntegrityDC,

    If not, we suggest you open a case to Microsoft to get help.

    If there are any questions regarding this issue, please be free to let me know.

    Best Regard,

    Jim

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    • Proposed as answer by Cappybob Monday, December 14, 2015 9:53 PM
    • Unproposed as answer by Cappybob Monday, December 14, 2015 9:54 PM
    • Proposed as answer by Cappybob Monday, December 14, 2015 9:57 PM
    • Unproposed as answer by Cappybob Monday, December 14, 2015 9:57 PM
    Saturday, September 12, 2015 5:26 AM
  • Same problem here, using virtual box and a virtual network on 192.168.56.x
    Monday, September 14, 2015 2:51 PM
  • It worked for me.

    We could access sites hosted on our local domain using Edge as soon as I removed my local domain name from:

    HKEY_CURRENT_USER\SOFTWARE\Classes\

    Local Settings\Software\Microsoft\Windows\

    CurrentVersion\AppContainer\Storage\

    microsoft.microsoftedge_8wekyb3d8bbwe\MicrosoftEdge\TabProcConfig

    This worked for me, was driving me nuts trying to figure out why my Homeseer server wouldn't open in Edge, but would in IE, Chrome, etc.  

    Thanks Zooper!

    Friday, September 25, 2015 2:24 PM
  •  I checked with the upgraded windows 8.1 to 10 machine ad have the same problem and the Tab ProcConfig entry has the IP of my local server.  This entry(TabProcConfig) does not exist in Build 10547 and there is n o problem I can access local addresses on this version without problems .  Perhaps this was the problem?
    Monday, September 28, 2015 5:51 AM
  • I had this problem and none of the proposed fixes helped me.  The ultimate solution was to remove the domain names from the "Trusted Sites" list.  If you're like me, you probably don't even remember adding them.  More details here: http://comma8comma1.com/2015/10/microsoft-edge-cannot-open-local-web-sites/
    Saturday, October 10, 2015 8:46 AM
  • None of the above suggestions worked for me, but the comment about trusted sites by The Real Evan de la Cruz lead me to a solution:  unchecking the auto-detection for intranet sites from the (IE) internet options.

    To do this, I went to Control Panel > Internet Options > Security > Local Intranet  > Sites

    and unchecked "include all local (intranet) sites not listed in other zones" and "Include all sites that bypass the proxy server".

    I then saved my settings and restarted Edge.Internet Options Local Intranet site detection with first two settings unchecked

    • Proposed as answer by awe Friday, November 6, 2015 9:42 AM
    • Marked as answer by Michael_LSModerator Wednesday, December 30, 2015 5:50 AM
    Wednesday, October 21, 2015 5:54 PM
  • This worked for me under Windows 10 Pro French Version. Thanks Brianna B, this solution solved my problem to open local host network by the hostname instead of localhost.

     unchecked only "include all local (intranet) sites not listed in other zones", in French "Inclure tous les sites locaux (intranet) non mentionnés dans d'autres zones".
    • Edited by asiahome Sunday, November 1, 2015 1:11 PM
    Sunday, November 1, 2015 1:06 PM
  • Thanks Brianna B, it worked for me also but I too only had to uncheck the one setting "include all local (intranet) sites not listed in other zones" to get it to work.
    Wednesday, November 11, 2015 5:49 PM
  • Played around with this some more and just turning on the "Automatically detect intranet network" setting also works for me.
    Thursday, November 12, 2015 9:19 PM
  • Confirmed - "Automatically detect intranet network" fixed it for me too. Mostly just a workaround than a fix. After all, Edge should not behave so differently from IE.
    Tuesday, December 15, 2015 7:52 AM
  • Deleting the entry in the registry worked for me.
    Wednesday, December 23, 2015 11:03 AM
  • I have tried all of these and still can't get anything working in Edge.

    My real problem is that I can't see localhost from my Win 10 UWP app, but I'm guessing that the Edge thing is related.   

    I've been looking for a solution for about 2 months now and tried absolutely everything suggested here and elsewhere.    

    All I want to be able to do is develop and test the front end and back end of an app on the same laptop.  

    How difficult can this be? 

    Sunday, January 3, 2016 7:23 PM
  • Unfortunately, none these solution have not worked for me either. I connect to a corporate LAN using Shrew Soft IPsec VPN adapter that adds a virtual Ethernet NIC, and update the routeing table to direct traffic to various different IP address ranges (such as 10.x.x.x) via this NIC. All pretty standard stuff.

    However, attempting to browse these private IP address in Edge results in the same issue.

    After checking the Windows Feedback for Edge, multiple people are experiencing the same issues.


    Chris

    Tuesday, March 8, 2016 7:14 PM
  • This is great! Save hours, Thanks
    Friday, March 25, 2016 3:19 AM
  • I have been having issues with Edge browser trying to get to local IP addresses of printers and other resources.   It is very inconsistent though, I can get the the webpages for 2 of the printers, our local Exchange server and Sharepoint, but not other local sites.  If I bring up Chrome or IE, the same site loads fine.   All sites also work fine from the outside world.  I found that stopping the Windows Firewall service resolved all of the issues with Edge browser, so I tried making rules to allow all inbound and outbound. This did not solve the issue, the firewall service has to be completely stopped to resolve the issue.   I thought I could live with this until I tried to download an app from the Windows Store only to find out that it will error out if the Firewall service is not running.    Back to Chrome for now.... 

    Monday, May 9, 2016 7:21 PM
  • Wow! This just started for me this morning. I fortunately found this discussion and this solution worked for me.

    My domain was in this registry key. I removed it and things started working just fine.

    Thursday, May 11, 2017 6:35 PM
  • I know this is a very old post but I have just upgraded to Windows 10 at work and was searching for a very long time with all suggestions failing until this one! Thanks for the solution!
    Wednesday, June 7, 2017 8:56 AM
  • Many thanks.
    It worked for me.
    Tuesday, June 13, 2017 8:23 AM
  • My "Sites" button is disabled, so it didn't worked.
    Monday, July 3, 2017 3:31 PM
  • This solved it for me, thank you!
    Thursday, July 27, 2017 5:02 PM
  • Well, I found the source of my problem. Apparently, Edge had decided to blacklist my local IP address. I found my IP address in a list under [HKEY_CURRENT_USER\SOFTWARE\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppContainer\Storage\microsoft.microsoftedge_8wekyb3d8bbwe\MicrosoftEdge\TabProcConfig]. I deleted the entry matching my IP address and it started working again. Hope this might help somebody else with the same problem. I have no idea why it even added the entry.

    So, I just ran into a similar issue. I have a bunch of local websites running on IoT devices and all of a sudden Microsoft Edge wouldnt allow me to open newly added devices (it worked in IE11 and Chrome though...). So, while I could still reach 192.168.0.1 and 192.168.0.9 over https as well as 192.168.0.150, 192.168.0.252, 253, 254 and so on over http it just showed a generic "Hmmm...can't reach this page" message for the newly added 192.168.0.136 as well as an older Raspberry Pi running Win10 IoT edition.

    I went to the registry key mentioned above and what I found was that all the sites that did load were in that list. I added a few which didn't and lo and behold, they now load as well.

    I have obviously not added the previous entires manually in the past, so I have no idea what is really going on. But at least I can now go on with developing.
    Tuesday, November 21, 2017 12:22 PM
  • None of the mentioned above worked for me. Like NOTHING I always wanted to use the Edge for my dev machine and you know ... forget a little bit about Chrome .. but it just doesnt work for me I tried litterally everything. If someone wanna help me out from the microsoft team I would be more than happy !

    • Tried the internet Options Method : didnt work (Automatically detect intranet network) or whatever
    • Tried to reinstall Edge : didnt work
    • Well I dont have the gpedit.msc .... so I dont think this is the solution ... 
    • I don't have the registry entry 'TabProcConfig' 

    Any help will be appreciated

     I have a vm, I put entries in the hosts file and I'm using firefox/chrome for dev/testing, one of our customers had an issue with Edge ... 

    Thanks !

    Thursday, March 22, 2018 7:43 PM
  • I don't have anything in that hive. What type of key do you enter and is it IP only or domain names also?
    Wednesday, April 4, 2018 1:37 PM
  • I tried various suggestions above but I couldn't find one that worked for me. In particular I tried:

    1. Using about:flags and confirming that "allow localhost loopback" was on

    2. Control panel, Network and Internet, Internet Options, Security and adding my site explicitly to Trusted Sites or Local Internet.

    3. CheckNetIsolation LoopbackExempt -a -n="Microsoft.MicrosoftEdge_8wekyb3d8bbwe"

    My environment

    In my case, I have VirtualBox 5.2.18 running on Windows 10 build 1803 "Spring Creators Update". Using Edge 42.17134.1.0. I have a host-only network for my VM guests. e.g. 192.168.7.0/24. I couldn't access addresses from my Edge on the VM host such as http://192.168.7.0. This site was hosted by a web server running in my VM guest. Note that this address worked just fine in Google Chrome, Internet Explorer 11 etc.

    What works

    The solution is as follows:

    1. Find the interface number for the host only network. I ran "route print" from the Windows command line and the first number shown in the "interface list" in my case was 17.

    2. Use regedit to change the interface type from 1 to 0. The key is:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e972-e325-11ce-bfc1-08002be10318}\XXXX

    In my case XXXX was 0016 because my interface number was 17. I had to change *NdisDeviceType from 0 to 1. The * in that key name is a literal asterisk. I had to reboot for the changes to take effect.

    The answer was gleaned from a post by "Jani L" dated Oct 3, 2017, on the first URL referenced below, but it didn't give a clue as to how to determine the interface number.

    References:

    https://developer.microsoft.com/en-us/microsoft-edge/platform/issues/10142843/

    https://www.virtualbox.org/ticket/15565

    Monday, September 3, 2018 6:01 AM
  • I tried various suggestions above but I couldn't find one that worked for me. In particular I tried:

    1. Using about:flags and confirming that "allow localhost loopback" was on

    2. Control panel, Network and Internet, Internet Options, Security and adding my site explicitly to Trusted Sites or Local Internet.

    3. CheckNetIsolation LoopbackExempt -a -n="Microsoft.MicrosoftEdge_8wekyb3d8bbwe"

    My environment

    In my case, I have VirtualBox 5.2.18 running on Windows 10 build 1803 "Spring Creators Update". Using Edge 42.17134.1.0. I have a host-only network for my VM guests. e.g. 192.168.7.0/24. I couldn't access addresses from my Edge on the VM host such as http://192.168.7.0. This site was hosted by a web server running in my VM guest. Note that this address worked just fine in Google Chrome, Internet Explorer 11 etc.

    What works

    The solution is as follows:

    1. Find the interface number for the host only network. I ran "route print" from the Windows command line and the first number shown in the "interface list" in my case was 17.

    2. Use regedit to change the interface type from 1 to 0. The key is:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e972-e325-11ce-bfc1-08002be10318}\XXXX

    In my case XXXX was 0016 because my interface number was 17. I had to change *NdisDeviceType from 0 to 1. The * in that key name is a literal asterisk. I had to reboot for the changes to take effect.

    The answer was gleaned from a post by "Jani L" dated Oct 3, 2017, on the first URL referenced below, but it didn't give a clue as to how to determine the interface number.

    References:

    https://developer.microsoft.com/en-us/microsoft-edge/platform/issues/10142843/

    https://www.virtualbox.org/ticket/15565

    I have a similar setup but with vmware, my solution was a bit different, I had to set *NdisDeviceType to 0.

    I'm using latest 1803 and I don't think the output of "route print" relates to the numbers in the registry, my vmware adapter was numbered as 9 and registry key was 0005, I just searched for the adapter by name to know where to edit the "*NdisDeviceType" value ("DriverDesc" = "VMware Virtual Ethernet Adapter for VMnet8").

    Thanks
    Monday, December 31, 2018 11:31 PM
  • I'm running the latest win 10 V 1809 build 17763.253.

    None of the stuff listed on this thread worked for me. 

     I found a workaround on another thread,  by adding the local IP range to the trusted sites, it works for me.

    Second workaround is using the server name instead of the IP address.

    Example: http://Computer-name/  which gets resolved to IP version 6 address.

    Since this is bug only happens with MS EDGE and works fine with all other browsers,  where is the official MS solution ?





    • Edited by fg2001 Tuesday, January 22, 2019 10:20 AM
    Tuesday, January 22, 2019 3:50 AM
  • Hi thanks for the tip!

    Im running Win 10 pro 1803 04.06.2018 17134.523

    Adding the IP-adresses in that way solved my problem with edge to display local IP adresses.

    All other things dont't work in my case.

    Funny that all other browsers (Chrome, Firefox and IE) have no problem with local IP adresses in our network.


    • Edited by olixan Wednesday, January 23, 2019 12:12 PM
    Wednesday, January 23, 2019 12:11 PM
  • Just ran into this where I work. We have an internal corporate network using a .domainname.local internal domain. When using Edge to access websites internally, it works if we specify only the hostname, fully qualified, it does not. Nor does it work using the IP address.

    This seems to have just started within the past month, and whats odd is, it works for some users just fine using the fully qualified name, while others it does not work. And, for those that it does not work on, rebuilding their machine or recreating their profile, it still does not work. Additionally, if we rebuild the machine or recreate the profile for users it does work on, it will break it for them. This leads me to believe a setting got set and is stuck for some users that allows it to work.

    Using the internal IP address works for no one.

    To be clear:

    http://hostname = works for everyone
    http://hostname.domainname.local = works for some, but not others. Rebuilding the computer or recreating a users profile will cause this to stop working
    http://10.0.0.5 = works for no one

    If we add *.domainname.local or the IP address to the trusted intranet sites, then this fixes the issue. However, without these added, IE works just fine. Neither Firefox or Chrome present these issues either.

    Anyone?

    Wednesday, January 23, 2019 7:03 PM
  • Just ran into this where I work. We have an internal corporate network using a .domainname.local internal domain. When using Edge to access websites internally, it works if we specify only the hostname, fully qualified, it does not. Nor does it work using the IP address.

    This seems to have just started within the past month, and whats odd is, it works for some users just fine using the fully qualified name, while others it does not work. And, for those that it does not work on, rebuilding their machine or recreating their profile, it still does not work. Additionally, if we rebuild the machine or recreate the profile for users it does work on, it will break it for them. This leads me to believe a setting got set and is stuck for some users that allows it to work.

    Using the internal IP address works for no one.

    To be clear:

    http://hostname = works for everyone
    http://hostname.domainname.local = works for some, but not others. Rebuilding the computer or recreating a users profile will cause this to stop working
    http://10.0.0.5 = works for no one

    If we add *.domainname.local or the IP address to the trusted intranet sites, then this fixes the issue. However, without these added, IE works just fine. Neither Firefox or Chrome present these issues either.

    Anyone?

    Nevermind, issue found.

    https://support.microsoft.com/en-us/help/4476976/windows-10-update-kb4476976
    After installing KB4480116, some users report that they cannot load a webpage in Microsoft Edge using a local IP address. Browsing fails or the webpage may become unresponsive.

    Wednesday, January 23, 2019 7:52 PM
  • This didn't work for me.  

    Love, praise, and worship God :)

    Thursday, January 24, 2019 4:40 PM
  • Apparently a recent update has caused this issue again.

    Instead of unchecking those Local Intranet options, I simply hit "Advanced" and added the Local IP Address I needed to the list. No more problem.

    Finger, poke, break. Finger, poke, break. It's what Microsoft loves to do. lol

    Friday, February 1, 2019 10:26 PM
  • Tries everything listed above. Still doesn't work. Very frustrating...
    Saturday, February 23, 2019 2:41 AM
  • Me too. It seems like Edge does not obey DNS. It looks like it uses external ip instead of the local one. But the most interesting part is that when i use npcap (like with wireshark) it works. And when ik quit npcap it does not work any more.

    Does Edge use a secret proxy?

    Tuesday, March 12, 2019 11:14 AM
  • I found my IP address in a list under [HKEY_CURRENT_USER\SOFTWARE\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppContainer\Storage\microsoft.microsoftedge_8wekyb3d8bbwe\MicrosoftEdge\TabProcConfig]. I deleted the entry matching my IP address and it started working again.
    Worked perfectly for me. No idea how it ended up in there, but it did.
    Sunday, May 12, 2019 8:45 PM
  • This works for me, I have a real domain pointing to multiples local development websites at home *.XXXX.net -> 192.168.1.*

    Thanks!
    Sunday, January 12, 2020 7:19 PM