none
Fast Search configuration failing RRS feed

  • Question

  • Hi, these are the steps that I am Following while running the configuration wizard..
    Step 1:->Choose Single server deployment(StandAlone)
    Step 2:->Provided Username <domain>\<administrator>
     password <password used by the admin account>
    Step 3:->Setting the cirtificate password same as that for the user.
    Step 4:->Setting ServerName same as that of my DomainName,port being 8000.
    Step 5:->Setting Database string as <server name>\<instance name>,keeping database name and port same.
    Step 6:->Checking <do not enable click through relevancy> option.
    Step 7:->Then click on configure.
    After following these steps the configuration fails, giving error in a log file.
    but its hard to find whats the error so can anybody help me out to check what may be the cause of this.
    thanks in advance,
    eStore.
    Tuesday, May 24, 2011 4:35 AM

All replies

  • It would help if you could provide the log file. Share it on http://pastie.org/ or similar if you don't want to paste it here.

    Regards,
    Mikael Svenson 


    Search Enthusiast - MCTS SharePoint/WCF4/ASP.Net4
    http://techmikael.blogspot.com/
    Tuesday, May 24, 2011 7:06 AM
  • Hi,

    I have pasted the log file at this location

    http://pastie.org/1964988

     

    regards,

    eStore.

    Tuesday, May 24, 2011 7:31 AM
  • Hi,

    I have figured out the error thats causing the configuration to fail.

    Its taking the password as "System.string" type where as it expects a value that is of "System.Security.SecureString" type.

    So can anybody tell me how to make the password value as "System.Security.SecureString" type so than configuration can continue.

    Regards,

    eStore.

    Tuesday, May 24, 2011 9:48 AM
  • Hi eStore,

    If this is the default setup scripts you are running it's weird that you get this errors. Or are you running it as a silent install?

    Either way, documentation on SecureString for PowerShell can be found here: http://technet.microsoft.com/en-us/library/dd347656.aspx

    Regards,
    Mikael Svenson 


    Search Enthusiast - MCTS SharePoint/WCF4/ASP.Net4
    http://techmikael.blogspot.com/
    Tuesday, May 24, 2011 10:11 AM
  • Hi Mikael,

    I removed the silent installation option plus for the password one i inserted the command ConvertTo-SecureString -AsPlainText -Force -Sting <password>.

    its now showing an error message that->"Insufficient disk space to write a log file C:\FastSearch\var\log\installer".

    I have around 16gb empty space on my disk.

    Regards,

    eStore.

    Tuesday, May 24, 2011 10:37 AM
  • Hi,

    I am running scripts to configure the FAST Search Engine but its showing an error that its not able to configure the database..

    I am providing database connection string as <servername>\<instance name>

    how can i check whats my correct connection string?

    Regards,

    eStore.

    Wednesday, May 25, 2011 5:37 AM
  • Hi,

    Have you checked that the user doing the install had DB creator access (http://technet.microsoft.com/en-us/library/ff381243.aspx#BKMK_SetUpPermissionsForMicrosoftSQLServer).

    And also check the log files in C:\FastSearch\var\log\installer for more detailed information.

    Regards,
    Mikael Svenson 


    Search Enthusiast - MCTS SharePoint/WCF4/ASP.Net4
    http://techmikael.blogspot.com/
    Wednesday, May 25, 2011 9:07 AM
  • Hi,

    Yes i made that sure that the user doing the install has dbCreator permission.

    regards,

    eStore.

     

    Wednesday, May 25, 2011 9:18 AM