none
Forms Based Authentication in Project Server 2013 RRS feed

  • Question

  • Hi,

    I have created a PWA web app with SQL Forms Based Authentication. I am able to login and able to see the Project Center page.

    But the Project Center Web Part is not getting displayed. Also facing the same issue while

    • Enterprise Custom Fields and Look up page, the page is blank
    • When user tries to edit user in Manage Users page under Security, that page is also blank
    • Projects ribbon doesn't show up
    • User not able to create projects

    Kindly provide some pointers for the same.

    Thanks & regards,

    Divyang Agrawal

    Friday, December 13, 2013 5:04 AM

All replies

  • Do you have enough hardware??

    Check FBA configuration for SharePoint 2013 in the link

    http://blogs.technet.com/b/speschka/archive/2012/07/28/fba-configuration-manager-for-sharepoint-2013.aspx


    kirtesh


    • Edited by Kirteshtiw Friday, December 13, 2013 6:34 AM
    Friday, December 13, 2013 5:16 AM
  • I think yes, we have enough hardware, because when we log in to the FBA enabled site using the default sign in page(after entering the forms user's credentials) everything (Project , Resource Center) displays as expected.

    Only when we login using the Custom sign in page, using the code we get problem.

    bool authenticated = SPClaimsUtility.AuthenticateFormsUser(url, username, password);

    if(authenticated) {

    Response.Redirect(home page usrl, false);

    }

     
    Monday, December 16, 2013 5:21 AM
  • Hi Kirtesh,

    Thanks for the response.

    The issue here is not related to hardware, but it is regarding the user not having appropriate rights to do the above mentioned operations.

    Are there few more steps that are required for the FBA, where a user needs to be given access rights explicitly.

    The users I have used for now have been added to administrator's group and have full rights on the system.

    Also, when I try to create a Project in the instance using the CSOM code and passing the user's credentials who is a part of Administrator Group., it gives me a 403 forbidden exception.

    Kindly provide some inputs for the same.

    Regards,

    Divyang Agrawal

    Monday, December 16, 2013 6:07 AM
  • http://technet.microsoft.com/en-us/library/cc197705(v=office.12).aspx

    Link is having information about assigning permission to user from manage user.


    kirtesh

    Wednesday, December 18, 2013 9:54 AM
  • Thanks Kirtesh for ur help.

    Ribbon and Project Center not displaying issue is solved now.

    We are using a LoadBalancer (Pound). some scripts which are responsible for loading the Project Center and SharePoint ribbons not getting loaded. Because Pound was not configured to allow them .So we simply configured pound to allow those scripts and issue was solved.

    But as Divyang said, another issue is still pending- when we try to create a Project in the instance using the CSOM code and passing the user's credentials who is a part of Administrator Group., it gives me a 403 forbidden exception.

    Please provide any pointers on this.

    Regards

    Rizwan Shaikh.

    Wednesday, December 18, 2013 10:12 AM