sticky
October 2018 Updates fixes many App-V Issues RRS feed

  • General discussion

  • I am hearing from several people with widely different file based issues with App-V on Windows 10 that the October 2018 rollup fixes their issues.

    It appears that there was a nasty NTFS bug which affected App-V and that seems to be the culprit. Information on this fix is included in Kb4462392, KB4463932, and KB4463933, which is the same fix released on different versions of Windows 10 as part of the October 2018 updates. (Presumably there are server versions on these also). The relevant item (copied from 4462392) is described only as

         "Addresses an issue that can cause App-V packages to fail because of a missing file or DLL error"

    But has been seen in many ways beyond just dll issues.

    I originally reported on this issue as a problem with App-V Connection Group layering in this post: https://social.technet.microsoft.com/Forums/en-US/7121f953-7875-4f8e-8cdb-18262297c592/confirmed-issue-with-1803-may-rollups-and-connection-group-merging?forum=mdopappv .

    A customer reported to me privately a RunVirtual failed to trigger when the referenced package was a connection group when used by a user with standard user rights but works with the user having admin rights. This is confirmed fixed with this update as well.

    Another customer reported privately an issue with VFS files not being found.

    There are many other issues here in the forums that seem likely candidates to be solved by this issue as well.


    App-V MVP & CTP Fellow. Author of AppV books: PowerShell with App-V 5, The Application Book, & Window Caching (http://www.tmurgent.com/Books)

    Wednesday, November 7, 2018 12:00 PM
    Moderator

All replies

  • Does it fix performance issues? That's our main problem, compared to App-V on 2008 R2 performance went down with like 200% on Windows Server 2016.

    Saturday, November 17, 2018 11:02 AM
  • Tim, do you think this could be a cause of permissions not being applied correctly.

    I have an app that has been working without issue for 3 years until w10 1709 update..now the full permissions set aren't recognised in the VFS.

    Thanks


    snoopv

    Monday, April 1, 2019 2:18 PM
  • Hi Tim,

    I'm running into a DLL not found issue on 1809 LTSC, with all current updates.

    The application is autograph maths and can be downloaded here: http://www.autograph-maths.com/downloads/windows/network/ and you can package it without a licence file in trial mode.

    After sequencing there is a BOCOF.DLL missing error, however procmon traces see the main exe of the application having all sorts of successful attempts to open and read this dll file.

    These updates should apply to the 1809 LTSC build right?  Searching for the KB numbers just brings up this post

    Could this be related?  I can't find any evidence of why the DLL error appears as all my troubleshooting shows the application working correctly.

    Thanks


    Friday, September 6, 2019 5:12 PM
  • I can't confirm if it is in 1809LTSC, but would assume it has to be.  It seems really odd if procmon shows the file be loaded and then you get an error message that it wasn't found.  I wouldn't trust the developer message and make sure it isn't something else missing.

    You can always try sequencing on a different OS and testing on your production build. But it does sound like this issue, and the issue was runtime not packaging.


    App-V MVP & CTP Fellow. Author of AppV books: PowerShell with App-V 5, The Application Book, & Window Caching (http://www.tmurgent.com/Books)


    Friday, September 6, 2019 6:05 PM
    Moderator
  • Hi Tim,

    Thank you very much for responding, gave me a few more idea's to try with a little bit more searching on further errors.

    I had an old 5.0 package for this application, which I tried and worked, one difference was PVAD location from 5.0 so I tried enabling PVAD as per your blog. This changed the performance of the package to instead error with a 0xc0000142 error, which usually means dirty empty folder in the package (but I usually only see this when editing and saving a package with these extra folders).  Tried removing all I could find and still the same error, confirmed with a Virtual Filesystem failure in event log.

    I found a reference to one person struggling with this issue with the 1809 sequencer, they reverted back to a previous sequencer and it worked without error.  Tried the same with the 1709 sequencer and it worked perfectly but did require the PVAD being manually set to the application install folder!  I'm afraid I can't find the reference again to switching to an older sequencer, found it over the weekend but don't have it on the PC I'm using at work.

    So thank you!

    Chris.

    Monday, September 9, 2019 10:37 AM
  • Thanks for letting us know what worked for you.

    For completeness, I assume use of the 1709 sequencer was on a 1709 OS VM for sequencing, but newer OS version for testing at the client, correct?


    App-V MVP & CTP Fellow. Author of AppV books: PowerShell with App-V 5, The Application Book, & Window Caching (http://www.tmurgent.com/Books)

    Monday, September 9, 2019 3:57 PM
    Moderator
  • Hi Tim,

    No, I uninstalled the 1809 sequence and installed the 1709 sequencer on the 1809 LTSC OS VM

    Client is 1809 LTSC OS

    Chris.


    Tuesday, September 10, 2019 8:07 AM
  • Thanks for detailing.

    I'm glad that worked for you, but when installing the sequencer I am generally uncomfortable with using an ADK version different from that of the underlying OS.  The reasoning is that the sequencer and client share a lot of components and the ADK sequencer is only the subset not included in the client that is in the OS.  So you used a mixed set, but it worked for you in this case. My preference would have been to sequence on 1709 with the 1709 ADK.


    App-V MVP & CTP Fellow. Author of AppV books: PowerShell with App-V 5, The Application Book, & Window Caching (http://www.tmurgent.com/Books)


    Tuesday, September 10, 2019 11:12 AM
    Moderator
  • Hi Tim,

    Thanks for the advice - I might look at setting up some various VM's to match OS and sequencer in case they are needed for a package.

    I've started getting a few more of these 0xc0000142 errors with packages I'm remaking/updating on 1809 to replace our Windows 7 versions, deleting the empty folders in the sequencer after packaging is fixing it, but it's a bit of a pain.

    If that continues I'm considering switching back to an earlier sequencer to see if the issue goes away, there should be no issue in running packages built in sequencers earlier than the OS version?  I would image it's not a good idea to use a sequencer more recent than the client OS though?

    One issue is that I can't find any release notes to make an informed decision of if I'm missing any features or bug fixes by reverting back to an earlier sequencer version, I found your App-V updates page which is taken from various update KB information as you seemed to be struggling to find a definitive list of changes for App-V since it was integrated into the OS?  I guess they just don't provide this and we have to guess or notice any changes if we use an earlier sequencer version?

    Sorry for hijacking the thread a bit!

    Thanks!

    Chris.

    Thursday, September 12, 2019 1:21 PM