locked
The server is failing to download some updates - 2012 R2, full SQL & win10 updates RRS feed

  • Question

  • I have WSUS on 2012 R2 using full SQL.  I tried to approve some windows 10 updates.  Download status stays at "downloaded 4942 of 4942 MB".  I then unapproved those updates and nothing changes.  I do have event ID 10032 "server is failing to download some updates"

    What I have tried so far; I believe I have done all the steps for win10 updates; I have added the mime type in IIS, checked for KB3159706 (not installed, says not applicable), re-did the post install, rebooted, ran clean up wizard, ran AJTek's maintenance wizard.

    This is the parent upstream server of 13 downstream replica servers.  Except for these stuck updates, it seems to be working OK.  I have considered reinstalling WSUS and redownloading everything but because I am using full SQL, would I need to delete that database?  I suspect there may be some database corruption which may or may not be related to this issue

    Monday, October 29, 2018 1:57 PM

All replies

  • Hi,

    WSUS will download updates' metadata into SUSDB, download update binary files into WSUS Content folder. 

    Therefore, you can delete the download files of the update in the content folder. Besides, you can delete the metedate from the SUSDB with SQL server management studio.

    Best regards,
    Johnson
    =====================
    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.
    Tuesday, October 30, 2018 5:55 AM