none
Remote Desktop Connection Fails - This computer cant't connect to the remote computer RRS feed

  • Question

  • Hello,

    I am facing an issue while attempting Remote Desktop Connection from Windows 7 Professional machine.

    When trying to take an RDP of a Windows 2016 Server using "MSTSC - Microsoft Remote Desktop Connection" I get an error " This computer can't connect to the remote computer. Try connecting again. If the problem continues, contact the owner of the remote computer or your network administrator."

    However, when I select the "Connect and don't warn me" option in the advanced section of Server Authentication Tab (MSTSC), it connects.

    Can anyone please guide me to resolve this problem ? Do I need to make changes at the server end or the Desktop level ?

    The version of Remote Desktop Connection I am using is "Shell Version 6.2.9200, Remote Desktop Protocol 8.0 Supported"

    Thanks,

    Swapnil.


    Swapnil Malpani

    Friday, March 8, 2019 4:38 AM

All replies

  • hi,

    did you disable tls 1.0 on server 2016 ?

    2 can you install below update on win7 ?
    https://support.microsoft.com/en-us/help/3080079/update-to-add-rds-support-for-tls-1-1-and-tls-1-2-in-windows-7-or-wind
    3 if you ping the hostname of server 2016 on win7 ,is it work ?
    4 what's the function of the server 2016 ,is it only session host or DC ?
    5 If you use mstsc /admin in command prompt on win7 ,then remote access server 2016 ,what's the result ?


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, March 8, 2019 2:38 PM
  • Is there any progress on your question?

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, March 12, 2019 2:13 AM
  • hi,

    TLS 1.0 is not disabled on the server.

    Ping is not allowed from the desktop as a firewall rule. However, I am able to telnet RDP port.

    mstsc/admin also results in same behaviour. Same error.


    Swapnil Malpani

    Tuesday, March 12, 2019 8:21 AM
  • hi,
    1 check if remote session related service is started on win7. like picture 1
    2 turn off the firewall temporarily on win7 client and check the result .
    3 go the destination session host server and uncheck "allow connection only from computers running remote desktop with network level authentication" and check the result . like picture 2



    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Thursday, March 14, 2019 8:16 AM
  • Is there any progress on your question?

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, March 26, 2019 8:22 AM