none
Hyper-V failed to enable replication for virtual machine RRS feed

  • Question

  • Hi,

    I'm trying to configure replication between 2 Windows 2016 in a workgroup.

    I followed this great article : https://the-server.ninja/2015/05/13/enable-hyper-v-replication-between-two-workgroup-servers/

    So, after that, I try to replicate a VM but I've got this error (with the GUI) :

    Hyper-V failed to enable replication for virtual machine 'serverTEST': The connection with the server was terminated abnormally (0x00002EFE). (Virtual machine ID AA298ECC-BC7F-4D0B-8359-A0AFA8B9D679)

    I tried to disable firewall on each node but the issue is still present.

    Do you have an idea to help me?

    Thanks!

    Christophe


    Monday, August 20, 2018 9:49 AM

All replies

  • Hi,

    There's a good discussion post about a similar environment, although server 2012 R2 but also in workgroup, have a look at it below:

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/bd1c0af0-ec16-40c7-83f2-3c8e1ac8916b/hyperv-0x00002efe-error-workaround-in-certificate-based-replication?forum=winserverhyperv

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Monday, August 20, 2018 9:57 AM
  • Hi,

    I thought that the problem was related with the certificates. So, I delete all certificates and renamed by replica server (it's currently for testing, I'm doing a POC).

    After that, I recreated and imported certificates.

    I tested as described in this article but I've another error :

    Enable-VMReplication : The operation on computer 'XEONOLD' failed: The WinRM client cannot process the request. If the authentication scheme is different from Kerberos, or if the client computer is not joined to a domain, then HTTPS transport must be used or the destination machine must be added to the TrustedHosts configuration setting. Use winrm.cmd to configure TrustedHosts. Note that computers in the TrustedHosts list might not be authenticated. You can get more information about that by running the following command: winrm help config.
    At line:1 char:1

    On my main server, I tested this winrm command :

    winrm set winrm/config/client @{TrustedHosts="XEONOLD"}

    But nothing works :-( I become crazy ...

    What could I test now?

    Thanks for your help.

    Kind regards,
    Christophe

    Wednesday, August 22, 2018 6:27 AM
  • What is your result when running the winrm set winrm/config/client @{TrustedHosts="XEONOLD"}  ?

    You could also try the steps provided in this post, see if they could be of any help.





    Blog: https://thesystemcenterblog.com LinkedIn:

    Wednesday, August 22, 2018 6:57 PM
  • Hi,

    Here's the result :

    C:\Users\Administrator>winrm set winrm/config/client @{TrustedHosts="XEONOLD"}
    Client
        NetworkDelayms = 5000
        URLPrefix = wsman
        AllowUnencrypted = false
        Auth
            Basic = true
            Digest = true
            Kerberos = true
            Negotiate = true
            Certificate = true
            CredSSP = false
        DefaultPorts
            HTTP = 5985
            HTTPS = 5986
        TrustedHosts = XEONOLD

    I'm going to test as explained in the other article.

    Thursday, August 23, 2018 8:21 AM
  • Okay, let us know how it goes!

    Blog: https://thesystemcenterblog.com LinkedIn:

    Thursday, August 23, 2018 8:23 AM
  • I imported the replica certificate (it was done before) but I don't know how I can change the FQDN.

    When I import the certificate, I can't change the name ...

    Thursday, August 23, 2018 8:34 AM