none
Project Server 2010 Email text shows HTML tags RRS feed

  • Question

  • Hello,

    I am facing a problem where the Project Server approval email sent to the portfolio managers is showing HTML tags in outlook.

    Hello<br/><br/>There is a proposal titled "test 1" created by "user" submitted for your review. Follow these steps to approve or reject the proposal:Click <a href="">this link</a>to view the proposal...

    We tried changing the default option set for outlook to display email in HTML but to no avail.

    Any help is much appreciated.

    Thank you.

    Wednesday, October 3, 2012 1:35 PM

Answers

All replies

  • Update:

    The sample proposal workflow email doesn't show this problem. Only my custom workflow. Keeping in mind that i didn't change anything in the email text or settings or activities.

    Monday, October 8, 2012 7:41 AM
  • That additional information is helpful. The email is generated by the workflow itself, and has nothing to do with Project Server settings, so the culprit is most likely a bug in your custom workflow. Have the developer crack it open and fix it.

    Gary Chefetz, MCITP, MCP, MVP msProjectExperts
    Project and Project ServerFAQs
    Project Server Help BLOG

    Monday, October 8, 2012 9:18 AM
    Moderator
  • Thank you for your reply Gary,

    The thing is I took the code from Microsoft Project Server SDK and changed a few things in it, but i didn't change anything related to the task emails, the changes i made were only adding activities for updating custom fields.

    So using microsoft's SDK code i built the workflow and deployed it. And the emails get sent with the HTML tags.

    Have you heard of such an issue? Could the SDK code be originally corrupted?

    Monday, October 8, 2012 9:58 AM
  • Update:

    Here is the HTML i get when i click on view source of the Outlook email that is displaying correctly:

    <html><head>

    <meta http-equiv="Content-Type" content="text/html; charset=utf-8"><base href="http://altepm/PWA"></head><body>Hello,<br><br>There is a proposal titled <b>aaatest</b>, created by <b>Al

    EPM Admin</b> submitted for your review. Follow these steps to approve or

    reject the proposal:<ul><li>Click <a href="http://altepm/PWA/projectdrilldown.aspx?projUid=3e68d8f2-467a-4c73-a07b-d7061820da6b">this

    link</a> to view the proposal</li><li>Click the 'Edit this task' button or

    click <a href="http://altepm/PWA/_layouts/pwa/Workflow/ApprovalTask.aspx?List=%7B96e74aa4%2Db9cd%2D40e9%2Da3a9%2D1a5679907a60%7D&amp;ID=125">this

    link</a> to review the approval task assigned to you</li><li>Follow instructions

    in the 'Task Description' section to approve or reject the proposal</li></ul>Thank

    you,<br>Office Server Administrator<br>

        </body></html>

    Here is the HTML i get when i click on view source of the Outlook email that is NOT displaying correctly:

    <html><head>

    <meta http-equiv="Content-Type" content="text/html; charset=utf-8"><base href="http://altepm/PWA"></head><body>Hello,&lt;br /&gt;&lt;br /&gt;There is a proposal titled &lt;b&gt;A4&lt;/b&gt;,

    created by &lt;b&gt;Al EPM Admin&lt;/b&gt; submitted for your review. Follow

    these steps to approve or reject the proposal:&lt;ul&gt;&lt;li&gt;Click &lt;a

    href=&quot;http://altepm/PWA/projectdrilldown.aspx?projUid=335e1488-9385-4073-82be-c5e405801533&quot;&gt;this

    link&lt;/a&gt; to view the proposal&lt;/li&gt;&lt;li&gt;Click the 'Edit

    this task' button or click &lt;a href=&quot;http://altepm/PWA/_layouts/pwa/Workflow/ApprovalTask.aspx?List=%7B96e74aa4%2Db9cd%2D40e9%2Da3a9%2D1a5679907a60%7D&amp;ID=131&quot;&gt;this

    link&lt;/a&gt; to review the approval task assigned to you&lt;/li&gt;&lt;li&gt;Follow

    instructions in the 'Task Description' section to approve or reject

    the proposal&lt;/li&gt;&lt;/ul&gt;Thank you,&lt;br /&gt;Office Server Administrator</body></html>

    Here is the text of the body in the SDK code:

    "Hello,&lt;br /&gt;&lt;br /&gt;There is a proposal titled &lt;b&gt;{0}&lt;/b&gt;, created by &lt;b&gt;{1}&lt;/b&gt; submitted for your review. Follow these steps to approve or reject the proposal:&lt;ul&gt;&lt;li&gt;Click &lt;a href=&quot;{2}&quot;&gt;this link&lt;/a&gt; to view the proposal&lt;/li&gt;&lt;li&gt;Click the &#39;Edit this task&#39; button or click &lt;a href=&quot;{3}&quot;&gt;this link&lt;/a&gt; to review the approval task assigned to you&lt;/li&gt;&lt;li&gt;Follow instructions in the &#39;Task Description&#39; section to approve or reject the proposal&lt;/li&gt;&lt;/ul&gt;Thank you,&lt;br /&gt;Office Server Administrator";

    Monday, October 8, 2012 10:52 AM
  • Sophie:

    It would appear that the system is not merging the arguments correctly based on the source and the results. Were both the working and non-working emails generated to the same user and project? Do you have any non-alphanumeric characters in the resource name or project name that might cause this?


    Gary Chefetz, MCITP, MCP, MVP msProjectExperts
    Project and Project ServerFAQs
    Project Server Help BLOG

    Tuesday, October 9, 2012 10:34 AM
    Moderator