locked
Incidents within the console have the 'last modified date' in US format but 'created date' in UK format. RRS feed

  • Question

  • Hi all. 

    I'm trying to work out how to adjust the 'Last modified date' within an incident view from the SCSM 2016 console as it's displaying in the wrong date\time format.

    All regional settings on the server and the clients are correct.

    Any advice?

    Wednesday, May 1, 2019 7:58 AM

Answers

  • I am also seeing this issue, running SCSM 2016 UR5.

    Edit: Managed to sort it, this seems to be a known issue in 2016 UR5.

    Can be fixed by doing this (as per Microsoft's support page, can't link it)

    The time format in some views, such as Workitems/IncidentManagement/All Incident, is not consistent with the system locale settings. This behavior may occur when you work with views in unsealed Management Packs (MP). To resolve this issue, follow the steps:

    1. Export the Service Manager Incident Management Configuration Library management pack.
    2. Modify the management pack. Locate the "LastModified" column and modify the binding path as follows:

      Before modification
      <mux:Column Name="lastModified" DisplayMemberBinding="{Binding Path=$LastModified$, Mode=OneWay}" Width="150" DisplayName="Header_Last_Modified" Property="$LastModified$" DataType="s:DateTime" />

      After modification
      <mux:Column Name="lastModified" DisplayMemberBinding="{datebinding:DateBinding Path=$LastModified$, Mode=OneWay}" Width="150" DisplayName="Header_Last_Modified" Property="$LastModified$" DataType="s:DateTime" />

    3. Repeat steps 1–2 for columns that are named “LastModified.”
    4. Re-import the modified management pack.
    5. Restart the console.

    Tuesday, September 10, 2019 8:00 AM

All replies

  • Hi,

    Which Service Manager Version and UR are you using?


    Michael Seidl (MVP)

    SYSCTR Senior Consultant, Blogger, CEO

    Blog | Twitter | Facebook | LinkedIn | Xing | Youtube

    Note: Posts are provided "AS IS" without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Monday, May 6, 2019 8:19 PM
  • I am also seeing this issue, running SCSM 2016 UR5.

    Edit: Managed to sort it, this seems to be a known issue in 2016 UR5.

    Can be fixed by doing this (as per Microsoft's support page, can't link it)

    The time format in some views, such as Workitems/IncidentManagement/All Incident, is not consistent with the system locale settings. This behavior may occur when you work with views in unsealed Management Packs (MP). To resolve this issue, follow the steps:

    1. Export the Service Manager Incident Management Configuration Library management pack.
    2. Modify the management pack. Locate the "LastModified" column and modify the binding path as follows:

      Before modification
      <mux:Column Name="lastModified" DisplayMemberBinding="{Binding Path=$LastModified$, Mode=OneWay}" Width="150" DisplayName="Header_Last_Modified" Property="$LastModified$" DataType="s:DateTime" />

      After modification
      <mux:Column Name="lastModified" DisplayMemberBinding="{datebinding:DateBinding Path=$LastModified$, Mode=OneWay}" Width="150" DisplayName="Header_Last_Modified" Property="$LastModified$" DataType="s:DateTime" />

    3. Repeat steps 1–2 for columns that are named “LastModified.”
    4. Re-import the modified management pack.
    5. Restart the console.

    Tuesday, September 10, 2019 8:00 AM