Windows 7 RC causes wireless service and router to hang RRS feed

  • Question

  • Here is an interesting one. I have a home LAN with 8 machines (XP-2000 etc) including a P4 dual boot Vista/Win7RC.
    A mix of Ethernet and Wireless to a D-Link GENII G640T on ADSL2.

    I have carefully checked the behaviour and it occurs when the WIN7RC is wireless into the adsl-router. I haven't yet checked the behaviour via the machine's ethernet.

    I emphasise, no problems with all the other systems rattling along just fine. It only occurs when the WIN7RC is booted and running.

    My 7RC test machine is an up-gunned Dell P4 GX270 4GB RAM 128MB Nvidia 5200 Dual Out, with HDDs, Vista on IDE 0 and WIN7 on IDE 1.
    The wireless aerial is a garden variety external D-Link from USB.

    The WIN7RC is only running windows resources for security with firewall and networking with normal public shares. No foriegn programs, no third party AV or firewall security programs installed at all.

    The RC runs fine network-wise with LAN access and internet surfing for about and hour to an hour and a half. Then suddenly traffic stops. The network icon shows no access. No amount of re-connecting attempts, rebooting, reloading, reinstalling gets the network back. Why you ask? Well that is because the ADSL-Router has siezed and no system can access it. You cannot even log into the router to diagnose a fault. It is completely unresponsive. The lights are on but no one is home. The only remedy is to power off the router and allow it to boot fresh. Once rebooted, the RC machine then picks up the network as do the other machines (without rebooting) and again runs fine for about an hour to an hour and a half. You can practically set your watch by this, it is either an hour or an hour and a half. Then poof! The router seizes again, all network access lost. No ether, no wireless, nothing.

    Emphasis on. ****This behaviour only occurs when the WIN7RC is running. The same machine running its Vista OS causes no such issues.
    I have tested this with another fully functional router and the same event occurs in the same timeframe when running the WIN7RC on wireless.

    My next step is to test and see if it occurs via the ethernet LAN card of the GX270. In the meantime, has anyone one else seen this behaviour or have any pointers to resolution?

    Farel the Sysadmin

    Monday, May 18, 2009 12:39 AM


  • Hi,
    I'm the original question, I disabled IPv6 on both the wireless and ethernet adapters, then neutered it in the win7 registry by creating a disabledcomponents dword value to kill all the processes except loopback. My original problem is gone, The D-Link router is no longer locking up, and the LAN is stable. So my original report at the head of this forum question is now resolved.
    What to do about the ipv6 in win7 is now the network teams problem I guess.
    • Marked as answer by SaMcp1123 Tuesday, June 2, 2009 11:05 PM
    Tuesday, June 2, 2009 10:47 AM

All replies

  • of all post regarding windows 7rc problem with wireless this one is the best!
    I have the same problem with an ACER ASPIRE 5615
    I thought it was impossible but it seems to manifest the same stuuuuupid network failure
    brb later with details!
    Monday, May 18, 2009 10:46 AM
  • I´ve got the same problem. I have Lenovo R61 with type:8933-cto 802.11a/b/g, 802.11b/g Wireless LAN Mini PCI Adapter
    Could not find any network during an hour and half. I have rebooting the machine could not find any wireless. Than i type ipconfig /renew and ipconfig /release by cmd. Than i´ve got back with connection to wireless. But it does the same in during every half or an hour.
    Monday, May 18, 2009 12:34 PM
  • Same type of problem here. My homemade Pentium 4 pc has a D-Link 520 pci card transmitting to a Belkin F5D7230-4. I can't maintain an internet connection more than a few minutes. The built in network problem solver usually repairs the connection for a few minutes, but using the internet on Windows 7 RC is a frustrating experience. I installed W7 on my second pc but I've used it very little because I can't keep connected.
    Monday, May 18, 2009 12:56 PM
  • hi, ive got an acer aspire 5315. used win 7 beta for a while, computer booted up and would connect to belkin n1 vision router, connected fine but no internet access. worked fine with basic vista. never used it since. going to test the rc on a packard bell easynote.
    Monday, May 18, 2009 3:48 PM
  • No routers are designed to work with Windows 7 yet. I can only imagine that it is a compatibility issue with the router itself. I would wait until there are new wireless drivers out on Windows 7 or wait on a router designed for Windows 7.
    • Proposed as answer by Adam M MCP Monday, May 18, 2009 8:05 PM
    • Edited by Adam M MCP Monday, May 18, 2009 10:02 PM didn't mean to propose as answer
    Monday, May 18, 2009 8:05 PM
  • So I''m back
    I have 2 computers
    one is Acer Aspire 5612znwlmi which HAS a broadcom wireless network adapter built-in and it runs with this nice Windows 7RC and looses network connection every15 minutes. No dual boot, Bitdefender as antivirus and firewall so local Defender and Windows Firewall are deactivated (but W7RC showed me a warning in which it stated some incompatibility with BitDfender way of reporting it's current status).
    I tried a solution found on this forum and uninstalled the driver for the wireless adapter which W7RC installed automaticly for me. The sistem freezed completely as soon as I tried to uninstall the driver and I was forced to shut it down by force. Only in safe mode I managed to disable the device and then uninstall it, reboot and install the right driver(I tried the one for Vista ultimate 32). Still the same problem!
    In another room I have a desktop PC made piece by piece by me with a wireless adaptor D-Link DWL-G510 and Vista Home Premium 32: when the W7RC crashes, the Vista looses also the link with the router (D-Link DI-624).
    If I'm not using the W7RC the network stays up and running forever!
    And also I thought it is a problem with uTorrent or the other program I''m usng BitComet, as soon as I start one of those two programms everything crashes, I mean the network connections of course.
    If it helps anyone, I noticed that when the troubleshooter fails, it fails because it wasn't able to reenable te network adapter: in other words it manages to disable the adapter but it fails to enable it, so I have to go to Coputer Manager and enable the network adapter!
    SoMicrosoft guys, try to solve this!
    Monday, May 18, 2009 8:35 PM
  • I have checked the ethernet on thr 7RC machine and there is no problem , it was completely stable for hours last night. But when I went back to wireless, poof! The ADSL router locked up right on the hour mark. Thinking it through on the OSI  it strikes me as an issue somehwere in level 5? What is level 5 ergo- for those who don't know the OSI, quote from wikipedia

    Layer 5: Session Layer

    The Session Layer controls the dialogues (connections) between computers. It establishes, manages and terminates the connections between the local and remote application. It provides for full-duplex , half-duplex , or simplex operation, and establishes checkpointing, adjournment, termination, and restart procedures. The OSI model made this layer responsible for graceful close of sessions, which is a property of the Transmission Control Protocol , and also for session checkpointing and recovery, which is not usually used in the Internet Protocol Suite. The Session Layer is commonly implemented explicitly in application environments that use remote procedure calls ."

    Dear MS techos, somewhere in the session layer for wireless there is a problem with the RC7, lkely driver related.

    anyway thats this sysadmin's best guess to start looking, we will see if they can come up with a fix.

    farel the sysadmin

    Tuesday, May 19, 2009 1:55 AM
  • i have problem is no stable when run full day... sometime need to replug againt usb wifi dongler..... (dlink & belkin testing)
    Tuesday, May 19, 2009 9:37 AM
  • Try to change security settings of your router or of your machine. If you running with security settings to WPA-PSK crypted to TKIP, try to chance to AES crypted with the same Cryptition.

    Tuesday, May 19, 2009 1:18 PM
  • Farel,

    What is the make/model of both routers that you tested with. Can you also paste the output of the following command run on a command prompt.  cmd> "netsh wlan sho dr". During the 1 hour that it takes to lock up the router, what kind of usage is happening on the Win7 RC machine?

    Thanks much,
    Taroon Mandhana [MSFT] 
    Friday, May 22, 2009 9:48 PM
  • iv been running the first beta and the rc and not had any problems with wireless or wiered connections on any ov my systems ? yet and im running xp home xp64pro vista and windows 7 beta as well as the rc runs as well as my vista set up ??

    the rc 7 is running on my hp nx6325 laptop on wireless via a netgear wnr3500 and a wnr 2000 repeater
    the original beta is running on a desk top on a usb wireless g connection
    Sunday, May 24, 2009 4:20 PM
  • I'm having a similar problem and it definitely ONLY happens with Windows 7 on my network. I've been running this router for 2 years and it's been rock solid in a mixed environment of clients XP (2), Vista (2), Mac (1), iPhone (2), AppleTV (1), DVRs (2), that is until I installed Windows 7 RC1.

    Ethernet: Marvell Yukon 88E8056 (built into the Asus P5K motherboard), Driver: Microsoft
    Router: Linksys WRT350N running DD-WRT v24-SP1 firmware
    Cable Modem: RCA DCM425 from Comcast

    Here's what happened:

    1) when I first installed Win7 RC1, it connected to my router, got an IP address via DHCP, created a Network and set it as "home network", everything was fine
    2) upon reboot, it would no longer connect to my LAN, DHCP failed, I could not connect to my router to see what was happeneing
    3) I disabled and re-enabled the Ethernet
    4) Windows 7 created an IPv6 tunnel to my Cable Modem and created a new "public network" with the domain of my provider (comcast.net)
    5) I rebooted my router and still no luck connecting on my local LAN 192.168.1.x, I also could not connect to my router
    6) I discovered that no matter what I tried, I could not get an IP address from the router's DHCP, although my other devices were up and still connecting to the internet, my Win7 PC could not, so I rebooted my router, when it came back up, I discovered that all my settings were lost! It reverted to factory defaults! 
    7) I restored all my settings
    8) I played around by rebooting Win7, and I was able to reproduce the problem, router crashed again
    9) I narrowed it down to IPv6 and the tunnel creation issue above - I completely disabled IPv6 in the registry (disabling it at the network interface is not enough) - this appeared to have fixed the problem as I was able to run for over 10 days without any issues

    Disabling IPv6 definitely added a huge amount of stability compared to before, BUT, it did not completely fix the issue.

    1) Last night I shutdown Windows 7
    2) This morning, I booted up and when it tried to get an IP address via DHCP, it failed and again crashed the router
    3) I rebooted the router and sure enough, all my settings were lost again

    Now, before some of you go off saying that it's my router that's going bad, well, it isn't, because I can reproduce this, all my devices on my network are running fine, then exactly at the time when I boot up Windows7 is when the router goes down (although it keeps routing packets). Also, if you Google this problem, you will see that many others are seeing this issue, on Linksys, D-Link, etc.

    From all of this, my guess is that Windows 7 does something with DHCP that is unlike any other client, and it's causing the DHCP server of the router to crash, and crash hard. Keep in mind that MANY of the worlds home networking routers/wifi use the same open source DHCP server code that is used in DD-WRT, such as Linksys, Netgear, D-Link.

    So although it may or may not be Windows 7 direct problem, for Windows7 users worldwide, this will not be a pleasant experience, especially those who are not experts at this stuff.... the first time they install Windows7, their network may be de-configured and go down and they will have a very poor opinion of Win7 and their experience.

    I hope someone from Microsoft will look into this further.


    • Edited by ixxxion Sunday, May 24, 2009 6:26 PM fixed typo
    Sunday, May 24, 2009 6:21 PM
  • ixxxion/jdreadd,

    Thank  you for the detailed description of the issue. In order for us to investigate this further, we might need your help in enabling some logs on the Windows 7 system and sharing them with us. Meanwhlie, we will also try to see if we can reproduce this issue locally. Is it possible for you to email me at taroonm at microsoft dot com . I can provide you further instructions on enabling the traces as well as the mechanism to upload them to us.  Others, you can also contact me at the above address if you are experiencing the same issue. Once we have investigated the issue, I will respond back on the forum about the details and workarounds.

    Thanks very much in selfhosting Windows 7 and providng feedback.

    Taroon [MSFT]

    Tuesday, May 26, 2009 6:57 PM
  • hi,
    Thanks for selfhosting Windows 7 and providng feedback.
    I am in DHCP team and wanted to investigate on the issue you are facing. In order to figure out the issue I need some traces, please provide me the traces by following the instructions below and then sending them to dhcpblog at microsoft dot com  
    1) Copy-paste the following exact instructions in a dhcptrace.cmd file

    @echo off

    IF "%1" == "-start" (
    netsh dhcpclient trace disable > NUL
    netsh trace stop > NUL
    echo Starting dhcp trace..
    del /Q %TEMP%\DhcpTraces
    echo Creating the folder %TEMP%\DhcpTraces
    mkdir %TEMP%\DhcpTraces
    ipconfig /all > %TEMP%\DhcpTraces\IpConfigStart.txt
    REG QUERY "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion" /v BuildLabEx > %TEMP%\DhcpTraces\BuildLabVersion.txt
    REG QUERY "HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters" /s > %TEMP%\DhcpTraces\TcpIpParametersStart.txt
    REG QUERY "HKLM\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters" /s > %TEMP%\DhcpTraces\TcpIp6ParametersStart.txt
    REG QUERY "HKLM\SYSTEM\CurrentControlSet\Services\Dhcp\Parameters" /s > %TEMP%\DhcpTraces\DhcpParametersStart.txt
    netsh trace start scenario=AddressAcquisition ^
     provider=Microsoft-Windows-TCPIP ^
     provider=Microsoft-Windows-winsock-AFD ^
     provider=Microsoft-Windows-WFP ^
     tracefile=%TEMP%\DhcpTraces\addracq-cap.etl protocol=UDP overwrite=yes report=no capture=yes >> %TEMP%\DhcpTraces\OtherLogs.txt
    netsh dhcpclient trace enable >> %TEMP%\DhcpTraces\OtherLogs.txt
    netsh dhcpclient trace dump
    copy /y %SYSTEMDRIVE%\Windows\System32\Logfiles\WMI\dhcpv4trace.log %TEMP%\DhcpTraces\dhcpv4tracestart.log >> %TEMP%\DhcpTraces\OtherLogs.txt
    copy /y %SYSTEMDRIVE%\Windows\System32\Logfiles\WMI\dhcpv6trace.log %TEMP%\DhcpTraces\dhcpv6tracestart.log >> %TEMP%\DhcpTraces\OtherLogs.txt
    echo Dhcp tracing successfully started
    goto eof


    IF "%1" == "-stop" (
    echo Stopping dhcp trace. Please wait for a few seconds..
    ipconfig /all > %TEMP%\DhcpTraces\IpConfigStop.txt
    REG QUERY "HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters" /s > %TEMP%\DhcpTraces\TcpIpParametersStop.txt
    REG QUERY "HKLM\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters" /s > %TEMP%\DhcpTraces\TcpIp6ParametersStop.txt
    REG QUERY "HKLM\SYSTEM\CurrentControlSet\Services\Dhcp\Parameters" /s > %TEMP%\DhcpTraces\DhcpParametersStop.txt
    netsh dhcpclient trace disable >> %TEMP%\DhcpTraces\OtherLogs.txt
    copy /y %SYSTEMDRIVE%\Windows\System32\Logfiles\WMI\dhcpcsvc.etl %TEMP%\DhcpTraces\dhcpcsvc.etl >> %TEMP%\DhcpTraces\OtherLogs.txt
    copy /y %SYSTEMDRIVE%\Windows\System32\Logfiles\WMI\dhcpcsvc6.etl %TEMP%\DhcpTraces\dhcpcsvc6.etl >> %TEMP%\DhcpTraces\OtherLogs.txt
    copy /y %SYSTEMDRIVE%\Windows\System32\Logfiles\WMI\dhcpqec.etl %TEMP%\DhcpTraces\dhcpqec.etl >> %TEMP%\DhcpTraces\OtherLogs.txt
    netsh dhcpclient trace dump
    copy /y %SYSTEMDRIVE%\Windows\System32\Logfiles\WMI\dhcpv4trace.log %TEMP%\DhcpTraces\dhcpv4traceend.log >> %TEMP%\DhcpTraces\OtherLogs.txt
    copy /y %SYSTEMDRIVE%\Windows\System32\Logfiles\WMI\dhcpv6trace.log %TEMP%\DhcpTraces\dhcpv6traceend.log >> %TEMP%\DhcpTraces\OtherLogs.txt
    netsh trace stop >> %TEMP%\DhcpTraces\OtherLogs.txt
    move /y %TEMP%\DhcpTraces\addracq-cap.etl %TEMP%\DhcpTraces\addracq-cap-uncorrelated.etl >> %TEMP%\DhcpTraces\OtherLogs.txt
    netsh trace correlate %TEMP%\DhcpTraces\addracq-cap-uncorrelated.etl %TEMP%\DhcpTraces\addracq-cap.etl retainpii=yes >> %TEMP%\DhcpTraces\OtherLogs.txt
    echo Dhcp tracing successfully stopped.
    echo Trace Location: %TEMP%\DhcpTraces
    echo Please send this folder to the feature team.
    goto eof


    echo -start : starts the dhcp trace
    echo -stop : stops the dhcp trace
    echo  eg: : dhcptrace -start
    echo  : dhcptrace -stop


    2) Now on a machine where you are able to repro this issue, in an elevated prompt,  please run "dhcptrace.cmd -start"
    3) Repro the issue. Try restarting the machine or do the steps that lead to no IP address. As you said, the machine should not have grabbed the IP.
    4) Wait for 5 mins and then from the elevated command prompt, execute "dhcptrace.cmd -stop"
    5) The log files are copied in %TEMP%\dhcptraces.
    6) Please compress and send us this folder.
    7) Please provide the exact repro steps along with the traces.

    It will be really helpful if you can provide us the above mentioned traces to figure out the exact issue.


    Wednesday, May 27, 2009 8:57 AM
  • hi billshoff,
    I tried to reproduce the issue with the same belkin router but not reproducible. Can you please share the traces with me next time you see this issue(follow the steps as mentioned in my previous reply on this forum). Whenever you lose the internet connectivity, check if you have IP address. Aslo try assigning static IP address on your Win7RC machine and see if you see this issue again.

    Wednesday, May 27, 2009 2:13 PM
  • Hi,
    I'm the original question, I disabled IPv6 on both the wireless and ethernet adapters, then neutered it in the win7 registry by creating a disabledcomponents dword value to kill all the processes except loopback. My original problem is gone, The D-Link router is no longer locking up, and the LAN is stable. So my original report at the head of this forum question is now resolved.
    What to do about the ipv6 in win7 is now the network teams problem I guess.
    • Marked as answer by SaMcp1123 Tuesday, June 2, 2009 11:05 PM
    Tuesday, June 2, 2009 10:47 AM
  • Me again, having spent a couple of minutes thinking it over, it might be wise to pursue a firmware upgrade on the router to see if the compatibility problem with ipv6 in win7 is localised there. Might not be win7s issue at all. Could be a latent firmware problem on certain routers?
    I'll up the firmware on the router, (there is a one stepup upgrade for the G640TGenII model from D-Link) renable ipv6 in win7,,, and see what happens. win7 may be the innocent victim here. My Lan IPs are static and hence more stable then the dhcp issues discussed above. So my bet is its the router firmware interacting with win7. Bearing in mind Vista doesn't have the problem, and the adapter drivers in use are identical anyway.

    the sysadmin
    Tuesday, June 2, 2009 11:08 AM
  • Not sure if this thread has gone quiet, but I have the exact same problem with a Belkin N1 Vision Router / Modem.  It was mostly rock solid before the Win 7 64 install.  Interestingly, I am also struggling with Remote Desktop (from win7 to win7, or even XP to win7).  It seems to cause similar problems if not the exact same, although I solved that by using other software.  I have moved to the free router/modem provided by my ISP and the problem has gone.

    One question - How do I go about disabling IPv6 as described by Farel above? Is there a layman's description?  I'm not stupid with PC's...but definitely not brave enough to tinker with the registry - which is what I thought his solution implies.



    Sunday, June 28, 2009 5:56 PM
  • The thread may be quiet but not dead, turns out firmware upgrades for routers, disabling ipv6, and anything else one might try,, the problem remains intransigent. Generally around net blogs other than this the issue is well represented. I can only take it as the 7 team must be working a fix. The problem is restricted to wireless, no problems with ethernet. And its only Win7RC that does it as originally described.
    • Proposed as answer by pcfella Monday, October 19, 2009 3:47 PM
    Tuesday, June 30, 2009 12:01 AM
    • Proposed as answer by pcfella Monday, October 19, 2009 3:47 PM
    Monday, October 19, 2009 3:47 PM